Bug 904028 - [WHQL][netkvm]Windows 2012 got BSOD while running job 1091NDISTest 6.0 - [1 Machine] - 1c_Mini6Send on HCK
[WHQL][netkvm]Windows 2012 got BSOD while running job 1091NDISTest 6.0 - [1 M...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Dmitry Fleytman
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 04:53 EST by Min Deng
Modified: 2014-01-01 11:43 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:43:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Just a screenshot for bsod (31.51 KB, image/png)
2013-01-25 04:53 EST, Min Deng
no flags Details
BSOD (49.27 MB, application/zip)
2013-01-25 05:15 EST, Min Deng
no flags Details
the latest one (49.65 MB, application/x-zip-compressed)
2013-02-04 21:12 EST, Min Deng
no flags Details

  None (edit)
Description Min Deng 2013-01-25 04:53:00 EST
Created attachment 687370 [details]
Just a screenshot for bsod

Description of problem:
[WHQL][netkvm]Windows 2012 got BSOD while running job 1091NDISTest 6.0 - [1 Machine] - 1c_Mini6Send on HCK

Version-Release number of selected component (if applicable):
virtio-win-prewhql-01-52

How reproducible:
3 times 3 failed
Steps to Reproduce:
1.boot up guest with virtio nic driver installed
  root     12223 54.5 39.1 6883296 6347076 pts/14 Sl+ 13:27  94:26 /usr/libexec/qemu-kvm -M rhel6.4.0 -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2012-nic1.raw,format=raw,if=none,id=drive-virtio0,boot=on,cache=none,werror=stop,rerror=stop -device ide-drive,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:52:15:70:31:48,bus=pci.0,addr=0x4 -boot c -uuid e43bbff3-d9a6-4ceb-beb4-86553ada0c3e -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/win2012-e1000-49-1,server,nowait -mon chardev=111a,mode=readline -name win2012-nic-49-1 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup-private,downscript=no -device e1000,netdev=hostnet1,id=net1,mac=00:62:12:26:33:48,bus=pci.0,addr=0x7 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -vnc :1 -vga cirrus
root     12257  8.8 38.2 6883292 6196716 pts/15 Sl+ 13:27  15:19 /usr/libexec/qemu-kvm -M rhel6.4.0 -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2012-nic2.raw,format=raw,if=none,id=drive-virtio0,boot=on,cache=none,werror=stop,rerror=stop -device ide-drive,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:54:61:36:53:48,bus=pci.0,addr=0x4 -boot c -uuid df2cf58b-a3fc-4cd8-8bc8-48c85b26b317 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/win2012-nic-e1000-2,server,nowait -mon chardev=111a,mode=readline -name win2012-nic-e1000-2 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup-private,downscript=no -device e1000,netdev=hostnet1,id=net1,mac=00:47:60:46:36:38,bus=pci.0,addr=0x7 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -vnc :2 -vga cirrus
2.submit job - 1091NDISTest 6.0 - [1 Machine] - 1c_Mini6Send

Actual results:
The job always failed 

Expected results:
The job can pass without any errors.

Additional info:
Upload the screenshot and dump after a while
Comment 2 Min Deng 2013-01-25 05:15:01 EST
Created attachment 687386 [details]
BSOD
Comment 5 Yan Vugenfirer 2013-01-29 07:02:28 EST
Related bug #867314 (Windows 2008 64bit).
Comment 8 Min Deng 2013-02-04 21:00:53 EST
Hi all,

   The bug still can be reproduced via build 53,so please double check the issue.
Thanks,
Min
Comment 9 Min Deng 2013-02-04 21:12:24 EST
Created attachment 693118 [details]
the latest one
Comment 10 Yan Vugenfirer 2013-02-05 05:02:25 EST
Hi,

Looks like an additional issue - Dima is handling it now.

Thanks,
Yan.
Comment 11 Yan Vugenfirer 2013-02-05 07:57:11 EST
Committed the fix.
Comment 12 Ronen Hod 2013-02-05 09:37:14 EST
Defered to 6.5. We decided to use a Previous build (build 49) for this driver.
Comment 13 Yan Vugenfirer 2013-02-06 04:10:49 EST
(In reply to comment #12)
> Defered to 6.5. We decided to use a Previous build (build 49) for this
> driver.
It should have the same issue on HCK.
Comment 15 Mike Cao 2013-02-07 09:29:46 EST
Reproduced this issue on build52 
Verified this issue on build 54 

Steps same as comment #0

Actual Results:
No BSOD occurs when running NDIS 1c_Mini6Send job

Based on above ,this issue has been fixed ald in build 54
Comment 18 Mike Cao 2013-04-01 04:34:50 EDT
According to comment #15 ,move status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.