Bug 904096 - nova has missing dependency on python-iso8601
nova has missing dependency on python-iso8601
Status: CLOSED DUPLICATE of bug 881515
Product: Fedora
Classification: Fedora
Component: python-novaclient (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 07:44 EST by Need Real Name
Modified: 2013-01-25 08:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-25 08:30:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2013-01-25 07:44:38 EST
]$ nova
Traceback (most recent call last):
  File "/usr/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.10.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2311, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2017, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/novaclient/shell.py", line 37, in <module>
    from novaclient.v1_1 import shell as shell_v1_1
  File "/usr/lib/python2.7/site-packages/novaclient/v1_1/shell.py", line 27, in <module>
    from novaclient.openstack.common import timeutils
  File "/usr/lib/python2.7/site-packages/novaclient/openstack/common/timeutils.py", line 25, in <module>
    import iso8601
ImportError: No module named iso8601

# yum install python-iso8601 -y

$ nova
# works!
Comment 1 Alan Pevec 2013-01-25 08:30:37 EST

*** This bug has been marked as a duplicate of bug 881515 ***

Note You need to log in before you can comment on or make changes to this bug.