Bug 904222 - augeas-libs-1.0.0-1.el5 update prevents setting /etc/sysconfig/network
augeas-libs-1.0.0-1.el5 update prevents setting /etc/sysconfig/network
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: augeas (Show other bugs)
el5
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 906361 (view as bug list)
Depends On:
Blocks: 920609
  Show dependency treegraph
 
Reported: 2013-01-25 14:22 EST by Nick Vatamaniuc
Modified: 2013-08-16 15:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: augeas-1.0.0-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 22:00:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Vatamaniuc 2013-01-25 14:22:15 EST
Description of problem:

augeas cannot see /etc/sysconfig/network settings file anymore.

augtool> ls /files/etc/sysconfig/network

shows nothing


Version-Release number of selected component (if applicable):

1.0.0-1.el5

How reproducible:

consistent


Steps to Reproduce:
1. augtool> ls /files/etc/sysconfig/network
2.
3.
  
Actual results:

<no result>

Expected results:



Additional info:

How to fix it:


(using Python)
{{{
>>> from augeas import Augeas
>>> a = Augeas(root='/', flags=Augeas.NO_LOAD)
>>> a.remove("/augeas/load/Shellvars/excl[.='/etc/sysconfig/network']")
1
>>> a.load()
>>> a.match('/files/etc/sysconfig/network')
['/files/etc/sysconfig/network']
}}}

(Thank Dominic from #augeas on freenode)
Comment 1 Jaromír Cápík 2013-01-28 11:34:04 EST
Hello Nick.

It seems you accidently chose a wrong component. Switching from 'atomix' to 'augeas'.

Regards,
Jaromir.
Comment 2 Nick Vatamaniuc 2013-01-28 21:21:48 EST
Hi Jaromir,

Yes I meant 'augeas', thank you for correcting it.
Comment 3 mleary 2013-01-30 19:54:22 EST
This update also breaks puppet (epel version).  Since updating all our puppet manifests which use augeas fail with:

Could not evaluate: unknown error - Failed to initialize Augeas

So I'm guessing this extends beyond the sysconfig lens.
Comment 4 Dominic Cleal 2013-01-31 09:05:36 EST
(In reply to comment #3)
> This update also breaks puppet (epel version).  Since updating all our
> puppet manifests which use augeas fail with:
> 
> Could not evaluate: unknown error - Failed to initialize Augeas
> 
> So I'm guessing this extends beyond the sysconfig lens.

That's a different issue, this describes a problem with one particular file.

Sounds like bug #901663, restart the puppet agent.
Comment 5 mleary 2013-01-31 09:16:10 EST
You are right - thanks.
Comment 6 Dominic Cleal 2013-03-21 19:18:29 EDT
Fixed upstream: https://github.com/hercules-team/augeas/commit/d6959e62
Comment 8 Fedora Update System 2013-06-18 11:12:33 EDT
augeas-1.0.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/augeas-1.0.0-4.fc19
Comment 9 Fedora Update System 2013-06-18 11:12:44 EDT
augeas-1.0.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/augeas-1.0.0-4.fc18
Comment 10 Fedora Update System 2013-06-18 11:12:51 EDT
augeas-1.0.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/augeas-1.0.0-4.fc17
Comment 11 Fedora Update System 2013-06-18 11:13:00 EDT
augeas-1.0.0-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/augeas-1.0.0-4.el5
Comment 12 Fedora Update System 2013-06-18 15:42:33 EDT
Package augeas-1.0.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing augeas-1.0.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11182/augeas-1.0.0-4.fc19
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-06-19 05:36:13 EDT
augeas-1.1.0-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/augeas-1.1.0-1.el5
Comment 14 Fedora Update System 2013-06-19 05:36:41 EDT
augeas-1.1.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/augeas-1.1.0-1.fc19
Comment 15 Fedora Update System 2013-06-19 05:37:09 EDT
augeas-1.1.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/augeas-1.1.0-1.fc18
Comment 16 Fedora Update System 2013-06-26 22:00:06 EDT
augeas-1.0.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Dominic Cleal 2013-06-27 03:57:49 EDT
*** Bug 906361 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2013-07-09 21:21:47 EDT
augeas-1.1.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-08-15 19:28:15 EDT
augeas-1.1.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-08-16 15:54:36 EDT
augeas-1.1.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.