Bug 904287 - [abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:1182:_parseRepoXML:RepoError: Error importing repomd.xml from google-chrome: Damaged repomd.xml file
[abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:1182:_parseRepoXML:RepoError: Erro...
Status: CLOSED DUPLICATE of bug 880722
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:73c47e542a3a11af4edf4293160...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 18:59 EST by Malar Kannan
Modified: 2013-02-01 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 10:15:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.31 KB, text/plain)
2013-01-25 18:59 EST, Malar Kannan
no flags Details
File: core_backtrace (802 bytes, text/plain)
2013-01-25 18:59 EST, Malar Kannan
no flags Details
File: environ (3.21 KB, text/plain)
2013-01-25 18:59 EST, Malar Kannan
no flags Details
File: smolt_data (3.63 KB, text/plain)
2013-01-25 18:59 EST, Malar Kannan
no flags Details

  None (edit)
Description Malar Kannan 2013-01-25 18:59:19 EST
Description of problem:
reposync problem

Version-Release number of selected component:
yum-utils-1.1.31-6.fc18

Additional info:
cmdline:        /usr/bin/python -tt /usr/bin/reposync --arch=x86_64 --gpgcheck --newest-only --plugins --downloadcomps
dso_list:       yum-3.4.3-47.fc18.noarch
executable:     /usr/bin/reposync
kernel:         3.7.2-204.fc18.x86_64
uid:            1000

Truncated backtrace:
yumRepo.py:1182:_parseRepoXML:RepoError: Error importing repomd.xml from google-chrome: Damaged repomd.xml file

Traceback (most recent call last):
  File "/usr/bin/reposync", line 352, in <module>
    main()
  File "/usr/bin/reposync", line 169, in main
    my.doRepoSetup()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 671, in doRepoSetup
    return self._getRepos(thisrepo, True)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 723, in _getRepos
    self._repos.doSetup(thisrepo)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 138, in doSetup
    self.retrieveAllMD()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 84, in retrieveAllMD
    dl = repo._async and repo._commonLoadRepoXML(repo)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1380, in _commonLoadRepoXML
    self._repoXML = self._parseRepoXML(result)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1182, in _parseRepoXML
    raise Errors.RepoError, 'Error importing repomd.xml from %s: %s' % (self.ui_id, e)
RepoError: Error importing repomd.xml from google-chrome: Damaged repomd.xml file

Local variables in innermost frame:
local: '/var/tmp/yum-malar-bdSPHH/google-chrome/repomd.xml'
self: <yum.yumRepo.YumRepository object at 0x2b09e10>
e: RepoMDError()
parse_can_fail: False
Comment 1 Malar Kannan 2013-01-25 18:59:23 EST
Created attachment 687751 [details]
File: backtrace
Comment 2 Malar Kannan 2013-01-25 18:59:25 EST
Created attachment 687752 [details]
File: core_backtrace
Comment 3 Malar Kannan 2013-01-25 18:59:28 EST
Created attachment 687753 [details]
File: environ
Comment 4 Malar Kannan 2013-01-25 18:59:31 EST
Created attachment 687754 [details]
File: smolt_data
Comment 5 Zdeněk Pavlas 2013-02-01 10:15:40 EST
Likely a dupe.  Please reopen if you can reproduce it in yum-utils-1.1.31-7.fc18

*** This bug has been marked as a duplicate of bug 880722 ***

Note You need to log in before you can comment on or make changes to this bug.