Bug 90497 - chkconfig core dump listing xinetd services
chkconfig core dump listing xinetd services
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: chkconfig (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-05-08 17:22 EDT by Jonathan Kamens
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 13:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-05-08 17:22:15 EDT
jik:/tmp!1001$ sudo chkconfig --list
Password:
ntpd            0:off   1:off   2:on    3:on    4:on    5:on    6:off
...
dhcrelay        0:off   1:off   2:off   3:off   4:off   5:off   6:off
xinetd based services:
Segmentation fault (core dumped)
jik:/tmp!1004$ sudo gdb /sbin/chkconfig core
GNU gdb Red Hat Linux (5.3post-0.20021129.29rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols 
found)...
Core was generated by `chkconfig --list'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/i686/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/i686/libc.so.6
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x400a0753 in strlen () from /lib/i686/libc.so.6
(gdb) where
#0  0x400a0753 in strlen () from /lib/i686/libc.so.6
#1  0x4006ffee in vfprintf () from /lib/i686/libc.so.6
#2  0x400783f2 in printf () from /lib/i686/libc.so.6
#3  0x08049ee5 in strcpy ()
#4  0x0804a3e1 in strcpy ()
#5  0x4003b8c7 in __libc_start_main () from /lib/i686/libc.so.6
(gdb) 

Looks like the stack is corrupt.  If you can't reproduce this, let me know and 
I can try running under a debugger or something to get more information.
Comment 1 Bill Nottingham 2003-05-18 20:21:13 EDT
Exactly which n-v-r of chkconfig?
Comment 2 Jonathan Kamens 2003-05-18 20:26:14 EDT
Alas, I've updated since then so I'm not certain.  It was a version that I
installed, probably from Raw Hide, on February 2, so if I had to guess, I'd say
1.3.8-1.

Now, with 1.3.8-2, I get something different (but no more useful):

$ sudo chkconfig --list
... various lines ...
dhcrelay        0:off   1:off   2:off   3:off   4:off   5:off   6:off
error reading from directory /etc/init.d: No such file or directory$ 

Note that there's no newline at the end of the output -- the dollar sign at the
end of the last line is the shell prompt.
Comment 3 Bill Nottingham 2003-05-18 23:34:17 EDT
Do you have any subdirectories (or other nonstandard FS structures) in
/etc/init.d or /etc/xinetd.d?
Comment 4 Jonathan Kamens 2003-05-19 09:15:32 EDT
I have RCS subdirectories in both /etc/init.d and /etc/xinetd.d (I RCS config 
files which I modify).  Surely chkconfig should be able to handle this case....
Comment 5 Bill Nottingham 2003-10-22 16:53:07 EDT
Hm, I'm trying this here and it's working for me. Can you tar up your
/etc/xinetd.d/ directory?
Comment 6 Jonathan Kamens 2003-10-23 13:01:13 EDT
I can't duplicate it any longer with chkconfig-1.3.8-4.

Note You need to log in before you can comment on or make changes to this bug.