Bug 90516 - shift key no longer recognized as modifier to function keys
shift key no longer recognized as modifier to function keys
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
: 112977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 02:08 EDT by Ivo Gough Eschrich
Modified: 2015-01-07 19:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 08:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Gough Eschrich 2003-05-09 02:08:45 EDT
Description of problem:
I use the shift key as modifier to certain function keys to access emacs
functions. The key combinations are defined in .emacs aka .xemacs/init.el for
example: (global-set-key '(shift f9) 'query-replace)
The xemacs version shipped with RedHat 9 does not register the shift key as
a modifier.

Version-Release number of selected component (if applicable):
XEmacs 21.4 (patch 12) "Portable Code" [Lucid] (i386-redhat-linux, Mule) of Thu
Feb 20 2003 on porky.devel.redhat.com

How reproducible:
always, even if global-set-key directive is absent.

Steps to Reproduce:
1. open xemacs
2. type 'Ctrl-h k' to invoke key function dictionary
3. type 'Shift-f9' etc
    
Actual results:
xemacs returns info for f9, not Shift-f9

Expected results:
should return info for Shift-f9

Additional info:
switching off default gnome desktop shortcuts did not make a difference.
.Xmodmap is loaded and respected. .Xdefaults is ignored, however that should
not make a difference in my case.
have not tried running under KDE.
Comment 1 Jens Petersen 2003-05-19 04:43:08 EDT
Reproduced.
Comment 2 Jens Petersen 2003-10-17 08:38:33 EDT
Still present in xemacs-21.4.14.
Comment 3 Jens Petersen 2004-01-15 00:22:32 EST
*** Bug 112977 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.