Bug 905203 - glusterfs 3.3.1 volume heal data info <something> not accurate.
glusterfs 3.3.1 volume heal data info <something> not accurate.
Status: CLOSED DUPLICATE of bug 864963
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 15:41 EST by Rob.Hendelman
Modified: 2013-03-22 01:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 01:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob.Hendelman 2013-01-28 15:41:59 EST
Description of problem:
output from checking heal status doesn't seem to be accurate.

Version-Release number of selected component (if applicable):
3.3.1

How reproducible:
Tried test just once.

Steps to Reproduce:
1. Setup 3 node (1 brick each) replicate cluster with the following settings:
Options Reconfigured:
performance.cache-size: 1073741824
performance.io-thread-count: 24
nfs.disable: on
network.ping-timeout: 5
cluster.stripe-block-size: 524288
cluster.min-free-disk: 5%
cluster.data-self-heal-algorithm: diff
cluster.self-heal-window-size: 512
cluster.quorum-count: 2
cluster.quorum-type: fixed

2.  Start rsync from client to filesystem.
3. Bring node 1 down for 5-10 minutes.
4. Bring node 1 back up
5. Bring node 2 down for 5-10 minutes.
6. Bring node 2 back up
7. Bring node 3 down for 5-10 minutes.
8. Bring node 3 back up.
9. Start & stop rsync a few times as a user might when testing/changing options.
  
Actual results:

Files seem to heal but "gluster volume heal newdata info heal-failed" and "split-brain" return a bunch of results.

Trying an "rsync -avcnP /mnt/gluster/bricks/1/home/ root@server:/mnt/gluster/bricks/1/home" (dry run,via checksum) returns nothing to be done so it looks like the data is actually synched.

Expected results:
I'd expect after the heal has finished to show nothing in heal-failed or split-brain.

Additional info:
This is my first-try using a quorum of 2 out of 3 nodes.  It seems taht the heal-failed/split-brain simply pulls info from logs but doesn't show what the current state is.  Is this expected?
Comment 1 Pranith Kumar K 2013-03-22 01:50:21 EDT

*** This bug has been marked as a duplicate of bug 864963 ***

Note You need to log in before you can comment on or make changes to this bug.