Bug 905238 - Icons created by virt inspector interface not used by anyone
Icons created by virt inspector interface not used by anyone
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 979979
  Show dependency treegraph
 
Reported: 2013-01-28 17:54 EST by Tom Horsley
Modified: 2013-07-02 07:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 979979 (view as bug list)
Environment:
Last Closed: 2013-06-29 14:14:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The virt-inspector -d output for a windows XP virtual machine (98.91 KB, text/plain)
2013-01-28 17:54 EST, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2013-01-28 17:54:29 EST
Created attachment 689418 [details]
The virt-inspector -d output for a windows XP virtual machine

Description of problem:

In my quest to understand where the guestfs-whatever transient virtual
machine were coming from, I started this thread:

http://lists.fedoraproject.org/pipermail/virt/2013-January/003550.html

Near the end I was asked to submit a bug report about the icons
(at least I think that's what I was asked :-), so this is it.

The virt-inspector tool does indeed create an icon and embed it in the
xml. If I base64 decode it, it is even a png of a windows wavy flag,
which is probably what it should be for a windows xp virtual machine.

But, after going to all that trouble, virt-manager doesn't show it
anywhere that I can see. It isn't on the main window, and if I open
a VM, it isn't on the overview page. I couldn't think of any place else
to look for it.


Version-Release number of selected component (if applicable):
Here's all the packages with "virt" in the name:

libvirt-daemon-driver-secret-0.10.2.2-3.fc18.x86_64
libvirt-daemon-0.10.2.2-3.fc18.x86_64
virt-viewer-0.5.4-3.fc18.x86_64
virtuoso-opensource-6.1.6-1.fc18.x86_64
libvirt-0.10.2.2-3.fc18.x86_64
virt-top-1.0.8-3.fc18.x86_64
libvirt-daemon-driver-uml-0.10.2.2-3.fc18.x86_64
python-virtinst-0.600.3-2.fc18.noarch
libvirt-daemon-driver-nwfilter-0.10.2.2-3.fc18.x86_64
libvirt-gconfig-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-network-0.10.2.2-3.fc18.x86_64
perl-Sys-Virt-0.10.2-1.fc18.x86_64
libvirt-daemon-qemu-0.10.2.2-3.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-xen-0.10.2.2-3.fc18.x86_64
libvirt-gobject-0.1.5-1.fc18.x86_64
libvirt-client-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.2.2-3.fc18.x86_64
libvirt-python-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-storage-0.10.2.2-3.fc18.x86_64
virt-manager-0.9.4-4.fc18.noarch
libvirt-daemon-config-network-0.10.2.2-3.fc18.x86_64
libvirt-daemon-kvm-0.10.2.2-3.fc18.x86_64
libvirt-glib-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-interface-0.10.2.2-3.fc18.x86_64
redland-virtuoso-1.0.15-2.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.2.2-3.fc18.x86_64
virt-manager-common-0.9.4-4.fc18.noarch


How reproducible:
every time I run virt-manager

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
icon in the xml, no icon on the screen

Expected results:
visible icon somewhere?

Additional info:
Comment 1 Richard W.M. Jones 2013-01-28 18:12:05 EST
$ base64 -di > icon.png 
iVBORw0KGgoAAAANSUhEUgAAABkAAAAUCAIAAAD3FQHqAAAD/klEQVQ4jbXUW0yTZxgH8C4c
Bo+ddMwEUQPBSUsppUcqUA4tFCoN0pYzCFjoutiFjiFgCbTQWhmxFsEDW2SCskghKCxDo7i5
sJGRILIlw02RRcPF1pGMDZk64zw8e63xxn1btov9L97LX97n/3zfS6P9T0FXCu4XYpcET2Th
qSJsYv78DtukTpZKpf8NWu3fja0stGxCx3oc0uBQySMDfU65ZkK5Sfo8/9a635mLNiaag9C1
BT+uwqOyO6XwZSLYs/mpleKdfTHmbgXhwsLCXBfkx2Yy/onGtji0s7CJge+J8JwRW5keLVyQ
0EsqZElvBOq7/PZNhLpmQ7sXNnzgWffuFbpEIqGGlj5sQns0tm5G2zrsz8SRSjQFzythIC08
oVCoMNJqTwXapqBzAXpXoGcZat1r+Xw+tXXvgAL3srExGJ0b8KMC7FM82AmXk8CZJ9lazlLX
+zSehbZZOLIIfavQdQsMdjaHw6G2POaw7w30qzm0YX1kr0l5Xh06xaP1B9Pe3CFNf+s13X5/
y6fgnIP3PdD3GzhmILdcGh0d/bd96Ros2VUt2vqBHLNbUtioVcgL5JzUYomymlZ7MtA2CQfn
4fgv0LsKe0YYSSmS2NhYCsV8eGWbdTGzdkVjRecg9o5hmeWhOHcprsgsKGZr6+mmQbBNQ8dN
6F6G9muv6Jq5bDabuq+6Q/crHKg2Y3UHui/hkVHcYX4iUvwglu/V7359V0OM3hirN3Nq2nh1
9hiHnavZnsBisXg8HoVlaPtDtw/zmrHpGI5Ooq0XNcbfY6U3E/LV/Y6XZgfXzg5FnD65ZXyI
OX8p/MFlRllhfGRkJIVVYDhdZH1caMUyO7oGcXgCazpQUXqbn/hFWoV42On79RB4LsKTrwCv
Ad6AG+fWi4QxTCaTwqqqmy2xoroRjR048BmeuIiVrRivWhKkHny7IeL80YDro/Dr54DfAF5/
yrkPi6KiosgHQdFXcd1Ppc2P8/Y82mVdthzw1Dju5lffE8gWxdkVPW1+k31w6yzcnQL81mvN
gaUujcvlkiVSWFJDfqm+PEOTkVWQlaRMSt2WmZA9wU4ZVekUZ1x+V9zw4zg8nPEOuAB3ptcU
58uEQqFYLI6Li3vREivEQa8GBUDAxrCNfv5+/i/7M3lMVZEqz8QdORT03Rm4TQa8+hQil/qk
P0YqTdjqjUgketEKCQlJlCeq8lTaci2DwfDx8fH19ZXlyMK14SqjxNHIG+8JmXYHuzs3V1fx
5LJ48kvHe0PxTrS3txu8aelqIadSqWTz2PJsOTeRS54XUvOzdkjI4sh0ZDQCEZHCGhsbMzxP
eno6OZOTk8nKdTpdREQE2Rch+N4IBAJSE5nu2aX+av0JMGKmahyMK+oAAAAASUVORK5CYII=
$ file icon.png 
icon.png: PNG image data, 25 x 20, 8-bit/color RGB, non-interlaced

It could be because the icon is too small for virt-manager
to display?  It does appear that libguestfs is creating a
valid PNG file however.
Comment 2 Richard W.M. Jones 2013-01-28 18:31:42 EST
I don't see any "minimum size" or similar in the code.  The
code does try to resize the icon down to 16x16 for display
in the main manager window:

http://git.fedorahosted.org/cgit/virt-manager.git/tree/src/virtManager/manager.py#n936
Comment 3 Cole Robinson 2013-06-13 15:55:13 EDT
Fixed upstream:

commit 91a97d439c97f0945b3caff3336119ede4a75ed6
Author: Cole Robinson <crobinso@redhat.com>
Date:   Thu Jun 13 15:54:12 2013 -0400

    manager: Fix loading libguestfs OS icons (bz 905238)
Comment 4 Fedora Update System 2013-06-19 19:00:47 EDT
virt-manager-0.10.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-1.fc19
Comment 5 Fedora Update System 2013-06-20 14:00:12 EDT
Package virt-manager-0.10.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11349/virt-manager-0.10.0-1.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-29 14:14:12 EDT
virt-manager-0.10.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.