Bug 90529 - xclock can't be switched to using alt-tab
xclock can't be switched to using alt-tab
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 09:13 EDT by Miloslav Trmac
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 14:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2003-05-09 09:13:40 EDT
Version-Release number of selected component (if applicable):
metacity-2.4.34-3.
XFree86-4.3.0-2

Steps to Reproduce:
1. Start xclock
2. Notice it appears in the task list applet on the panel
3. Unsuccessfuly try to switch to it using alt-tab
    
This might as well be because the xclock utility doesn't behave.
I don't really care whether this works, but the inconsistency
between task list applet and metacity might matter.
Comment 1 Havoc Pennington 2003-05-09 11:29:39 EDT
This is why:

Thu Dec  5 18:41:02 2002  HideToshi Tajima  <hidetoshi.tajima@sun.com>

	* src/window.h (META_WINDOW_IN_NORMAL_TAB_CHAIN,
	META_WINDOW_IN_DOCK_TAB_CHAIN) : never use a window with input =
	FALSE take_focus = FALSE in the	normal and dock tab chains. #90409

You can see bugzilla.gnome.org bug 90409 for the full analysis.
Comment 2 Miloslav Trmac 2003-05-13 11:24:43 EDT
Havoc,
Thanks, so it is by design.
I was trying to use Alt-Tab not for the focus, but
to raise the window; A similar comment in the gnome
bug was not answered either.

Anyway, feel free to close this bug if you don't feel
like reverting the change. I've observed it
only on xclock and ghostscript output window,
both have a more GNOME-ish replacement.
Thanks.
Comment 3 Havoc Pennington 2003-05-13 14:43:37 EDT
I think the current setup suboptimal, but I don't really know any way to 
fix it, so I think it's the best we can get. We might want to fix 
xclock to accept focus, perhaps.

Note You need to log in before you can comment on or make changes to this bug.