Bug 905306 - Fedora 18 DVD installer limits choice of desktop environments
Summary: Fedora 18 DVD installer limits choice of desktop environments
Status: CLOSED DUPLICATE of bug 875433
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-29 06:18 UTC by Nandan Bhat
Modified: 2013-01-30 04:45 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-01-29 14:46:04 UTC


Attachments (Terms of Use)

Description Nandan Bhat 2013-01-29 06:18:37 UTC
Description of problem:
Unable to select multiple desktop environments for installation in DVD edition

Version-Release number of selected component (if applicable):
Fedora 18 x86_64 DVD installer

How reproducible:
Every time

Steps to Reproduce:
1. Boot with x86_64 DVD installer
2. Proceed to package selection.
3. Installer limits choice to either GNOME, KDE, LXDE, XFCE desktop environments
  
Actual results:
Limitation on choice of desktop environments

Expected results:
Flexibility in choosing desktop environments (or any other software)

Additional info:
This limitation makes downloading the DVD edition a waste of bandwidth (expensive in India). After install, not everyone would be capable of setting up yum with DVD repository instead of the standard fedora and updates repositories. Many packages (already present in the DVD) would still get downloaded from the internet.

Comment 1 Chris Lumens 2013-01-29 14:46:04 UTC

*** This bug has been marked as a duplicate of bug 875433 ***

Comment 2 Steve Tyler 2013-01-29 14:59:23 UTC
The network install CD will automatically show more desktop environments:
https://fedoraproject.org/en/get-fedora-options#formats

Comment 3 Andre Robatino 2013-01-30 04:45:08 UTC
It's not that hard to set up the DVD image as a repo after installation (although I agree that the installer should not cripple the install images in this way, but unfortunately the anaconda devs are determined to do that). See https://bugzilla.redhat.com/show_bug.cgi?id=888307#c8 which works if you copy the DVD image to the HDD after installation and loop mount it. Also be warned that in F19, the DVD will probably default to downloading updates rather than using the packages on the DVD itself - see bug 889366 - so in order to be able to use all of the packages on the DVD after installation, you will then have to change the default setting for that as well.


Note You need to log in before you can comment on or make changes to this bug.