Bug 905359 - ovirt-cli quits with DistributionNotFound exception on fedora18
ovirt-cli quits with DistributionNotFound exception on fedora18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ovirt-engine-cli (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
infra
: Reopened
: 908791 (view as bug list)
Depends On: 881011
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 04:12 EST by Sander Hoentjen
Modified: 2013-04-19 21:18 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 881011
Environment:
Last Closed: 2013-02-09 06:30:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10922 None None None Never

  None (edit)
Description Sander Hoentjen 2013-01-29 04:12:13 EST
+++ This bug was initially created as a clone of Bug #881011 +++

Description of problem:
on fedora18, ovirt-shell quits with an exception

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install fedora+ovirt 
2.run ovirt-shell
3.
  
Actual results:
error is being thrown:
Traceback (most recent call last):
  File "/usr/bin/ovirt-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2815, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pexpect<=2.3



Expected results:
system should enter the CLI

Additional info:

--- Additional comment from Michael Pasternak on 2012-11-28 08:05:31 EST ---

(In reply to comment #0)
> Description of problem:
> on fedora18, ovirt-shell quits with an exception
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1.install fedora+ovirt 
> 2.run ovirt-shell
> 3.
>   
> Actual results:
> error is being thrown:
> Traceback (most recent call last):
>   File "/usr/bin/ovirt-shell", line 5, in <module>
>     from pkg_resources import load_entry_point
>   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2815, in
> <module>
>     working_set.require(__requires__)
>   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in
> require
>     needed = self.resolve(parse_requirements(requirements))
>   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in
> resolve
>     raise DistributionNotFound(req)
> pkg_resources.DistributionNotFound: pexpect<=2.3
> 
> 
> 
> Expected results:
> system should enter the CLI
> 
> Additional info:

how it's possible? i tested it on clean f18! does your yum.repos configured properly?

--- Additional comment from Ohad Basan on 2012-11-28 08:42:12 EST ---

yes they are.

[ovirt-nightly]
name=Nightly builds of the oVirt project
baseurl=http://ovirt.org/releases/nightly/rpm/Fedora/17/
enabled=1
skip_if_unavailable=1
gpgcheck=0

--- Additional comment from Michael Pasternak on 2012-11-28 08:49:35 EST ---

(In reply to comment #2)
> yes they are.
> 
> [ovirt-nightly]
> name=Nightly builds of the oVirt project
> baseurl=http://ovirt.org/releases/nightly/rpm/Fedora/17/
> enabled=1
> skip_if_unavailable=1
> gpgcheck=0

we're not distributing "pexpect", my question if f18 repo is configured.

--- Additional comment from Ohad Basan on 2012-11-28 09:03:09 EST ---

it is configured properly

--- Additional comment from Michael Pasternak on 2012-11-28 14:00:43 EST ---

[root@dhcp-1-76 ~]# cat /etc/redhat-release 
Fedora release 18 (Spherical Cow)

-------------------------------------------------------
[root@dhcp-1-76 ~]# yum search pexpect -v
Not loading "blacklist" plugin, as it is disabled
Loading "langpacks" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Loading "versionlock" plugin
Not loading "whiteout" plugin, as it is disabled
Adding en_US to language list
Config time: 0.013
Yum Version: 3.4.3
Setting up Package Sacks
Reading version lock configuration
pkgsack time: 0.236
rpmdb time: 0.000
tags time: 0.000
================ N/S Matched: pexpect ===================================
pexpect.noarch : Pure Python Expect-like module
Repo        : @fedora

-----------------------------------------------------------------

[root@dhcp-1-76 ~]# cat /etc/yum.repos.d/fedora.repo 
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
#metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

--- Additional comment from Jason Brooks on 2013-01-10 19:33:14 EST ---

I'm getting this same issue with F18 and the version of oVirt 3.1 in the F18 repos. 

The error msg asks for pexpect<=2.3, and F18 says: "Package pexpect-2.3-8.fc18.noarch is obsoleted by python-pexpect-2.5.1-5.fc18.noarch which is already installed"

--- Additional comment from Michael Pasternak on 2013-01-13 03:14:52 EST ---

(In reply to comment #6)
> I'm getting this same issue with F18 and the version of oVirt 3.1 in the F18
> repos. 
> 
> The error msg asks for pexpect<=2.3, and F18 says: "Package
> pexpect-2.3-8.fc18.noarch is obsoleted by python-pexpect-2.5.1-5.fc18.noarch
> which is already installed"

i couldn't reproduce it then on very same machine Ohad has used, but i'll change
dependency to allow pexpect >= 2.3, i guess we will cross the bridge when we'll
get there (issues with newer versions (i remember some talk about breaking backward compatibility))

anyway thanks for reporting this Jason.

--- Additional comment from Michael Pasternak on 2013-01-13 03:21:34 EST ---

http://gerrit.ovirt.org/10922
Comment 1 Sander Hoentjen 2013-01-29 04:21:04 EST
On Fedora 18, I can make the current version (ovirt-engine-cli-3.2.0.5-1.fc18.noarch) work when I edit /usr/lib/python2.7/site-packages/ovirt_shell-3.2.0.5_SNAPSHOT-py2.7.egg-info/requires.txt to have:
pexpect-u >= 2.3
instead of:
pexpect <= 2.3
Comment 2 Michael Pasternak 2013-01-29 06:06:33 EST
mentioned issues is fixed in 3.2.0.9, 

Juan,

what is 3.2 f18 publishing schedule?
Comment 3 Juan Hernández 2013-01-29 06:25:37 EST
Michael, there is no schedule. Is that 3.2.0.9 version compatible with ovirt-engine 3.1? If it is I can update the ovirt-engine-cli package.
Comment 4 Michael Pasternak 2013-01-30 08:03:09 EST
(In reply to comment #3)
> Michael, there is no schedule. Is that 3.2.0.9 version compatible with
> ovirt-engine 3.1? If it is I can update the ovirt-engine-cli package.

somehow i was sure that we are distributing oVirt (3.2) to f18, anyway
please upload latest 3.2 sdk/cli to fedora,

sdk: release 3.2.0.8-1
cli: release 3.2.0.9-1

thanks Juan.
Comment 5 Fedora Update System 2013-01-30 09:20:52 EST
ovirt-engine-cli-3.2.0.9-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ovirt-engine-cli-3.2.0.9-1.fc18
Comment 6 Fedora Update System 2013-01-30 09:37:43 EST
ovirt-engine-cli-3.2.0.9-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ovirt-engine-cli-3.2.0.9-1.el6
Comment 7 Sander Hoentjen 2013-01-31 03:21:33 EST
With this update I get:
Traceback (most recent call last):
  File "/usr/bin/ovirt-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2815, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pexpect>=2.3

If I change 'pexpect >= 2.3' to 'pexpect-u >= 2.3' in /usr/lib/python2.7/site-packages/ovirt_shell-3.2.0.9_SNAPSHOT-py2.7.egg-info/requires.txt it will work again.
Comment 8 Juan Hernández 2013-02-07 11:08:21 EST
*** Bug 908791 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-02-07 11:37:25 EST
ovirt-engine-cli-3.2.0.9-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ovirt-engine-cli-3.2.0.9-2.fc18
Comment 10 Juan Hernández 2013-02-07 11:40:51 EST
Sander, I took the change you proposed and added a patch to the packge to implement it. I think it will be ok now. Thanks.
Comment 11 Fedora Update System 2013-02-08 11:59:54 EST
Package ovirt-engine-cli-3.2.0.9-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ovirt-engine-cli-3.2.0.9-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2142/ovirt-engine-cli-3.2.0.9-2.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-02-09 06:31:01 EST
ovirt-engine-cli-3.2.0.9-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-02-20 10:35:03 EST
ovirt-engine-cli-3.2.0.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ovirt-engine-cli-3.2.0.10-1.el6
Comment 14 Fedora Update System 2013-03-09 14:20:13 EST
ovirt-engine-cli-3.2.0.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Lior Vernia 2013-04-10 07:13:05 EDT
Encountered same bug on Fedora 17.

<snip>

[lvernia@dhcp-1-166 ovirt-engine]$ ovirt-shell
Traceback (most recent call last):
  File "/usr/bin/ovirt-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2735, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pexpect-u>=2.3
[lvernia@dhcp-1-166 ovirt-engine]$ yum info pexpect
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
Name        : pexpect
Arch        : noarch
Version     : 2.3
Release     : 7.fc17
Size        : 784 k
Repo        : installed
From repo   : fedora
Summary     : Pure Python Expect-like module
URL         : http://pexpect.sourceforge.net/
Licence     : MIT
Description : Pexpect is a pure Python module for spawning child applications; controlling
            : them; and responding to expected patterns in their output. Pexpect works like
            : Don Libes' Expect. Pexpect allows your script to spawn a child application and
            : control it as if a human were typing commands.
            : 
            : Pexpect can be used for automating interactive applications such as ssh, ftp,
            : passwd, telnet, etc. It can be used to automate setup scripts for duplicating
            : software package installations on different servers. And it can be used for
            : automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
            : Pexpect is pure Python. Unlike other Expect-like modules for Python, Pexpect
            : does not require TCL or Expect nor does it require C extensions to be compiled.
            : It should work on any platform that supports the standard Python pty module.

</snip>

Worked around it by changing "pexpect-u >= 2.3" in /usr/lib/python2.7/site-packages/ovirt_shell-3.2.0.11_SNAPSHOT-py2.7.egg-info/requires.txt to "pexpect >= 2.3".
Comment 16 Fedora Update System 2013-04-11 06:59:45 EDT
ovirt-engine-cli-3.2.0.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ovirt-engine-cli-3.2.0.11-1.fc17
Comment 17 Fedora Update System 2013-04-19 21:18:45 EDT
ovirt-engine-cli-3.2.0.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.