Bug 905423 - Handle /etc/init/control-alt-delete.conf as a conf file (inline doc)
Handle /etc/init/control-alt-delete.conf as a conf file (inline doc)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
: 1020904 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 07:21 EST by sorin
Modified: 2016-11-25 07:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Users are not aware of /etc/init/*.conf files being overwritten on update. Consequence: Users changes are rewritten to the default values. Fix: Inform users in comment that these files should not be changed. Result: Users are told to user .override files instead.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:11:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sorin 2013-01-29 07:21:08 EST
Description of problem:
closely related to 663594 - [RFE] 

in short, these .conf files have been deemed not-configuration-files, and are handled as such by rpm (similar to the /etc/init.d/ scripts). Instead, .override files should be used.

Unfortunately, the suffix of the files is obviously misleading, and the way to use the .override files (and the fact this functionality exists) is not immediately obvious.

Version-Release number of selected component (if applicable):

upstart in RHEL6.3

How reproducible:

n/a

Steps to Reproduce:
1.
2.
3.
  
Actual results:

user assumes these are configuration files, edits them, and finds them to be overwritten  at next upgrade by the files inside the rpm.

Expected results:

user immediately notices these are not config files, and not meant to be edited.

Additional info:

the simple solution is to not name the files .conf, to begin with, and add a warning inside such files of the sort "do NOT edit, your changes will be overwritten. Please see man 5 foo.override on how to use .override files instead"
Comment 2 Lukáš Nykrýn 2013-01-29 08:07:24 EST
It is not a good idea to change suffix of these files, but adding some comment with warning looks as a reasonable solution.
Comment 13 Lukáš Nykrýn 2013-10-21 03:29:37 EDT
*** Bug 1020904 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2013-11-21 17:11:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1679.html

Note You need to log in before you can comment on or make changes to this bug.