Bug 905725 - Telnetd broken
Telnetd broken
Status: CLOSED DUPLICATE of bug 904182
Product: Fedora
Classification: Fedora
Component: telnet (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 21:49 EST by Chuck Forsberg
Modified: 2013-04-30 19:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 16:12:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Forsberg 2013-01-29 21:49:26 EST
Description of problem:telnetd is broken.
Example login follows:

[caf@omen ftp]$ telnet omen1
Trying 192.168.1.13...
Connected to omen1.
Escape character is '^]'.
Fedora release 18 (Spherical Cow)
Kernel 3.7.4-204.fc18.x86_64 on an x86_64 (10)
men login: 
           assword: 
                    ast login: Mon Jan 28 07:26:45 from omen3
BASH_PROFILE
on Jan 28 16:56:44 PST 2013
bash: /usr/games/fortune: No such file or directory
tyname=/dev/pts/10	DISPLAY=omen.com:3.0	ERM=xterm-256color	 23 rows  79 columns



Version-Release number of selected component (if applicable):
18   rawhide

How reproducible:


Steps to Reproduce:
1.enable telnetd
2.telnet to system
3. perform login
  
Actual results:
shown above, missing parts of output stream

Expected results:
normal output

Additional info:
The host system may crash as a result is a file transfer is attemptred.

On some connections operation is normal - it happens randomly but often.
Comment 1 Kyle McMartin 2013-01-30 16:12:58 EST

*** This bug has been marked as a duplicate of bug 904182 ***

Note You need to log in before you can comment on or make changes to this bug.