Bug 904182 - telnet-server output garbled
telnet-server output garbled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 905725 906125 (view as bug list)
Depends On:
Blocks: 1308660
  Show dependency treegraph
 
Reported: 2013-01-25 12:03 EST by Henrik Nordström
Modified: 2016-02-15 12:11 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1308660 (view as bug list)
Environment:
Last Closed: 2013-03-16 21:06:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Nordström 2013-01-25 12:03:21 EST
Description of problem:

Garbled output from telnet-server on Fedora 18

Version-Release number of selected component (if applicable):

telnet-server-0.17-54.fc18.x86_64

How reproducible:

Always

Steps to Reproduce:
1. yum install telnet-server
2. chkconfig telnet on
3. service xinetd start
4. telnet localhost
5. optionally try to log in but problem already visible
  
Actual results:

missing characters. newlines not working.

Expected results:

business as usual

Additional info:
Comment 1 Ed Greshko 2013-01-29 19:30:37 EST
I find 2 manifestations of the problem....

One looks as you describe....

[egreshko@meimei ~]$ telnet localhost
Trying ::1...
Connected to localhost.
Escape character is '^]'.
Fedora release 18 (Spherical Cow)
Kernel 3.7.4-204.fc18.x86_64 on an x86_64 (4)
eimei login: 
             assword: 
                      ast login: Wed Jan 30 08:23:52 from localhost

The other...

[egreshko@meimei ~]$ telnet f18x
Trying 192.168.0.168...
Connected to f18x.
Escape character is '^]'.
Fedora release 18 (Spherical Cow)
Kernel 3.7.4-204.fc18.x86_64 on an x86_64 (3)
Connection closed by foreign host.

In both cases if I add 

server_args     = -D options

to the telnet file in /etc/xinetd.d the problem is "fixed".
Comment 2 Ed Greshko 2013-01-30 01:58:12 EST
FYI, I also reverted to the F17 telnet-server package.  This did not fix the problem.  Testing was done with the firewall disabled as well.
Comment 3 Kyle McMartin 2013-01-30 16:12:58 EST
*** Bug 905725 has been marked as a duplicate of this bug. ***
Comment 4 Kyle McMartin 2013-01-30 16:45:03 EST
https://lkml.org/lkml/2013/1/15/641

davej points this out... looks like it's a /sbin/login bug.

fun.
Comment 5 Ed Greshko 2013-01-30 20:20:29 EST
FWIW, I replaced login with the one from F17 and this "fixed" the problem.
Comment 6 Adam Tkac 2013-01-31 05:43:30 EST
(In reply to comment #5)
> FWIW, I replaced login with the one from F17 and this "fixed" the problem.

Thanks for testing, reassigning to util-linux for further inspection.
Comment 7 Kyle McMartin 2013-01-31 12:15:13 EST
https://lkml.org/lkml/2013/1/15/641

probably should be assigned to the kernel... makes my head hurt thinking about tty though.
Comment 8 Karel Zak 2013-02-01 11:44:54 EST
*** Bug 906125 has been marked as a duplicate of this bug. ***
Comment 9 Attila 2013-02-05 08:22:47 EST
I can confirm and reproduce this bug.
The version of my installed telnet-server package is:
telnet-server-0.17-54.fc18.i686
Comment 10 Karel Zak 2013-02-20 12:33:45 EST
The patch is in TTY tree and probably will be merged into kernel 3.9-rc.
Comment 11 Josh Boyer 2013-02-20 14:13:22 EST
Hopefully it will make it into the stable releases.  In the meantime, we can bring it back after a bit of time in Linus' tree.
Comment 12 Josh Boyer 2013-03-04 09:17:33 EST
This is fixed with

commit b81273a132177edd806476b953f6afeb17b786d5
Author: Jiri Slaby <jslaby@suse.cz>
Date:   Tue Jan 15 23:26:22 2013 +0100

    TTY: do not reset master's packet mode

which is in rawhide already.  There's no CC to stable, so we'll have to look at bringing it back as I said in my previous comment.
Comment 13 Josh Boyer 2013-03-11 09:08:00 EDT
Added to F17/F18.
Comment 14 Fedora Update System 2013-03-14 18:52:27 EDT
kernel-3.8.3-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.8.3-101.fc17
Comment 15 Fedora Update System 2013-03-14 22:57:18 EDT
kernel-3.8.3-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.8.3-201.fc18
Comment 16 Fedora Update System 2013-03-15 21:20:39 EDT
Package kernel-3.8.3-201.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.8.3-201.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3893/kernel-3.8.3-201.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-03-16 21:07:01 EDT
kernel-3.8.3-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Attila 2013-03-19 07:57:30 EDT
Thank you for fixing this bug. The output from telnet-server is ok again.
Comment 19 Fedora Update System 2013-03-21 20:11:05 EDT
kernel-3.8.3-103.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.