This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 906031 - installation failure: "Error accessing file for config"
installation failure: "Error accessing file for config"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 920764 950437 953667 (view as bug list)
Depends On:
Blocks: ARMTracker F19Beta/F19BetaBlocker 887223
  Show dependency treegraph
 
Reported: 2013-01-30 11:31 EST by Joe Orton
Modified: 2013-06-16 07:49 EDT (History)
29 users (show)

See Also:
Fixed In Version: curl-7.24.0-9.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-01 00:23:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
f18 kickstart failure (28.73 KB, image/png)
2013-01-30 11:31 EST, Joe Orton
no flags Details
kickstart script (1.37 KB, text/plain)
2013-01-30 11:34 EST, Joe Orton
no flags Details
screenshot of anaconda.log (34.62 KB, image/png)
2013-01-30 11:38 EST, Joe Orton
no flags Details
anaconda-tb (1.26 MB, text/plain)
2013-04-16 05:33 EDT, Ľuboš Kardoš
no flags Details
anaconda.log (26.99 KB, text/x-log)
2013-04-16 05:34 EDT, Ľuboš Kardoš
no flags Details
program.log (42.96 KB, text/x-log)
2013-04-16 05:35 EDT, Ľuboš Kardoš
no flags Details
packaging.log (881.57 KB, text/x-log)
2013-04-16 05:36 EDT, Ľuboš Kardoš
no flags Details
syslog (85.32 KB, application/octet-stream)
2013-04-16 05:37 EDT, Ľuboš Kardoš
no flags Details
storage.log (204.16 KB, text/x-log)
2013-04-16 05:37 EDT, Ľuboš Kardoš
no flags Details
ifcfg.log (486 bytes, text/x-log)
2013-04-16 05:38 EDT, Ľuboš Kardoš
no flags Details
Tarball containing anaconda logs from failed F19 Alpha RC3 installation (173.62 KB, application/x-compressed-tar)
2013-04-16 08:15 EDT, Nils Philippsen
no flags Details
libcurl-based reproducer (1.43 KB, text/plain)
2013-04-26 08:34 EDT, Kamil Dudka
no flags Details

  None (edit)
Description Joe Orton 2013-01-30 11:31:08 EST
Created attachment 690490 [details]
f18 kickstart failure

Description of problem:
Doing a kickstart install into a kvm guest; the generated kickstart script works for installing Fedora 17 and way back, but maybe something non-obvious has changed in the syntax?

Version-Release number of selected component (if applicable):
anaconda 18.37.11

How reproducible:
always

Steps to Reproduce:
1. kickstart install kvm guest
 
Actual results:
failure

I'll attach the ks script too.
Comment 1 Joe Orton 2013-01-30 11:34:33 EST
Created attachment 690491 [details]
kickstart script
Comment 2 Joe Orton 2013-01-30 11:38:41 EST
Created attachment 690492 [details]
screenshot of anaconda.log
Comment 3 Chris Lumens 2013-01-30 13:19:57 EST
We've also got bug 887223 tracking this in RHEL7.  I do not believe this is anything specific about your kickstart file.  The other bug report indicates it's a transient error, but you indicate it is reproducible every time.
Comment 4 Joe Orton 2013-01-31 05:22:18 EST
Yes, I tried it twice times yesterday and once again this morning.  Exactly the same failure every time.  This is my virt-install line if that helps:

virt-install --quiet --connect qemu:///system --virt-type kvm --name f18k --network bridge=virtbr,mac=52:54:00:96:ce:be --ram 1000 --os-type linux --os-variant fedora18 --disk path=/var/lib/libvirt/images/f18k.img,size=15 --noautoconsole --location http://myhost/mirror/fedora/releases/18/Fedora/x86_64/os/ --extra-args 'ks=http://myhost/~jorton/ks.php?host=myguest&url=fedora/releases/18/Fedora/x86_64/os/'
Comment 5 Chris Lumens 2013-04-10 14:57:43 EDT
*** Bug 950437 has been marked as a duplicate of this bug. ***
Comment 6 Dan Mashal 2013-04-13 16:45:57 EDT
Description of problem:
Installing MATE Desktop using TC6 alpha netinstaller

Version-Release number of selected component:
anaconda-19.18-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha-TC6\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha-TC6

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 7 Adam Williamson 2013-04-14 01:55:31 EDT
Dan, could you please provide rationale for this being nominated as an Alpha blocker? Thanks.
Comment 8 Dan Mashal 2013-04-14 01:57:24 EDT
(In reply to comment #7)
> Dan, could you please provide rationale for this being nominated as an Alpha
> blocker? Thanks.

Under criterion of a failed install.
Comment 9 Nils Philippsen 2013-04-15 10:20:23 EDT
Description of problem:
Tried to install TC6. Crashed after setting the root password (not sure it's related to that however).

- workstation profile with a few additional options
- English (US) language, German (nodeadkeys) layout
- btrfs

Version-Release number of selected component:
anaconda-19.18-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   method=http://dl.fedoraproject.org/pub/alt/stage/19-Alpha-TC6/Fedora/x86_64/os/
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha-TC6

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 10 Adam Williamson 2013-04-15 12:28:00 EDT
Discussed at 2013-04-15 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-15/f19alpha-blocker-review-7.2013-04-15-16.00.log.txt . This is obviously a show-stopper bug, but it seems to be transient for most reporters, and the initial reporter is using a kickstart (which is outside of Alpha criteria). There really isn't much consistency between reports, so it's hard to pin down the cause here.

Overall we felt there are obviously many more cases where this doesn't happen than where it does, or else there wouldn't be so many check marks in the Alpha validation test matrices. So for now, it is rejected as a blocker on the basis it's just not affecting enough installs. If more details emerge that pin down the cause of this more precisely and they seem to indicate it is a blocker after all, please re-propose.
Comment 11 Adam Williamson 2013-04-15 12:55:08 EDT
Joe, if you can reproduce this reliably, can you please attach the full set of anaconda log files from /tmp after the failure?

That applies to all reporters - please, if you're able to reproduce this, attach your logs. Thanks!
Comment 12 Joe Orton 2013-04-16 03:46:48 EDT
I'm not sure I can reproduce this any more.  My environment has changed slightly: I was using an f17 kvm host.  

I've just installed three f18 vms in a row, using exactly the same kickstart file as above, and it worked perfectly.  I'll check with f19 and That Other Distro as well.
Comment 13 Ľuboš Kardoš 2013-04-16 05:23:08 EDT
Description of problem:
I don't know what caused this problem. I was performing normal installation and a while after my clicking on "begin installation", traceback was showed. I'm not able to reproduce it. Maybe some race condition.

Version-Release number of selected component:
anaconda-19.19-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 14 Ľuboš Kardoš 2013-04-16 05:33:52 EDT
Created attachment 736260 [details]
anaconda-tb
Comment 15 Ľuboš Kardoš 2013-04-16 05:34:39 EDT
Created attachment 736261 [details]
anaconda.log
Comment 16 Ľuboš Kardoš 2013-04-16 05:35:42 EDT
Created attachment 736262 [details]
program.log
Comment 17 Ľuboš Kardoš 2013-04-16 05:36:28 EDT
Created attachment 736263 [details]
packaging.log
Comment 18 Ľuboš Kardoš 2013-04-16 05:37:08 EDT
Created attachment 736264 [details]
syslog
Comment 19 Ľuboš Kardoš 2013-04-16 05:37:45 EDT
Created attachment 736266 [details]
storage.log
Comment 20 Ľuboš Kardoš 2013-04-16 05:38:18 EDT
Created attachment 736267 [details]
ifcfg.log
Comment 21 Nils Philippsen 2013-04-16 08:10:55 EDT
I can reproduce this issue reliably using the netinst ISO image -- using the complete DVD image seems to work (it's installing package ATM).

Here's what/how I tried to install:

- No kickstart

- English language, German keyboard layout

- VM with leftover partitioning, or empty virtual disk image. Choose the single virtual disk (15GB), then "Done", BTRFS scheme and custom partitioning. In the case with existing partitions, delete them first of course. Then choose the suggested partitioning and reduce swap from 4GB to 1GB, extend root (and home) volumes by the gained 3GB, then "Done":

  Manual Partitioning (BTRFS):
    DATA
        /home [home] 13.859GB (BTRFS, btrfs, Single)
    SYSTEM
        /boot [vda1] 500MB (Standard Partition, ext4)
        /root [root] 13.859GB (BTRFS, btrfs, Single)
        Swap [vda2] 1GB (Standard Partition, swap)

- Software Selection:
    Environment:
        Development and Creative Workstation
    Add-ons:
        Administration Tools
        C Development Tools and Libraries
        Design Suite
        Development Tools
        Engineering and Scientific
        PostgreSQL Database
        RPM Development Tools
        Security Lab
        System Tools

- "Begin Installation"

- Set root password

The crash happens at this point usually. If I'm especially quick, I can enter the "user creation" spoke first.

I'll attach a tarball with all log files I found in /tmp.

Adam: As kickstart is not involved and I can reliably reproduce this, would you consider this a blocker?
Comment 22 Nils Philippsen 2013-04-16 08:15:05 EDT
Created attachment 736295 [details]
Tarball containing anaconda logs from failed F19 Alpha RC3 installation
Comment 23 Adam Williamson 2013-04-16 12:37:41 EDT
Nils: can you reproduce it without installing a giant ton of add-ons?
Comment 24 Stefano Karapetsas 2013-04-16 15:02:50 EDT
Description of problem:
Random error during installation

Version-Release number of selected component:
anaconda-19.18-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha-TC6\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha-TC6

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 25 Brian Lane 2013-04-16 17:08:08 EDT
That traceback has:

Local variables in innermost frame:
e: [Errno 12] Timeout on file:///tmp/anaconda-yum.conf: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 300 seconds')

Which makes me think this is a virt problem.
Comment 26 Dan Mashal 2013-04-16 17:16:41 EDT
(In reply to comment #25)
> That traceback has:
> 
> Local variables in innermost frame:
> e: [Errno 12] Timeout on file:///tmp/anaconda-yum.conf: (28, 'Operation too
> slow. Less than 1000 bytes/sec transferred the last 300 seconds')
> 
> Which makes me think this is a virt problem.

I installed on dual striped sata 3 ssd on a quad core AMD.

Can you please increase the timeout value?
Comment 27 Adam Williamson 2013-04-16 17:24:26 EDT
For blocker consideration purposes - by my count we have 6 people who have hit this bug with F19:

Dan
Nils
Ľuboš
Stefano
Tao Wu (#950437)
Jens (#950954)
Comment 28 Adam Williamson 2013-04-16 17:28:38 EDT
A thought: for anyone who experiences this bug regularly or 100% of the time, does passing "slub_debug=-" on the kernel command line help? I'm wondering if this bug is somewhat performance-related, which would explain it happening apparently more often with F19 Alpha, as the debug kernel makes performance rather worse.
Comment 29 Stefano Karapetsas 2013-04-16 17:29:05 EDT
I have a Core 2 Duo P8600 with 4GB of RAM, 128GB SSD and I'm using Virtualbox, and the install crashed 3/3 attempts during different parts of the install.
Comment 30 Stefano Karapetsas 2013-04-16 17:50:55 EDT
Adam, I just got the issue also with "slub_debug=-".
Comment 31 Stefano Karapetsas 2013-04-16 19:12:52 EDT
Same issue with RC3
Comment 32 Adam Williamson 2013-04-17 02:13:10 EDT
We should re-consider this one in the go/no-go meeting, I think. Re-proposing.
Comment 33 Dan Mashal 2013-04-17 02:44:36 EDT
Thanks. +1
Comment 34 Nils Philippsen 2013-04-17 10:07:34 EDT
(In reply to comment #23)
> Nils: can you reproduce it without installing a giant ton of add-ons?

Hmpf. It seems whatever I do today, I can't reproduce the problem -- leaving everything (under my control) the same, even to the point of running a second VM in parallel as I did yesterday, running an installation of F19 RC3 from a DVD ISO image (both to images in the same folder).

That kind of leaves changes in the tree (? -- is the RC3 anaconda tied to the RC3 tree or will it pick newer stuff?), or even which mirror was chosen, or it was that I have much fewer browser windows/tabs open, ... which all isn't exactly helpful in figuring out what went wrong then.

(In reply to comment #25)
> That traceback has:
> 
> Local variables in innermost frame:
> e: [Errno 12] Timeout on file:///tmp/anaconda-yum.conf: (28, 'Operation too
> slow. Less than 1000 bytes/sec transferred the last 300 seconds')
> 
> Which makes me think this is a virt problem.

I'm not sure about that number of 300 seconds -- I think I got through the whole process in less than 5 minutes but it's a close call.
Comment 35 Adam Williamson 2013-04-17 12:35:37 EDT
Discussed (again) at 2013-04-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-17/f19alpha-blocker-review-8.2013-04-17-16.00.log.txt . The increasing number of people hitting this concerns us somewhat. However, this seems to be something of a heisenbug - it's very hard to pin down - and the information available indicates it's not actually a showstopper for anyone (all reporters seem to have found that it starts working if they wait a while, or use the DVD, or something).

So right now we're working on the basis that this only affects netinstalls and is something to do with the mirror used or the repository contents, it affects a minority of install attempts, and it will usually work if the user waits a while and tries again. Using the DVD image is also a workaround. On that basis, we decided to once again reject the bug as a blocker. If we're able to find information that contradicts the above, this may change things.

Stefano, it'd be handy if you could try today and see if it's cleared up for you - you're the only reporter so far who hasn't reported back that a later attempt was successful, but it seems that so far, you've only hit the bug on one day. It'd be good to know if today it's started working for you (as for Nils).
Comment 36 D. Marlin 2013-04-17 17:40:37 EDT
I'm running livemedia-creator on an F19 ARM system (Calxeda HighBank), and also see the folling in a dump:

--------
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 473, in updateBaseRepo
    self._yumCacheDirHack()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 195, in setup
    self.updateBaseRepo(fallback=not flags.automatedInstall)
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 656, in payloadInitialize
    payload.setup(storage)
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf

Local variables in innermost frame:
e: [Errno 12] Timeout on file:///tmp/anaconda-yum.conf: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 300 seconds')
url: file:///tmp/anaconda-yum.conf
includetuple: ('file:///tmp/anaconda-yum.conf', None)
self: <yum.parser.ConfigPreProcessor instance at 0x1600080>
absurl: file:///tmp/anaconda-yum.conf
fo: None
--------

The command line used is:

  livemedia-creator \
   --no-virt --make-disk \
   --armplatform=tegra \
   --ks=./F19-trimslice-test.ks

running:

  anaconda-19.19-1.fc19.armv7hl
  lorax-19.2-1.fc19.armv7hl
  python-blivet-0.10-1.fc19.noarch
  kernel-highbank-3.6.10-8.fc18


Note: we are using an F18 kernel, the same one we successfully used for running lmc on F18.
Comment 37 Dan Mashal 2013-04-18 03:06:48 EDT
Still hitting this on RC4
Comment 38 Dan Scott 2013-04-19 22:10:30 EDT
Description of problem:
After failed UEFI attempts, switched my BIOS to legacy mode (Lenovo x120e) and attempted an install.

My LAN connection to the internt failed for a period of time, so for about two hours the installer waited for me to set up the LAN connection again, after which I was able to set a mirror and choose a set of software packages (GNOME 3).

As this is the first time this happened, I'm not sure if it is repeatable. Will try again.

Version-Release number of selected component:
anaconda-19.20-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=bf3dd9e9-d3b1-4259-afa2-c42c943b97fc rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 39 Adam Williamson 2013-04-19 22:54:31 EDT
dan: see the commonbugs note - give it a while and try again, or use the DVD or live.
Comment 40 Dan Scott 2013-04-19 23:06:12 EDT
Thanks Adam. My report was automatically filed as a duplicate; I have already read the common bugs note and am trying again. This time seems to be working, adding weight to the "possibly an issue with the selected repo" theory.
Comment 41 Adam Williamson 2013-04-19 23:18:44 EDT
yeah, it's a weird issue - if you read back through the comments, for some people just retrying right away works, for some it works the next day, for the other Dan it never seems to work...it's odd.
Comment 42 Dan Mashal 2013-04-19 23:33:37 EDT
(In reply to comment #41)
> yeah, it's a weird issue - if you read back through the comments, for some
> people just retrying right away works, for some it works the next day, for
> the other Dan it never seems to work...it's odd.

No it works. But it crashes more than it works.
Comment 43 Dan Mashal 2013-04-22 11:56:15 EDT
I have hit this on baremetal now with TC6 on a UEFI install.
Comment 44 Dan Mashal 2013-04-22 12:10:44 EDT
I think this is related to partitioning somehow. 

I don't know if others are hitting this with automatic partitioning enabled but after 2nd try and choosing reclaim space and letting anaconda create the partitions instead of creating them by hand the install *seems* to be running. 

But I would say we can rule out physical/virtual/uefi/non-uefi to from this bug as I have tested them all.
Comment 45 kuchiman 2013-04-22 15:19:01 EDT
Description of problem:
Installing F19 RC4. 

Version-Release number of selected component:
anaconda-19.20-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 46 Brian Lane 2013-04-23 20:45:37 EDT
I am seeing this while working on some new code, it is frequently failing to read file:///run/install/DD-1/x86_64/repodata/repomd.xml so it isn't limited to just the config file.

Currently I am hitting it 9/10 tries on a KVM PXE setup.

I'm going to jump to conclusions and speculate that there is something funky going on in urlgrabber which is what yum uses to read file:// URI's.

Adding Zdenek Pavlas to the CC to get his thoughts.
Comment 47 Arkady L. Shane 2013-04-24 10:43:20 EDT
I've got such bug when try to build Fedora iso-image with enabled updates-testing repo:

---
Pungi:INFO: Adding repo ourtree
Pungi:INFO: URL for repo ourtree is ['file:///builddir/19/x86_64/os']
hfsplus-tools-540.1.linux3-3.fc19.x86_64
checking for root privileges
checking the selinux mode
checking yum base object
setting up build architecture
setting up build parameters
installing runtime packages
got release: fedora-release
running runtime-install.tmpl
Looking for extra fedup-dracut packages...
installpkg *-fedup-dracut failed: No package(s) available to install
template command error in runtime-install.tmpl:
  run_pkg_transaction
  NoMoreMirrorsRepoError: failure: repodata/repomd.xml from ourtree: [Errno 256] No more mirrors to try.
file:///builddir/19/x86_64/os/repodata/repomd.xml: [Errno 12] Timeout on file:///builddir/19/x86_64/os/repodata/repomd.xml: (28, 'Operation too slow. 
Less than 1000 bytes/sec transferred the last 30 seconds')
Warning: Reusing existing destination directory.
Could not find valid repo at: /builddir/19/x86_64/os
Spawning worker 0 with 4377 pkgs
Workers Finished
Saving Primary metadata
Saving file lists metadata
Saving other metadata
Generating sqlite DBs
Sqlite DBs complete
Traceback (most recent call last):
  File "/usr/bin/pungi", line 256, in <module>
    main()
  File "/usr/bin/pungi", line 146, in main
    mypungi.doBuildinstall()
  File "/usr/lib/python2.7/site-packages/pypungi/__init__.py", line 937, in doBuildinstall
    workdir=workdir, outputdir=outputdir)
  File "/usr/lib/python2.7/site-packages/pylorax/__init__.py", line 243, in run
    rb.install()
  File "/usr/lib/python2.7/site-packages/pylorax/treebuilder.py", line 104, in install
    self._runner.run("runtime-install.tmpl")
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 180, in run
    self._run(commands)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 199, in _run
    f(*args)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 485, in run_pkg_transaction
    self.yum.buildTransaction()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1263, in buildTransaction
    self.save_ts(auto=True)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6513, in save_ts
    msg += "%s:%s:%s\n" % (r.id, len(r.sack), r.repoXML.revision)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1661, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1657, in _getRepoXML
    self._loadRepoXML(text=self.ui_id)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1648, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1622, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1447, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1225, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1021, in _getFile
    raise Errors.NoMoreMirrorsRepoError(errstr, errors)
yum.Errors.NoMoreMirrorsRepoError: failure: repodata/repomd.xml from ourtree: [Errno 256] No more mirrors to try.
file:///builddir/19/x86_64/os/repodata/repomd.xml: [Errno 12] Timeout on file:///builddir/19/x86_64/os/repodata/repomd.xml: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
---
Comment 48 Kuba H 2013-04-24 12:20:57 EDT
Description of problem:
Problem happened during new user creation.

Version-Release number of selected component:
anaconda-19.20-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 49 Brian Lane 2013-04-24 17:31:21 EDT
This error comes from curl's Curl_speedcheck function so I think there is something going wrong with its calculation on file:// transfers.

I changed the urlgrabber setting for LOW_SPEED_LIMIT to 1 instead of 1000 and I am still consistently seeing this error in my tests.

Any additional advice for debugging would be appreciated. I can reproduce this in my setup 9/10 tries.
Comment 50 Brian Lane 2013-04-24 19:32:09 EDT
It appears that curl isn't resetting itself correctly when a new request is made. Something about the starting state causes it to mis-calculate the transfer time for the file.

If I add the following before making the calls to add the local repos the install works fine, no timeout errors:

+        with _yum_lock:
+            from urlgrabber import grabber
+            grabber.reset_curl_obj()
Comment 51 Zdeněk Pavlas 2013-04-25 04:56:22 EDT
What version of python-urlgrabber is being used?  There was a rather nasty bug that could be related (BZ 923951), but that has been fixed in python-urlgrabber-3.9.1-26.fc19 almost month ago, and urlgrabber is resetting the curl object before each request.  The relevant commit is here: http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=129e0e98

I've just checked that the curl object is being reset for file:// urls, too.
Comment 52 Kamil Dudka 2013-04-25 07:12:37 EDT
Why is this assigned to curl?  Do we have any (py)curl-based reproducer of the issue?
Comment 53 Brian Lane 2013-04-25 09:29:21 EDT
Sorry, I don't have a simple reproducer for this. But I am consistently hitting it with my boot.iso setup. The reason I re-assigned it to curl is that:

1 - the error is generated by the speedcheck function in curl.
2 - It works if I increase the timeout to some insane level, like 300000
3 - It works if I reset the curl object right before adding repos (without increasing the timeout).
4 - It appears to abort the file grab immediately. There is no 300 second delay from when it tries to when it gets the error, indicating a timing problem.

curl should be resetting its timers on each file grab, we shouldn't need to reset the object outside of curl.

The version of urlgrabber I am using has the fix for bug 923953 (that was the first thing I checked), but I am not sure of the exact version. I think I used Alpha TC6 as the base for this PXE setup, but I'll have to see if I can find a version number somewhere.

Also note that we are seeing this across a number of different setups, not just KVM, but also bare metal installs as well as pungi runs.
Comment 54 Brian Lane 2013-04-25 09:40:32 EDT
curl --version reports 7.29.0 and urlgrabber is 3.9.1 with the _do_open reset() call in place. The image doesn't have any more exact version numbers than that in it.
Comment 55 Zdeněk Pavlas 2013-04-25 11:14:40 EDT
Probably found the root cause of this..

data->state.keeps_speed is not being reset between requests.  curl_easy_reset() zeroes out data->set and data->progress, but the keeps_speed variable is stored in data->state instead (should be in progress, probably).

There's Curl_speedinit() function to zero it out, called from do_init().  But alas, create_conn() skips do_init() for connections that don't require network.
Comment 56 Adam Williamson 2013-04-25 19:42:29 EDT
3.9.1-26 went stable a long time ago, on 03-27. The builds people have been hitting this with definitely had 3.9.1-26 in them.
Comment 57 Jens Petersen 2013-04-26 03:31:55 EDT
I haven't been able to net install F19 Alpha yet because of this...
Comment 58 Jens Petersen 2013-04-26 03:38:32 EDT
Removing the RejectedBlocker for Alpha from the Whiteboard
so this gets attention as a Beta blocker.
Comment 59 Kamil Dudka 2013-04-26 04:57:51 EDT
Thanks for the analysis.  I will try to create a libcurl-based reproducer on my own.
Comment 60 Zdeněk Pavlas 2013-04-26 05:25:35 EDT
I've patched curl, so the keeps_speed timestamp is reset also before each file:// request.  Should fix #4 (immediate abort).

scratch build is available there:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5304060

However, I didn't manage to reproduce this, and am not sure why additional reset() did help.  To trigger the 'Operation too slow' error, progress code has to calculate low enough speed && it has to be low for 30 seconds.  Mabye the extra reset() helped with the first part(?)

diff -up curl-7.29.0/lib/url.c.orig curl-7.29.0/lib/url.c
--- curl-7.29.0/lib/url.c.orig	2013-02-06 10:47:19.000000000 +0100
+++ curl-7.29.0/lib/url.c	2013-04-26 10:51:29.361598999 +0200
@@ -4895,6 +4895,9 @@ static CURLcode create_conn(struct Sessi
                           -1, NULL); /* no upload */
     }
 
+    /* since we skip do_init() */
+    Curl_speedinit(data);
+
     return result;
   }
 #endif
Comment 61 Kamil Dudka 2013-04-26 06:45:47 EDT
There seems to be a similar bug for the FTP protocol, which is fixed already:

    bug 679709

I will try to reuse the reproducer from there:

    attachment #503481 [details]
Comment 62 Kamil Dudka 2013-04-26 08:34:26 EDT
Created attachment 740383 [details]
libcurl-based reproducer

git-bisect points to the following upstream commit:

https://github.com/bagder/curl/commit/9dd85bce
Comment 63 Kamil Dudka 2013-04-26 08:55:07 EDT
(In reply to comment #60)
> diff -up curl-7.29.0/lib/url.c.orig curl-7.29.0/lib/url.c
> --- curl-7.29.0/lib/url.c.orig	2013-02-06 10:47:19.000000000 +0100
> +++ curl-7.29.0/lib/url.c	2013-04-26 10:51:29.361598999 +0200
> @@ -4895,6 +4895,9 @@ static CURLcode create_conn(struct Sessi
>                            -1, NULL); /* no upload */
>      }
>  
> +    /* since we skip do_init() */
> +    Curl_speedinit(data);
> +
>      return result;
>    }
>  #endif

This seems like the correct way to fix the bug, will commit it on your behalf.
Comment 64 Kamil Dudka 2013-04-26 10:15:10 EDT
upstream commit:

https://github.com/bagder/curl/commit/b37b5233
Comment 65 Kamil Dudka 2013-04-26 11:01:09 EDT
fixed in curl-7.30.0-2.fc20
Comment 66 Fedora Update System 2013-04-26 12:01:11 EDT
curl-7.27.0-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/curl-7.27.0-9.fc18
Comment 67 Fedora Update System 2013-04-26 12:01:59 EDT
curl-7.29.0-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/curl-7.29.0-6.fc19
Comment 68 Fedora Update System 2013-04-26 12:02:37 EDT
curl-7.24.0-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/curl-7.24.0-8.fc17
Comment 69 Brian Lane 2013-04-26 17:25:19 EDT
*** Bug 920764 has been marked as a duplicate of this bug. ***
Comment 70 Fedora Update System 2013-04-26 19:54:35 EDT
Package curl-7.24.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing curl-7.24.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6720/curl-7.24.0-8.fc17
then log in and leave karma (feedback).
Comment 71 Dan Mashal 2013-04-27 03:06:36 EDT
Thanks.
Comment 72 Chris Lumens 2013-04-30 07:51:12 EDT
*** Bug 953667 has been marked as a duplicate of this bug. ***
Comment 73 Steve Dickson 2013-04-30 11:07:08 EDT
Description of problem:
Trying to install F-19 alpha

Version-Release number of selected component:
anaconda-19.20-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   method=ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/releases/test/19-Alpha/Fedora/x86_64/os/
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 129, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1398, in preInstall
    self._writeInstallConfig()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in _writeInstallConfig
    self._yumCacheDirHack()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 279, in _yumCacheDirHack
    if not self._yum.conf.cachedir.startswith(self._yum.conf.installroot):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1001, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 338, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1000, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 91, in __init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 205, in _pushfile
    'Error accessing file for config %s' % (absurl)
ConfigError: Error accessing file for config file:///tmp/anaconda-yum.conf
Comment 74 Kamil Dudka 2013-04-30 18:52:56 EDT
(In reply to comment #73)
> Trying to install F-19 alpha

Could you please try it with libcurl-7.29.0-6.fc19 in use?
Comment 75 Fedora Update System 2013-05-01 00:23:16 EDT
curl-7.29.0-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 76 Adam Williamson 2013-05-02 20:15:48 EDT
Note: the fix for this was pulled into F19 Beta TC2, so if you want to verify it and you have a reliable reproducer, please test with that. Similarly, if anyone hits this with TC2 or later, then we apparently still have a problem.
Comment 77 Fedora Update System 2013-05-05 23:48:29 EDT
curl-7.27.0-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 78 Fedora Update System 2013-05-09 08:07:46 EDT
curl-7.24.0-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/curl-7.24.0-9.fc17
Comment 79 Fedora Update System 2013-05-09 08:08:23 EDT
curl-7.27.0-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/curl-7.27.0-10.fc18
Comment 80 Fedora Update System 2013-05-14 23:25:36 EDT
curl-7.27.0-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 81 Fedora Update System 2013-05-25 08:14:38 EDT
curl-7.24.0-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 82 Jos Vos 2013-06-16 07:49:58 EDT
I still have this problem (sometimes) on F18 with all updates applied (curl-7.27.0-10.fc18).  I'm creating custom install media with pungi, including all non-testing updates, I include a kickstart file in the image etc., and some work, some don't work, sometimes the same image does work one time and fails the other time.

Any help is appreciated.

Note You need to log in before you can comment on or make changes to this bug.