Bug 983409 - RFE: add gnome-shell-extension-sensors in place of broken gnome-shell-extensions-cpu-temperature
RFE: add gnome-shell-extension-sensors in place of broken gnome-shell-extensi...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 03:22 EDT by collura
Modified: 2014-03-16 23:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 12:29:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collura 2013-07-11 03:22:09 EDT
Description of problem:

  please update to use gnome-shell-extension-sensors.

  the newer version [1] of 

    gnome-shell-extension-cpu-temperature (needs fixing)

  is 

    gnome-shell-extension-sensors [2] (shiny newer version).  

  this type of data can be very important to have at fingertips.
  the older version is broken again and the newer version shows more data.


Version-Release number of selected component (if applicable):

  currently broken [3] gnome-shell-extension-cpu-temperature-1.1-1.fc19.x86_64

How reproducible:

  often since gnome3

Steps to Reproduce:
1. install gnome-shell-extension-cpu-temperature
2. possibly modify the metadata.json file (see bug#906090)
3. enable in gnome-tweak-tool and restart gnome
4. data might appear in toolbar as expected

Actual results:

  cpu-temperature extension has been broken intermittantly for last few releases

Expected results:

  access to sensor data

Additional info:

 link to supporting files:
   [1] https://extensions.gnome.org/extension/82/cpu-temperature-indicator/
   [2] https://github.com/xtranophilist/gnome-shell-extension-sensors

 some of the related bugs:
   [3] https://bugzilla.redhat.com/show_bug.cgi?id=957384
   [3] https://bugzilla.redhat.com/show_bug.cgi?id=912115
   [3] https://bugzilla.redhat.com/show_bug.cgi?id=906090
Comment 1 Bill Nottingham 2013-07-11 10:42:03 EDT
Moving to gnome-shell-extension-cpu-temperature, as that maintainer would be the likely one to pick up the new version.
Comment 2 Fabian Affolter 2013-11-22 02:42:36 EST
Package is retired.
Comment 3 collura 2013-11-22 19:36:26 EST
i understand why the the originally named extension  

   'gnome-shell-extension-cpu-temperature'

would be retired ( because the extension had its name changed to 

   'gnome-shell-extension-sensors' ). 


however this request for enhancement was originally filed against the fedora distribution so the newly named version of the extension would be pulled in.  


the old extension that was just listed as the package for the bug so that the maintainer would more easily see it (see comment#1) :')


the new extension looks to be live and well with recent edits occuring a few weeks ago:

     https://github.com/xtranophilist/gnome-shell-extension-sensors


the functionality is still needed. 
the new gnome-shell-extension-sensors seems to be alive still.
this rfe should still be open.

changing the package back to distribution and setting version to rawhide :')
Comment 4 Fabian Affolter 2013-12-21 12:34:36 EST
Well, for me maintaining gnome extensions is a very big time consumer because the upstream projects doesn't follow the changes in the gnome shell cycles closely, most of the time. Nowadays a lot of extensions are available in the Gnome Shell Extensions "thing" [1] which make it very easy for the users to install extensions.

[1] https://extensions.gnome.org/
Comment 5 Bill Nottingham 2014-01-06 12:29:37 EST
We don't normally add packages without willing maintainers - if the maintainer of the old version isn't going to maintain it, then there would need to be a new one.

I've added this to the package request wishlist at https://fedoraproject.org/wiki/Package_maintainers_wishlist.

Closing as DEFERRED until a maintainer steps up for it (see the process at https://fedoraproject.org/wiki/Join_the_package_collection_maintainers).

Note You need to log in before you can comment on or make changes to this bug.