Bug 906125 - login in util-linux-2.22.1-2.4.fc18.x86_64 is broken
login in util-linux-2.22.1-2.4.fc18.x86_64 is broken
Status: CLOSED DUPLICATE of bug 904182
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 17:18 EST by H.J. Lu
Modified: 2013-02-01 11:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 11:44:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2013-01-30 17:18:17 EST
When I tried to rlogin into Fedora 18, login on Fedora 18
hung.  Replace rlogin from util-linux-2.21.2-3.fc17.x86_64
fixes the problem.
Comment 1 H.J. Lu 2013-01-30 20:11:17 EST
It is caused by

2e7035646eb85851171cc2e989bfa858a4f00cd4 is the first bad commit
commit 2e7035646eb85851171cc2e989bfa858a4f00cd4
Author: Karel Zak <kzak@redhat.com>
Date:   Thu Jul 12 16:33:52 2012 +0200

    login: close tty before vhangup()
    
    Let's close all tty file descriptors before vhangup() call.
    
    References: https://lkml.org/lkml/2012/6/5/145
    Signed-off-by: Karel Zak <kzak@redhat.com>

:040000 040000 bb1aadd64c6eca4c79689c4a8d574fbbf8bec97d 799d7b20e24e9d0a430c71b3f1810c0b19db39dc M	login-utils
Comment 2 H.J. Lu 2013-01-31 11:27:46 EST
It also breaks telnet server.
Comment 3 Karel Zak 2013-02-01 11:44:53 EST

*** This bug has been marked as a duplicate of bug 904182 ***

Note You need to log in before you can comment on or make changes to this bug.