Bug 906188 - [RFE] Group multiple locale codes under language teams
[RFE] Group multiple locale codes under language teams
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michelle Kim
Zanata-QA Mailling List
:
: 1075276 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 00:23 EST by David Mason
Modified: 2015-07-28 22:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 22:46:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-01-31 00:23:58 EST
Description of problem:
Locales that are effectively equivalent such as 'es' and 'es-ES' are completely separated in Zanata. This means that translators have to join multiple language teams, more language team coordinator roles must be filled, and extra administration is required for language team management.

 - Equivalent locales should be grouped together under language teams so that there are less teams to manage and translators can join less teams.
 - Joining a team should give a translator permission to translate any of the locales that are grouped under that team.
 - A default set of language groups/teams should be present in a standard Zanata deployment, but an administrator should be able to add a new language team, change which language team a locale is grouped under, and remove an empty language team.
Comment 1 Sean Flanigan 2013-02-01 02:55:35 EST
Also, locale groups should be applied to TM requests and copyTrans.  In other words, someone translating a project in es should see es-ES translation memory results as well.
Comment 2 David Mason 2013-02-03 20:16:44 EST
Automatic merging of TM results makes sense for exactly equivalent locales, but may not be desired in some cases for closely related but not identical locales. Translators may be able to provide some insight here.

When we have implemented the ability to select different locales in the TM search, I suggest that we either:

 - provide an option to use results from each locale individually, as well as an option to use a merged set of results from all locales in the locale group for the locale of the document. The merged set might be a good default; OR

 - allow selection of any combination of locales for TM results, with all the locales in the locale group being selected by default.
Comment 3 Ding-Yi Chen 2014-03-11 20:14:20 EDT
*** Bug 1075276 has been marked as a duplicate of this bug. ***
Comment 5 Luke Brooker 2015-03-31 23:35:58 EDT
This has been brought up in user interviews. Specifically related to Chinese.
Comment 7 Damian Jansen 2015-07-13 20:20:34 EDT
Reassigned to PM
Comment 8 Zanata Migrator 2015-07-28 22:46:49 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-187

Note You need to log in before you can comment on or make changes to this bug.