Bug 906214 - [RHEV 3.1 support] check image status before start vm
Summary: [RHEV 3.1 support] check image status before start vm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: scheduler
Version: 0.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.12
Assignee: Qixiang Wan
QA Contact: Dan Callaghan
URL:
Whiteboard: Cloud
Keywords:
Depends On:
Blocks: 880002
TreeView+ depends on / blocked
 
Reported: 2013-01-31 07:03 UTC by Qixiang Wan
Modified: 2018-02-06 00:41 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-11 04:56:43 UTC


Attachments (Terms of Use)

Description Qixiang Wan 2013-01-31 07:03:15 UTC
Description of problem:
Due to bug 906213, vm will not be locked while creating the image, so vm start may happen while image is locked.

2013-01-30 19:47:57,410 beakerd ERROR Exception in exception handler :-(
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/bkr/server/tools/beakerd.py", line 477, in provision_virt_recipes
    manager.destroy_vm(system_name)
  File "/usr/lib/python2.6/site-packages/bkr/server/model.py", line 6672, in destroy_vm
    vm.delete()
  File "/usr/lib/python2.6/site-packages/ovirtsdk/infrastructure/brokers.py", line 5092, in delete
    headers={"Correlation-Id":correlation_id})
  File "/usr/lib/python2.6/site-packages/ovirtsdk/infrastructure/proxy.py", line 111, in delete
    return self.request('DELETE', url, body, headers)
  File "/usr/lib/python2.6/site-packages/ovirtsdk/infrastructure/proxy.py", line 128, in request
    last=last)
  File "/usr/lib/python2.6/site-packages/ovirtsdk/infrastructure/proxy.py", line 154, in __doRequest
    raise RequestError, response
RequestError: 
status: 400
reason: Bad Request
detail: Cannot remove VM: The disks guest_for_recipe_7_Disk1 are locked. Please try again in a few minutes.


Version-Release number of selected component (if applicable):
Beaker 0.11 + RHEV 3.1

How reproducible:
100%

Steps to Reproduce:
1. Attach a RHEV 3.1 instance to beaker server
2. Create a job which can run with rhev guests
  
Actual results:
failed to schedule recipe with rhev guests due to start vm failure

Expected results:
job can run with rhev guests

Additional info:

Comment 1 Qixiang Wan 2013-01-31 08:12:40 UTC
on gerrit: http://gerrit.beaker-project.org/#/c/1682/

Comment 4 Dan Callaghan 2013-04-11 04:56:43 UTC
Beaker 0.12 has been released.


Note You need to log in before you can comment on or make changes to this bug.