Bug 90658 - im-sdk candidate window show only white boxes
im-sdk candidate window show only white boxes
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: im-sdk (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
:
Depends On: 101377
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 00:48 EDT by Jens Petersen
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: 11.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 02:12:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of tofu boxes (3.14 KB, image/png)
2003-05-12 01:14 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2003-05-12 00:48:22 EDT
Description of problem:
When using im-sdk IM's that show a candidate window, the candidate
window only shows white tofu boxes.

Version-Release number of selected component (if applicable):
im-sdk-20030507-2

How reproducible:
Every time

Steps to Reproduce:
% export LANG=ja_JP.UTF-8
% /usr/lib/im/htt -if CannaLE &
% /usr/lib/im/httx &
% XMODIFIERS=@im=htt gedit

In gedit type
  Ctrl-Space
  t o u k y o u Space Space

Actual results:
Candidate window appears with white boxes instead of text.

Expected results:
Japanese text for henkan candidates.
Comment 1 Jens Petersen 2003-05-12 01:14:44 EDT
Created attachment 91613 [details]
screenshot of tofu boxes
Comment 2 Yu Shao 2003-05-12 01:29:35 EDT
It is a little tricky to fix, cause it is like that you need one X core fontset
to make it suitable for all non-ascii languages, I will contact with Himi anyway.
Comment 3 Leon Ho 2003-07-10 02:42:55 EDT
We may able to use the same fontset as gtkrc.utf8 for this after the XLC_LOCALE 
orders are fixed? 
Comment 4 Jens Petersen 2003-12-17 00:37:55 EST
Seems to be fine with im-sdk-11_4-2.1.
Comment 5 Jens Petersen 2003-12-17 00:58:55 EST
Errm, well ja_JP.UTF8/CannaLE is ok, but not zh_CN.UTF-8/newpy
apparently.
Comment 6 Yu Shao 2003-12-17 01:03:10 EST
I remembered it was ok with Ja and only with Ja, I will include a
patch soon.
Comment 7 Jens Petersen 2004-02-10 02:12:53 EST
This is now fixed and working in recent versions.

Note You need to log in before you can comment on or make changes to this bug.