Bug 90661 - pine doesn't show author and title of mail in the list of mail menu
pine doesn't show author and title of mail in the list of mail menu
Status: CLOSED DUPLICATE of bug 91232
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 02:58 EDT by Eric Doutreleau
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Doutreleau 2003-05-12 02:58:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.2.1) Gecko/20030225

Description of problem:
when i list list of mail from time to time pine doesn't show for one or
two mail no author and no title whereas they exist in the mail

Version-Release number of selected component (if applicable):
pine-4.44-18

How reproducible:
Sometimes

Steps to Reproduce:
1. launch pine
2. Select your inbox
3. 
    

Actual Results:  i don't have all the author and title of mail. 
In these lines i have just the date of mail that could be incorrect

Expected Results:  i would like to have all the author and the subject of the mail

Additional info:
Comment 1 Mike A. Harris 2003-05-12 15:18:28 EDT
PINE is not unicode compatible, and Red Hat Linux 8.0 and 9 default to using
unicode locales such as en_US.UTF-8 and other UTF-8 locales in all installations.

Any text mode application running in a UTF-8 locale which does not understand
UTF-8 sequences can not display them.  There are other similar problems with
different encodings being mixed, such as email in ISO8859-15 with
foreign characters being displayed to a UTF-8 terminal and being interpreted
as UTF-8 instead.

The typical visual results when an application is using one encoding, and
the terminal and other software using another encoding are screen corruption
and "garbage" displayed on screen.  Other typical results are random cursor
behavior, dissappearing characters and other visual oddities.

With applications which support UTF-8, there is no problem, as the application
uses the proper encoding that the terminal understands.  For applications
like pine however, which do not understand UTF-8, they interpret the encoding
incorrectly as they simply do not understand it.

Technically speaking, this is not a bug, but is rather simply a feature
lacking from pine and many other text mode applications.  Lack of UTF-8
support in particular.  The reason it appears to be a bug, is because
pine is being started up in an environment that it does not support.  You
must start pine and use pine only in a locale encoding which it understands,
such as ISO-8859-1 or ISO8859-15 or some other supported 8 bit locale.

To do this, run pine with:  "LANG=en_US pine" or in your case it might
perhaps be:  "LANG=fr_FR pine" instead.

Alternatively, you can disable unicode system wide if you prefer by setting
the system default locale to be non unicode.  set LANG=fr_FR in
/etc/sysconfig/i18n and reboot.

If after trying these changes, you still encounter problems, you should
seek technical support on the University of Washington's pine-info mailing
list to try and find other possible workarounds for this problem.  While
annoying, it is important to note that these types of problems will exist
as long as pine lacks unicode support.

If you still have problems after this, please report the problem directly
to the University of Washington who produces pine, so that they can
investigate the issue further and hopefully fix it in a future release.

Please update this report with your results after trying my suggestions.

You may also wish to note that pine has been deprecated from Red Hat Linux,
and will be removed from a future release of the operating system.
Comment 2 Eric Doutreleau 2003-05-16 02:48:14 EDT
okay i use the first solution to modify the LANG parameter before launching pine
and it works quite well

Thanks for the explanation
Comment 3 Mike A. Harris 2003-05-20 04:34:05 EDT

*** This bug has been marked as a duplicate of 91232 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.