Bug 906667 - RFE: put-project should be able to get the project type and project Id from zanata.xml
RFE: put-project should be able to get the project type and project Id from z...
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michelle Kim
Zanata-QA Mailling List
: screened
: 737799 (view as bug list)
Depends On:
Blocks: 907678
  Show dependency treegraph
 
Reported: 2013-02-01 02:04 EST by Ding-Yi Chen
Modified: 2015-07-28 23:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 907678 (view as bug list)
Environment:
Last Closed: 2015-07-28 23:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-02-01 02:04:30 EST
Description of problem:
In maven-client-2.0.2-SNAPSHOT, defaultProjectType become an mandatory option.
However, this is interfering the project maintainers' work flows.

Quite a few project maintainers work create a new project using following method:
1. Copy zanata.xml of other project.
2. Change the project name and version (they seldom need to change project type, as they usually deal with just one type).
3. Using either zanata client to create project.

After the introduce of defaultProjectType, now not only it breaks the existing automation scripts, but also project maintainer now need to type redundant information to command line options.

Version-Release number of selected component (if applicable):
Maven client 2.0.2-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1. Copy a existing working zanata.xml
2. Change the project id to "PushTest" or other id that haven't been used.
3. mvn -e zanata:put-project
  
Actual results:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:2.0.2-SNAPSHOT:put-project (default-cli) on project null: The parameters 'defaultProjectType' for goal org.zanata:zanata-maven-plugin:2.0.2-SNAPSHOT:put-project are missing or invalid -> [Help 1]                                                                                                                      
Expected results:
Project "PushTest" created successfully.

Additional info:
Comment 1 Ding-Yi Chen 2013-02-01 02:09:25 EST
*** Bug 737799 has been marked as a duplicate of this bug. ***
Comment 3 Damian Jansen 2015-07-13 20:21:16 EDT
Reassigned to PM
Comment 4 Zanata Migrator 2015-07-28 23:27:32 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-273

Note You need to log in before you can comment on or make changes to this bug.