Bug 909296 - [abrt] fedora-easy-karma-0-0.15.20110825git36efb338.fc16: cookies.py:270:_find_no_duplicates:CookieConflictError: There are multiple cookies with name, 'tg-visit'
[abrt] fedora-easy-karma-0-0.15.20110825git36efb338.fc16: cookies.py:270:_fin...
Status: CLOSED DUPLICATE of bug 906924
Product: Fedora
Classification: Fedora
Component: fedora-easy-karma (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
abrt_hash:ab7259ef4d4380ee3b6c67bd7b9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 10:00 EST by Samuel Greenfeld
Modified: 2013-02-08 10:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 10:13:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Greenfeld 2013-02-08 10:00:08 EST
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/fedora-easy-karma --list-rpms-only
comment:        Ran "fedora-easy-karma --list-rpms-only" after installing python-fedora-0.3.32.3-1.fc16.noarch
executable:     /usr/bin/fedora-easy-karma
kernel:         3.6.11-4.fc16.x86_64
time:           Fri 08 Feb 2013 09:56:42 AM EST
uid:            1000
username:       greenfeld

backtrace:
:cookies.py:270:_find_no_duplicates:CookieConflictError: There are multiple cookies with name, 'tg-visit'
:
:Traceback (most recent call last):
:  File "/usr/bin/fedora-easy-karma", line 510, in <module>
:    FedoraEasyKarma()
:  File "/usr/bin/fedora-easy-karma", line 310, in __init__
:    testing_updates = bc.query(release=release, status="testing", limit=1000)["updates"]
:  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 147, in query
:    return self.send_request('list', req_params=params, auth=auth)
:  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 344, in send_request
:    auth_params=auth_params, retries=retries)
:  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 381, in send_request
:    new_session = response.cookies.get(self.session_name, '')
:  File "/usr/lib/python2.7/site-packages/requests/cookies.py", line 149, in get
:    return self._find_no_duplicates(name, domain, path)
:  File "/usr/lib/python2.7/site-packages/requests/cookies.py", line 270, in _find_no_duplicates
:    raise CookieConflictError('There are multiple cookies with name, %r' % (name))
:CookieConflictError: There are multiple cookies with name, 'tg-visit'
:
:Local variables in innermost frame:
:domain: None
:name: 'tg-visit'
:toReturn: 'e0bf326be3bd2c5b18370d8e17baad2138362081'
:self: <<class 'requests.cookies.RequestsCookieJar'>[Cookie(version=0, name='tg-visit', value='e0bf326be3bd2c5b18370d8e17baad2138362081', port=None, port_specified=False, domain='', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=False, expires=None, discard=True, comment=None, comment_url=None, rest={'HttpOnly': None}, rfc2109=False), Cookie(version=0, name='tg-visit', value='c280095e13d671b3b82eaf2cac8b70a3e70df5bf', port=None, port_specified=False, domain='admin.fedoraproject.org', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'httponly': None}, rfc2109=False)]>
:cookie: Cookie(version=0, name='tg-visit', value='c280095e13d671b3b82eaf2cac8b70a3e70df5bf', port=None, port_specified=False, domain='admin.fedoraproject.org', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'httponly': None}, rfc2109=False)
:path: None
Comment 1 Toshio Ernie Kuratomi 2013-02-08 10:12:34 EST
I believe that this is the same as bug: https://bugzilla.redhat.com/show_bug.cgi?id=906924  (Note the traceback in the linked upstream bug report: https://github.com/fedora-infra/python-fedora/pull/6#issuecomment-12958779
).

I'll close this as a duplicate of the python-requests bug.  Feel free to reopen against python-fedora if this occurs after python-requests is updated.

/me also works on updating python-requests.
Comment 2 Toshio Ernie Kuratomi 2013-02-08 10:13:15 EST

*** This bug has been marked as a duplicate of bug 906924 ***

Note You need to log in before you can comment on or make changes to this bug.