Bug 908105 - mate-terminal.spec should include "Requires: mate-desktop"
Summary: mate-terminal.spec should include "Requires: mate-desktop"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-terminal
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 988944
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2013-02-05 21:51 UTC by François Cami
Modified: 2014-06-13 20:44 UTC (History)
4 users (show)

Fixed In Version: mate-terminal-1.6.1-11.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-18 00:33:52 UTC
Type: Bug


Attachments (Terms of Use)

Description François Cami 2013-02-05 21:51:17 UTC
Description of problem:
Launching mate-terminal on a system without mate-desktop installed doesn't work.

$ mate-terminal 

(mate-terminal:5148): GLib-GIO-ERROR **: Settings schema 'org.mate.interface' is not installed

Trace/breakpoint trap
$


Version-Release number of selected component (if applicable):
mate-terminal-1.5.0-1.fc18.x86_64


How reproducible: always


Steps to Reproduce:
1. Install Fedora with a non-MATE desktop environment (for instance XFCE)
2. Install mate-terminal
3. Launch mate-terminal
  

Actual results: see afore-mentioned error message.


Expected results: a nice, shiny, slightly dated but much loved terminal application appears :) 


Additional info: installing mate-desktop-1.5.5-1.fc18.x86_64 fixed the problem, because it provides the required XML file:

$ rpm -ql mate-desktop |grep interface
/usr/share/glib-2.0/schemas/org.mate.interface.gschema.xml
$

So I think mate-terminal should require mate-desktop. :)

Comment 1 Dan Mashal 2013-02-12 12:35:37 UTC
Interesting. But if I require mate-desktop then that requires a bunch of other stuff. I'll look into making mate-terminal more of a standalone package, but mate packages were made for mate desktop group. You can install gnome terminal and get practically the same thing. Don't get me wrong, I love mate-terminal but maybe just need to patch this 1 file into it. Will talk to upstream about it.

Comment 2 Dan Mashal 2013-02-16 21:52:26 UTC
Can't fix this.

Comment 3 François Cami 2013-02-16 22:32:14 UTC
Dan, you can fix this easily.
I never asked you to make mate-terminal work without mate-terminal.
But mate-terminal SHOULD work if installed via "yum install mate-terminal".
So as stated previously, please add the following line to your .spec:

Requires: mate-desktop

Comment 4 Dan Mashal 2013-02-18 21:49:12 UTC
Per your request. I thought we had a lot more hard requires in mate-desktop itself, so not really a big deal. Building on koji now.

Comment 5 Fedora Update System 2013-02-18 22:20:09 UTC
mate-terminal-1.5.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-terminal-1.5.0-3.fc18

Comment 6 Fedora Update System 2013-02-18 23:13:13 UTC
mate-terminal-1.5.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-terminal-1.5.0-3.fc17

Comment 7 François Cami 2013-02-19 18:10:48 UTC
Thank you Dan.

Comment 8 Dan Mashal 2013-02-19 21:10:21 UTC
Not a problem. Please leave karma on bodhi.

Comment 9 Fedora Update System 2013-02-20 03:59:12 UTC
Package mate-terminal-1.5.0-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-terminal-1.5.0-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2721/mate-terminal-1.5.0-3.fc17
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-03-02 20:00:54 UTC
mate-terminal-1.5.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-03-02 20:05:24 UTC
mate-terminal-1.5.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Christoph Wickert 2013-07-26 18:30:56 UTC
Please remove the dependency on mate-desktop again, you are forcing people to install half of mate if they only want a certain component. Instead, fix bug 988944. You can then savly drop the dependency as the schemas are part of the gnome-desktop-libs package which is pulled in automatically through the dependency on libmate-desktop-2.

Comment 13 Christoph Wickert 2013-07-26 19:44:13 UTC
(In reply to Christoph Wickert from comment #12)
> You can then savly drop the dependency as the schemas are part
> of the gnome-desktop-libs package which is pulled in automatically through
> the dependency on libmate-desktop-2.

Actually this is wrong, libmate-desktop2 is not pulled in automatically, so you still need to require mate-desktop-libs explicitly. Sorry, my bad.

Comment 14 Fedora Update System 2013-08-08 12:55:23 UTC
mate-terminal-1.6.1-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-terminal-1.6.1-11.fc18

Comment 15 Fedora Update System 2013-08-08 12:55:34 UTC
mate-terminal-1.6.1-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-terminal-1.6.1-11.fc19

Comment 16 Fedora Update System 2013-08-09 16:58:50 UTC
Package mate-terminal-1.6.1-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-terminal-1.6.1-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14445/mate-terminal-1.6.1-11.fc19
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2013-08-18 00:33:52 UTC
mate-terminal-1.6.1-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2013-08-18 00:40:57 UTC
mate-terminal-1.6.1-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Michael P. Curran 2014-02-06 03:26:16 UTC
I can confirm that mate-terminal 1.7.1 still requires the whole of mate-desktop and all of mate-desktop's dependencies.  I have installed mate-common and mate-desktop, and libvte-dev, in order to build the mate-terminal git package.  Now it's stating that I need even more to get it to run.  This seems very excessive for this lite package.  Here is the error I'm getting:

(mate-terminal:24528): GLib-GIO-ERROR **: Settings schema 'org.mate.interface' is not installed

Could you please let me know which package would include this schema so I can download the package and extract the schema file?  I would appreciate it.  I think you have a chance to get a much larger user base due to gnome-terminal no longer supporting a lot of functionalities like transparency, tab completion and others, but a lot of linux users will be hesitant to install mate-terminal along with all its unnecessary dependencies.

Comment 20 Michael P. Curran 2014-06-13 20:44:54 UTC
(In reply to Michael P. Curran from comment #19)
> I can confirm that mate-terminal 1.7.1 still requires the whole of
> mate-desktop and all of mate-desktop's dependencies.  I have installed
> mate-common and mate-desktop, and libvte-dev, in order to build the
> mate-terminal git package.  Now it's stating that I need even more to get it
> to run.  This seems very excessive for this lite package.  Here is the error
> I'm getting still:
> 
> (mate-terminal:24528): GLib-GIO-ERROR **: Settings schema
> 'org.mate.interface' is not installed


Is it possible to just grab the schema files from mate-desktop and force the install of mate-terminal?  This could be a very popular package now since native wm/compositor support in gnome has been dropped.  This will be my next attempt to get the most minimal (working) install of mate-terminal.  Please let me know if you have any suggestions.  I'm not that great at development; so any support/hints would be much appreciated.


Note You need to log in before you can comment on or make changes to this bug.