Bug 988944 - mate-desktop-libs should not require mate-desktop
mate-desktop-libs should not require mate-desktop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-desktop (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: depchain 908105 974791
  Show dependency treegraph
 
Reported: 2013-07-26 14:24 EDT by Christoph Wickert
Modified: 2013-08-17 20:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-desktop-1.6.1-11.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 20:31:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the spec file in rawhide (3.03 KB, patch)
2013-07-26 14:26 EDT, Christoph Wickert
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2013-07-26 14:24:45 EDT
Description of problem:
mate-desktop is kind of a meta-package. It has a lot of dependencies but only contains a single binary (mate-about).

The problem is that a lot of mate components require libmate-desktop-2, just like with gnome-desktop and libgnome-desktop, see bug 693547. The the dependency to mate-desktop you are forcing people to install half of Mate, even if they want to only use a a certain component or program.

Same goes for the gsettings schemas. They need to be present, otherwise the applications crash as in bug 908105, bug 974791, bug 988278 and possibly others.

The simple solution is to drop the dependency from -libs to the base package but move the locales and the schema to -libs instead.

Long story short: Something that is called *-libs should never explicitly require it's base package. The dependency goes vice versa from the base package to the libs.
Comment 1 Christoph Wickert 2013-07-26 14:26:52 EDT
Created attachment 778850 [details]
patch for the spec file in rawhide
Comment 2 Wolfgang Ulbrich 2013-07-27 09:08:25 EDT
You have to talk with Dan about the mate-desktop package split, but i did say to him that i see no reason not to do this.
Comment 3 Fedora Update System 2013-08-07 19:36:52 EDT
mate-desktop-1.6.1-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-desktop-1.6.1-11.fc18
Comment 4 Fedora Update System 2013-08-07 19:37:01 EDT
mate-desktop-1.6.1-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-desktop-1.6.1-11.fc19
Comment 5 Fedora Update System 2013-08-09 13:07:53 EDT
Package mate-desktop-1.6.1-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-desktop-1.6.1-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14497/mate-desktop-1.6.1-11.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-08-17 20:31:43 EDT
mate-desktop-1.6.1-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-08-17 20:36:58 EDT
mate-desktop-1.6.1-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.