Bug 908143 - [abrt] evolution-3.7.4-1.fc19: WebCore::AccessibilityTableRow::parentTable: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.7.4-1.fc19: WebCore::AccessibilityTableRow::parentTable: P...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: webkitgtk3 (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:96720264df556780634a3741146...
:
: 919919 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 21:05 EST by Adam Williamson
Modified: 2013-03-20 03:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: webkitgtk3-1.11.5-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 03:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (89.22 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: build_ids (13.08 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: cgroup (172 bytes, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: core_backtrace (10.46 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: dso_list (32.55 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: environ (2.58 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: limits (1.72 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: maps (162.05 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: open_fds (2.52 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: proc_pid_status (1.24 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: smolt_data (4.39 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
File: var_log_messages (3.84 KB, text/plain)
2013-02-05 21:06 EST, Adam Williamson
no flags Details
decoded backtrace (hopefuly full) (66.92 KB, application/octet-stream)
2013-02-07 06:48 EST, Jiri Moskovcak
no flags Details

  None (edit)
Description Adam Williamson 2013-02-05 21:05:53 EST
Description of problem:
This crash has been happening frequently since upgrade to Rawhide, doesn't seem to be in relation to a single specific operation, but usually when clicking on a mail.

Version-Release number of selected component:
evolution-3.7.4-1.fc19

Additional info:
backtrace_rating: 4
cmdline:        evolution
crash_function: WebCore::AccessibilityTableRow::parentTable
executable:     /usr/bin/evolution
kernel:         3.8.0-0.rc6.git0.2.fc19.x86_64
remote_result:  NOTFOUND
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 WebCore::AccessibilityTableRow::parentTable at /lib64/libwebkitgtk-3.0.so.0
 #1 WebCore::AccessibilityTableRow::isTableRow at /lib64/libwebkitgtk-3.0.so.0
 #2 WebCore::AccessibilityTableRow::roleValue at /lib64/libwebkitgtk-3.0.so.0
 #3 webkitAccessibleDetach at /lib64/libwebkitgtk-3.0.so.0
 #4 WebCore::AXObjectCache::remove at /lib64/libwebkitgtk-3.0.so.0
 #6 WebCore::RenderObject::willBeDestroyed at /lib64/libwebkitgtk-3.0.so.0
 #7 WebCore::RenderObject::destroy at /lib64/libwebkitgtk-3.0.so.0
 #8 WebCore::RenderObjectChildList::destroyLeftoverChildren at /lib64/libwebkitgtk-3.0.so.0
 #9 WebCore::RenderObject::willBeDestroyed at /lib64/libwebkitgtk-3.0.so.0
 #10 WebCore::RenderObject::destroy at /lib64/libwebkitgtk-3.0.so.0
Comment 1 Adam Williamson 2013-02-05 21:06:21 EST
Created attachment 693619 [details]
File: backtrace
Comment 2 Adam Williamson 2013-02-05 21:06:23 EST
Created attachment 693620 [details]
File: build_ids
Comment 3 Adam Williamson 2013-02-05 21:06:25 EST
Created attachment 693621 [details]
File: cgroup
Comment 4 Adam Williamson 2013-02-05 21:06:27 EST
Created attachment 693622 [details]
File: core_backtrace
Comment 5 Adam Williamson 2013-02-05 21:06:29 EST
Created attachment 693623 [details]
File: dso_list
Comment 6 Adam Williamson 2013-02-05 21:06:31 EST
Created attachment 693624 [details]
File: environ
Comment 7 Adam Williamson 2013-02-05 21:06:33 EST
Created attachment 693625 [details]
File: limits
Comment 8 Adam Williamson 2013-02-05 21:06:35 EST
Created attachment 693626 [details]
File: maps
Comment 9 Adam Williamson 2013-02-05 21:06:37 EST
Created attachment 693627 [details]
File: open_fds
Comment 10 Adam Williamson 2013-02-05 21:06:39 EST
Created attachment 693628 [details]
File: proc_pid_status
Comment 11 Adam Williamson 2013-02-05 21:06:41 EST
Created attachment 693629 [details]
File: smolt_data
Comment 12 Adam Williamson 2013-02-05 21:06:43 EST
Created attachment 693630 [details]
File: var_log_messages
Comment 13 Milan Crha 2013-02-06 02:50:46 EST
Thanks for a bug report. Unfortunately the ABRT did a bad job with attachments (see bug #908210), though from the truncated backtrace it seems like a webkit bug, thus I'm moving it there.
Comment 14 Jiri Moskovcak 2013-02-07 06:48:40 EST
Created attachment 694424 [details]
decoded backtrace (hopefuly full)
Comment 15 Tomas Popela 2013-02-07 10:18:32 EST
I think it is the same as upstream bug https://bugs.webkit.org/show_bug.cgi?id=106903 . When the patch will be ready we will update the webkitgtk3 package.
Comment 16 Adam Williamson 2013-02-13 17:22:16 EST
Thanks. FWIW, due to this bug, https://bugzilla.gnome.org/show_bug.cgi?id=693101 and a few others, I've switched to Thunderbird for now - current Rawhide Evo is just too badly broken to use.
Comment 17 Tomas Popela 2013-02-15 03:05:24 EST
Fixed in webkitgtk3-1.11.5-2.fc19
Comment 18 Milan Crha 2013-03-11 05:15:15 EDT
*** Bug 919919 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.