Bug 908274 - $dev->get_parent() can't get undef if there is no parent
Summary: $dev->get_parent() can't get undef if there is no parent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Sys-Virt
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-06 10:15 UTC by zhe peng
Modified: 2016-04-26 16:27 UTC (History)
6 users (show)

Fixed In Version: perl-Sys-Virt-0.10.2-6.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, using the libvirt-tck utility to find the parent device of a node device with no parent incorrectly returned a "libvirt error code: 0" error message. Now, it is valid for the virNodeDeviceGetParent() function to return NULL if the parent device is nonexistent, and the error message is no longer displayed.
Clone Of:
: 994141 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:24:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1387 normal SHIPPED_LIVE perl-Sys-Virt bug fix update 2015-07-20 17:58:14 UTC

Description zhe peng 2013-02-06 10:15:08 UTC
Description of problem:
When try to get parent of nodedev if there is no parent,libvirt-tck get error.


Version-Release number of selected component (if applicable):
libvirt-0.10.2-17.el6.x86_64
perl-Sys-Virt-0.10.2-5.el6.x86_64
kernel-2.6.32-348.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.in libvirt-tck script,added
.....
my @nodelist = $conn->list_all_node_devices();
  foreach my $dev (@nodelist){
  my $parent = $dev->get_parent();
  diag $parent;
}
.....

Actual results:

libvirt error code: 0, message: Unknown problem



Expected results:
should return "undef"

Additional info:
the first item in nodelist is "computer",no parent.
use python interface can return "None".

Comment 1 Daniel Berrangé 2013-08-06 13:29:00 UTC
commit 04470fa5412cbd04386c5c2e785e4672cc6e0e0f
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Aug 6 14:23:55 2013 +0100

    Fix error handling for virNodeDeviceGetParent()
    
    It is valid for virNodeDeviceGetParent() to return NULL in the
    case where there is no parent device present.
    
    Signed-off-by: Daniel P. Berrange <berrange@redhat.com>

Comment 4 zhe peng 2015-03-25 08:06:46 UTC
verify with build:perl-Sys-Virt-0.10.2-6.el6.x86_64

step:

same step with bug description
no libvirt error return.

move to verified.

Comment 5 errata-xmlrpc 2015-07-22 07:24:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1387.html


Note You need to log in before you can comment on or make changes to this bug.