Bug 908408 - full-screen=auto-conf -- setting resolution in a loop
Summary: full-screen=auto-conf -- setting resolution in a loop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 952327
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-06 16:05 UTC by Tomas Jamrisko
Modified: 2013-11-21 08:07 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to connect to a multi-monitor guest in fullscreen mode, secondary monitors would sometimes keep flashing in a loop. Now, an unecessary extra monitor reconfiguration message has been removed and any extra monitors no longer flash when in fullscreen mode.
Clone Of:
Environment:
Last Closed: 2013-11-21 08:07:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
Output from remote-viewer (10.10 KB, application/octet-stream)
2013-02-06 16:05 UTC, Tomas Jamrisko
no flags Details
Log from vdagent (10.02 KB, text/plain)
2013-02-06 16:05 UTC, Tomas Jamrisko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Tomas Jamrisko 2013-02-06 16:05:05 UTC
Created attachment 694015 [details]
Output from remote-viewer

Description of problem:
Adding --full-screen=auto-conf option when connecting to a windows 7 guest with 2 monitors both on client and guest results in periodical flickering (configuration is periodically updated, even though there is no change)

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Setup a windows 7 VM with 2 qxl devices
2. Connect to it with --full-screen=auto-conf option
  
Actual results:
Displays flicker often enough to prevent any sort of meaningful work.

Expected results:
it should not update the configuration so often

Comment 1 Tomas Jamrisko 2013-02-06 16:05:40 UTC
Created attachment 694016 [details]
Log from vdagent

Comment 3 RHEL Product and Program Management 2013-02-11 06:48:49 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Marc-Andre Lureau 2013-05-09 14:52:20 UTC
Tomas, isn't there an already fixed bug for RHEV/mingw-virt-viewer? Can you add dependency relation between them? thanks

Comment 6 Tomas Jamrisko 2013-05-09 15:50:50 UTC
I believe you mean this one, right? https://bugzilla.redhat.com/show_bug.cgi?id=952327

Adding it as dependency.

Comment 7 Marc-Andre Lureau 2013-05-09 16:07:55 UTC
thanks! -> POST

Comment 13 tingting zheng 2013-07-08 03:12:49 UTC
Tested with:
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64

# rpm -qa |grep spice
spice-gtk-tools-0.20-1.el6.x86_64
spice-glib-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-gtk-0.20-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

Steps:
1. Setup a windows 7 VM with 2 qxl devices
2. Connect to it with --full-screen=auto-conf option

The displays don't flickek,guest can work well,so move the bug to VERIFIED.

Comment 14 errata-xmlrpc 2013-11-21 08:07:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.