Bug 952327 - with RHEV-M's "full screen" or CLI "--full-screen=auto-conf", secondary monitor of the guest keeps flashing
Summary: with RHEV-M's "full screen" or CLI "--full-screen=auto-conf", secondary monit...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.2.0
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
: 922391 952691 (view as bug list)
Depends On:
Blocks: 908408
TreeView+ depends on / blocked
 
Reported: 2013-04-15 16:34 UTC by David Jaša
Modified: 2018-12-01 15:25 UTC (History)
11 users (show)

Fixed In Version: mingw-virt-viewer-0.5.3-25.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to connect to a multi-monitor guest in fullscreen mode, secondary monitors would sometimes keep flashing in a loop. Now, an unecessary extra monitor reconfiguration message has been removed and any extra monitors no longer flash when in fullscreen mode.
Clone Of:
Environment:
Last Closed: 2013-06-10 20:04:42 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
vdagent.log (30.60 KB, text/plain)
2013-04-23 10:21 UTC, David Jaša
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:0889 0 normal SHIPPED_LIVE mingw-virt-viewer enhancement update 2013-06-10 23:53:14 UTC

Description David Jaša 2013-04-15 16:34:17 UTC
Description of problem:
with RHEV-M's "full screen" or CLI "--full-screen=auto-conf", secondary monitor of the guest keeps flashing (as if the resolution of it was changing in the loop - to the same one)

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-24 / Windows XP
vdagent-win -16 (Windows 7 64b)
qxl-win -16

How reproducible:
always

Steps to Reproduce:
1. have a windows VM with 2+ monitor but just one active
2. connect to the VM from 2+ monitor client with RHEV-M "Full screen" checked or with "--full-screen=auto-conf" on CLI
3.
  
Actual results:
after the connection, the second monitor keeps flashing and can not be effectively used because any mouse work is interrupted every other second

Expected results:
second monitor flashes just once at guest monitor resolution is adjusted to client one

Additional info:

Comment 1 David Jaša 2013-04-16 15:00:56 UTC
*** Bug 952691 has been marked as a duplicate of this bug. ***

Comment 2 David Jaša 2013-04-16 15:01:54 UTC
Contrary to Vimal's setup, the first monitor was still perfectly usable but the secondary kept flashing. Things were OK when going fullscreen from windowed mode.

Comment 8 Marc-Andre Lureau 2013-04-22 19:38:06 UTC
very likely vdagent bug, due to custom resolution regression when enabling extra monitors.

Comment 9 Marc-Andre Lureau 2013-04-22 21:12:44 UTC
Please grab the vdagent.log, thanks

Comment 10 David Jaša 2013-04-23 10:21:02 UTC
Created attachment 738926 [details]
vdagent.log

vdservice.log:
2100::INFO::2013-04-23 06:15:10,062::VDService::main::***Service started***
2100::INFO::2013-04-23 06:15:10,062::log_version::1.1.0.10016
2100::INFO::2013-04-23 06:15:10,062::VDService::execute::Active console session id: 1
2100::INFO::2013-04-23 06:15:10,070::VDService::execute::Connect state: 0

Comment 12 Marc-Andre Lureau 2013-04-23 12:50:34 UTC
Sent patch to fix this on spice-gtk side:

http://lists.freedesktop.org/archives/spice-devel/2013-April/013171.html

It would be worth to fix vdagent too to not reconfigure monitor with same config, but it's another story.

Comment 13 Arnon Gilboa 2013-04-24 12:12:18 UTC
(In reply to comment #12)
> Sent patch to fix this on spice-gtk side:
> 
> http://lists.freedesktop.org/archives/spice-devel/2013-April/013171.html
> 
> It would be worth to fix vdagent too to not reconfigure monitor with same
> config, but it's another story.

will give it a look from vdagent side.

Comment 16 Bill Sanford 2013-04-26 19:12:15 UTC
This is verified with RHEV-M 3.2 (sf14) and virt-viewer 0.5.3-23.

Comment 17 Bill Sanford 2013-04-30 13:05:40 UTC
Wrong bug verified.

Comment 18 Bill Sanford 2013-04-30 15:16:40 UTC
This is now verified with spice-client-msi-3.2-10 and mingw-virt-viewer 0.5.3-25.

Comment 19 Marc-Andre Lureau 2013-05-06 10:29:22 UTC
*** Bug 922391 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2013-06-10 20:04:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0889.html


Note You need to log in before you can comment on or make changes to this bug.