Bug 908717 - mathtext fonts missing?
Summary: mathtext fonts missing?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-matplotlib
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-07 11:27 UTC by Fabian
Modified: 2013-07-25 00:49 UTC (History)
8 users (show)

Fixed In Version: python-matplotlib-1.2.0-14.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-25 00:33:43 UTC


Attachments (Terms of Use)
Example Python script and result images (50.00 KB, application/x-tar)
2013-02-07 11:27 UTC, Fabian
no flags Details

Description Fabian 2013-02-07 11:27:44 UTC
Created attachment 694421 [details]
Example Python script and result images

Description of problem: Mathtext rendering failed (printed cryptic characters instead of rendered mathematical expressions), apparantly due to some necessary fonts not installed.

Version-Release number of selected component (if applicable):
default version from repository (1.2.0)

How reproducible:
Use matplotlibs mathtext (without package lyx-fonts installed). The following reproduces the issue on my system (see attached test.py and result images (tar'ed)).

    # rendering fails
    sudo yum remove lyx-fonts -y
    python test.py
    # rendering succeeds
    sudo yum install lyx-fonts -y
    python test.py

The package lyx-fonts was not installed by default (e.g., as dependency) for me.

Note:
The suggestion to install lyx-fonts comes from this comment on another bug report (on the same bug I suppose): 

    https://bugzilla.redhat.com/show_bug.cgi?id=562421#c31

Comment 1 Paulo Andrade 2013-02-07 14:03:35 UTC
checking the fonts ...

$ repoquery -f '*/cm*.ttf'
lyx-fonts-0:2.0.5.1-1.fc19.noarch
ncl-0:6.1.0-2.fc19.x86_64

Removing lyx-fonts and installing ncl in my
computer does not correct the problem in your
sample script...
$ rpm -ql ncl|egrep 'cm.*ttf$'
/usr/lib64/ncarg/database/ftfonts/cmex10.ttf
/usr/lib64/ncarg/database/ftfonts/cmsy10.ttf
(expected as ncl does not tell about it to fontconfig)

and poor python-matplotlib does not bundle any font...
but it has those in .afm format:

ls BUILD/matplotlib-1.2.0/lib/matplotlib/mpl-data/fonts/afm
cmex10.afm   pagko8a.afm  pcrro8a.afm   phvr8an.afm   pplbi8a.afm  putb8a.afm
cmmi10.afm   pbkd8a.afm   phvb8a.afm    phvro8a.afm   pplr8a.afm   putbi8a.afm
cmr10.afm    pbkdi8a.afm  phvb8an.afm   phvro8an.afm  pplri8a.afm  putr8a.afm
cmsy10.afm   pbkl8a.afm   phvbo8a.afm   pncb8a.afm    psyr.afm     putri8a.afm
cmtt10.afm   pbkli8a.afm  phvbo8an.afm  pncbi8a.afm   ptmb8a.afm   pzcmi8a.afm
pagd8a.afm   pcrb8a.afm   phvl8a.afm    pncr8a.afm    ptmbi8a.afm  pzdr.afm
pagdo8a.afm  pcrbo8a.afm  phvlo8a.afm   pncri8a.afm   ptmr8a.afm
pagk8a.afm   pcrr8a.afm   phvr8a.afm    pplb8a.afm    ptmri8a.afm

A solution could be to
reopen https://bugzilla.redhat.com/show_bug.cgi?id=885312
and probably (request to) fix lyx-fonts and ncl to not bundle
the fonts. But I am afraid the naming pattern used in
jsmath-fonts, due to the jsMath- prefix may cause it to not
be properly used by matplotlib.

An easier solution could be to patch
%{python_sitearch}/matplotlib/mpl-data/matplotlibrc

or in the case of your sample script, the pseudo patch:
 import matplotlib.pyplot as plt
+plt.rcParams['mathtext.fontset'] = "stix"
 plt.plot([1,5])

the comment in matplotlibrc says:
#mathtext.fontset : cm # Should be 'cm' (Computer Modern), 'stix',
                       # 'stixsans' or 'custom'

Comment 2 Fedora Update System 2013-03-28 20:30:43 UTC
python-matplotlib-1.2.0-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-10.fc18

Comment 3 Fedora Update System 2013-04-02 17:49:07 UTC
python-matplotlib-1.2.0-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-11.fc18

Comment 4 Fedora Update System 2013-04-03 01:20:26 UTC
python-matplotlib-1.2.0-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-12.fc18

Comment 5 Fedora Update System 2013-04-03 01:20:51 UTC
python-matplotlib-1.2.0-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-12.fc19

Comment 6 Fedora Update System 2013-04-03 04:55:00 UTC
Package python-matplotlib-1.2.0-11.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-matplotlib-1.2.0-11.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4741/python-matplotlib-1.2.0-11.fc18
then log in and leave karma (feedback).

Comment 7 Fabian 2013-04-03 18:07:34 UTC
(In reply to comment #6)
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing python-matplotlib-1.2.0-11.fc18'

I installed the update and the new dependency to stix-math-fonts but apparantly this did not fix the problem. 

To workaround this I (still) need to specify to use the stix fonts explicitly (or install lyx-fonts as initially stated):

plt.rcParams['mathtext.fontset'] = "stix"

Is matplotlib configured to use the wrong fontset by default?

Comment 8 Paulo Andrade 2013-04-03 20:54:00 UTC
You are right. My patch was not properly tested, the portion
to change matplotlibrc is bogus because the matplotlibrc
is recreated from matplotlibrc.template

Well, too bad that that when using a python-matplotlib with
the proper patch, it fails to regenerate python-matplotlib
documentation with a crash in python...

(gdb)  r /usr/bin/sphinx-build -b html -d build/doctrees . build/html
Starting program: /usr/bin/python2.7 /usr/bin/sphinx-build -b html -d build/doctrees . build/html
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Detaching after fork from child process 13536.
Detaching after fork from child process 13538.
Running Sphinx v1.1.3
Initializing GitHub plugin
loading pickled environment... not yet created
animation, api, axes_grid, event_handling, misc, mplot3d, old_animation, pylab_examples, tests, units, user_interfaces, widgets, 
building [html]: targets for 565 source files that are out of date
updating environment: 565 added, 0 changed, 0 removed
Detaching after fork from child process 13540.                                  
Detaching after fork from child process 13541.
Detaching after fork from child process 13542.
Detaching after fork from child process 13543.
Missing separate debuginfo for /lib64/libgraphite2.so.3                         
Try: yum --disablerepo='*' --enablerepo='*debug*' install /usr/lib/debug/.build-id/dd/25c9f750a76a85b7285cd94208ef21651a8ee1.debug
Detaching after fork from child process 13608.fine_image                        
Detaching after fork from child process 13609.emo_parasite_axes2                
Detaching after fork from child process 13610.les/fancybox_demo                 
Detaching after fork from child process 13612.les/mathtext_examples             
Detaching after fork from child process 13613.
Detaching after fork from child process 13614.
Detaching after fork from child process 13615.
Detaching after fork from child process 13616.
Detaching after fork from child process 13617.
Detaching after fork from child process 13618.
Detaching after fork from child process 13619.
Detaching after fork from child process 13620.
Detaching after fork from child process 13621.
Detaching after fork from child process 13622.
Detaching after fork from child process 13623.
Detaching after fork from child process 13624.
Detaching after fork from child process 13625.
Detaching after fork from child process 13626.
Detaching after fork from child process 13627.
Detaching after fork from child process 13628.
Detaching after fork from child process 13629.
Detaching after fork from child process 13630.

Program received signal SIGSEGV, Segmentation fault.
visit_decref (op=<unknown at remote 0x-100>, data=0x0)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:389
389         if (PyObject_IS_GC(op)) {
Missing separate debuginfos, use: debuginfo-install PyQt4-4.10-2.fc20.x86_64 SDL-1.2.15-7.fc20.x86_64 agg-2.5-16.fc19.x86_64 atk-2.8.0-1.fc20.x86_64 atlas-3.8.4-8.fc19.x86_64 cairo-1.12.14-1.fc19.x86_64 expat-2.1.0-5.fc19.x86_64 fontconfig-2.10.92-2.fc20.x86_64 freetype-2.4.11-3.fc20.x86_64 gdk-pixbuf2-2.28.0-1.fc20.x86_64 glib2-2.36.0-1.fc20.x86_64 glibc-2.17-5.fc20.x86_64 gtk2-2.24.17-1.fc19.x86_64 harfbuzz-0.9.14-1.fc20.x86_64 jbigkit-libs-2.0-8.fc19.x86_64 keyutils-libs-1.5.5-4.fc19.x86_64 krb5-libs-1.11.1-6.fc20.x86_64 libICE-1.0.8-5.fc19.x86_64 libSM-1.2.1-5.fc19.x86_64 libX11-1.5.99.901-2.fc19.x86_64 libXau-1.0.6-7.fc19.x86_64 libXcomposite-0.4.4-3.fc19.x86_64 libXcursor-1.1.13-4.fc19.x86_64 libXdamage-1.1.4-3.fc19.x86_64 libXext-1.3.1-4.fc19.x86_64 libXfixes-5.0-5.fc19.x86_64 libXi-1.7-1.fc19.x86_64 libXinerama-1.1.2-4.fc19.x86_64 libXrandr-1.4.0-3.fc19.x86_64 libXrender-0.9.7-4.fc19.x86_64 libXxf86vm-1.1.2-4.fc19.x86_64 libcom_err-1.42.7-2.fc19.x86_64 libdrm-2.4.42-2.fc19.x86_64 libffi-3.0.13-1.fc20.x86_64 libgcc-4.8.0-0.18.fc20.x86_64 libgfortran-4.8.0-0.18.fc20.x86_64 libicu-50.1.2-5.fc19.x86_64 libjpeg-turbo-1.2.90-2.fc20.x86_64 libpng-1.5.13-2.fc19.x86_64 libquadmath-4.8.0-0.18.fc20.x86_64 libselinux-2.1.13-12.fc20.x86_64 libstdc++-4.8.0-0.18.fc20.x86_64 libtiff-4.0.3-5.fc19.x86_64 libuuid-2.23-0.1.fc20.x86_64 libwayland-client-1.0.6-1.fc20.x86_64 libwayland-server-1.0.6-1.fc20.x86_64 libxcb-1.9-2.fc19.x86_64 mesa-libEGL-9.1-3.fc20.x86_64 mesa-libGL-9.1-3.fc20.x86_64 mesa-libgbm-9.1-3.fc20.x86_64 mesa-libglapi-9.1-3.fc20.x86_64 numpy-1.7.0-1.fc19.x86_64 openssl-libs-1.0.1e-4.fc20.x86_64 pango-1.34.0-1.fc20.x86_64 pcre-8.32-4.fc19.x86_64 pixman-0.28.0-3.fc19.x86_64 python-markupsafe-0.11-8.fc19.x86_64 python-pillow-2.0.0-3.gitde210a2.fc20.x86_64 qt-4.8.4-15.fc20.x86_64 qt-x11-4.8.4-15.fc20.x86_64 sip-4.14.5-1.fc20.x86_64 systemd-libs-200-3.fc20.x86_64 wxBase-2.8.12-8.fc19.x86_64 wxGTK-2.8.12-8.fc19.x86_64 wxPython-2.8.12.0-4.fc19.x86_64 zlib-1.2.7-10.fc19.x86_64
(gdb) bt
#0  visit_decref (op=<unknown at remote 0x-100>, data=0x0)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:389
#1  0x0000003dbe67f1d6 in dict_traverse (op=
    {'rawsource': u':func:`matplotlib.projections.register_projection`', 0x0: <unknown at remote 0x-100>, 'parent': <paragraph(rawsource=u'By defining the class attribute ``name``, the projection axes can be\nregistered with :func:`matplotlib.projections.register_projection`\nand subsequently simply invoked by name::', parent=<list_item(rawsource=u"By defining the class attribute ``name``, the projection axes can be\nregistered with :func:`matplotlib.projections.register_projection`\nand subsequently simply invoked by name::\n\n    plt.axes(projection='my_proj_name')\n", attributes={'dupnames': [], 'classes': [], 'backrefs': [], 'ids': [], 'names': []}, parent=<bullet_list(rawsource='', attributes={'bullet': u'-', 'ids': [], 'backrefs': [], 'dupnames': [], 'classes': [], 'names': []}, parent=<block_quote(rawsource='', parent=<section(rawsource='', parent=<section(rawsource='', parent=<document(nametypes={u'creating a new projection': None, u'matplotlib.projections.polar.PolarAxes': True, u'matplotlib.projections....(truncated), visit=0x3dbe7096c0 <visit_decref>, arg=0x0)
    at /usr/src/debug/Python-2.7.3/Objects/dictobject.c:2097
#2  0x0000003dbe709a77 in subtract_refs (
    containers=0x3dbe9a4f20 <generations+96>)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:416
#3  collect (generation=2)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:948
#4  0x0000003dbe70a687 in collect_generations ()
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:1070
#5  _PyObject_GC_Malloc (basicsize=18446744073709551360)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:1531
#6  0x0000003dbe70a706 in _PyObject_GC_NewVar (
    tp=tp@entry=0x3dbe98f760 <PyTuple_Type>, nitems=nitems@entry=2)
    at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:1551
#7  0x0000003dbe6972af in PyTuple_New (size=size@entry=2)
    at /usr/src/debug/Python-2.7.3/Objects/tupleobject.c:106
#8  0x0000003dbe6d9a26 in PyEval_EvalFrameEx (
    f=f@entry=Frame 0x591e380, for file /home/pcpa/rpmbuild/BUILD/matplotlib-1.2.0/build/lib.linux-x86_64-2.7/matplotlib/mathtext.py, line 556, in __init__ (self=<CachedFont(charmap={32L: 3, 33L: 4, 34L: 5, 35L: 6, 36L: 7, 37L: 8, 38L: 9, 39L: 10, 40L: 11, 41L: 12, 42L: 13, 43L: 14, 44L: 15, 45L: 16, 46L: 17, 47L: 18, 48L: 19, 49L: 20, 50L: 21, 51L: 22, 52L: 23, 53L: 24, 54L: 25, 55L: 26, 56L: 27, 57L: 28, 58L: 29, 59L: 30, 60L: 31, 61L: 32, 62L: 33, 63L: 34, 64L: 35, 65L: 36, 66L: 37, 67L: 38, 68L: 39, 69L: 40, 70L: 41, 71L: 42, 72L: 43, 73L: 44, 74L: 45, 75L: 46, 76L: 47, 77L: 48, 78L: 49, 79L: 50, 80L: 51, 81L: 52, 82L: 53, 83L: 54, 84L: 55, 85L: 56, 86L: 57, 87L: 58, 88L: 59, 89L: 60, 90L: 61, 91L: 62, 92L: 63, 93L: 64, 94L: 65, 95L: 66, 96L: 67, 97L: 68, 98L: 69, 99L: 70, 100L: 71, 101L: 72, 102L: 73, 103L: 74, 104L: 75, 105L: 76, 106L: 77, 107L: 78, 108L: 79, 109L: 80, 110L: 81, 111L: 82, 112L: 83, 113L: 84, 114L: 85, 115L: 86, 116L: 87, 117L: 88, 118L: 89, 119L: 90, 120L: 91, 121L: 92, 122L: 93, 123L: 94, 124L: 95, ...(truncated), throwflag=throwflag@entry=0)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:2252
#9  0x0000003dbe6dd58d in PyEval_EvalCodeEx (co=<optimized out>, 
    globals=<optimized out>, locals=locals@entry=0x0, 
    args=args@entry=0xf27b8d8, argcount=2, kws=kws@entry=0x0, 
    kwcount=kwcount@entry=0, defs=defs@entry=0x0, defcount=defcount@entry=0, 
    closure=0x0) at /usr/src/debug/Python-2.7.3/Python/ceval.c:3330
#10 0x0000003dbe66d2e0 in function_call (func=<function at remote 0x1744230>, 
    arg=(<CachedFont(charmap={32L: 3, 33L: 4, 34L: 5, 35L: 6, 36L: 7, 37L: 8, 38L: 9, 39L: 10, 40L: 11, 41L: 12, 42L: 13, 43L: 14, 44L: 15, 45L: 16, 46L: 17, 47L: 18, 48L: 19, 49L: 20, 50L: 21, 51L: 22, 52L: 23, 53L: 24, 54L: 25, 55L: 26, 56L: 27, 57L: 28, 58L: 29, 59L: 30, 60L: 31, 61L: 32, 62L: 33, 63L: 34, 64L: 35, 65L: 36, 66L: 37, 67L: 38, 68L: 39, 69L: 40, 70L: 41, 71L: 42, 72L: 43, 73L: 44, 74L: 45, 75L: 46, 76L: 47, 77L: 48, 78L: 49, 79L: 50, 80L: 51, 81L: 52, 82L: 53, 83L: 54, 84L: 55, 85L: 56, 86L: 57, 87L: 58, 88L: 59, 89L: 60, 90L: 61, 91L: 62, 92L: 63, 93L: 64, 94L: 65, 95L: 66, 96L: 67, 97L: 68, 98L: 69, 99L: 70, 100L: 71, 101L: 72, 102L: 73, 103L: 74, 104L: 75, 105L: 76, 106L: 77, 107L: 78, 108L: 79, 109L: 80, 110L: 81, 111L: 82, 112L: 83, 113L: 84, 114L: 85, 115L: 86, 116L: 87, 117L: 88, 118L: 89, 119L: 90, 120L: 91, 121L: 92, 122L: 93, 123L: 94, 124L: 95, 125L: 96, 126L: 97, 160L: 98, 161L: 99, 162L: 100, 163L: 101, 164L: 102, 165L: 103, 166L: 104, 167L: 105, 168L: 106, 169L: 107, 170L: 108, 171L: 10...(truncated), kw=0x0) at /usr/src/debug/Python-2.7.3/Objects/funcobject.c:526
11 0x0000003dbe649a73 in PyObject_Call (
    func=func@entry=<function at remote 0x1744230>, 
    arg=arg@entry=(<CachedFont(charmap={32L: 3, 33L: 4, 34L: 5, 35L: 6, 36L: 7, 37L: 8, 38L: 9, 39L: 10, 40L: 11, 41L: 12, 42L: 13, 43L: 14, 44L: 15, 45L: 16, 46L: 17, 47L: 18, 48L: 19, 49L: 20, 50L: 21, 51L: 22, 52L: 23, 53L: 24, 54L: 25, 55L: 26, 56L: 27, 57L: 28, 58L: 29, 59L: 30, 60L: 31, 61L: 32, 62L: 33, 63L: 34, 64L: 35, 65L: 36, 66L: 37, 67L: 38, 68L: 39, 69L: 40, 70L: 41, 71L: 42, 72L: 43, 73L: 44, 74L: 45, 75L: 46, 76L: 47, 77L: 48, 78L: 49, 79L: 50, 80L: 51, 81L: 52, 82L: 53, 83L: 54, 84L: 55, 85L: 56, 86L: 57, 87L: 58, 88L: 59, 89L: 60, 90L: 61, 91L: 62, 92L: 63, 93L: 64, 94L: 65, 95L: 66, 96L: 67, 97L: 68, 98L: 69, 99L: 70, 100L: 71, 101L: 72, 102L: 73, 103L: 74, 104L: 75, 105L: 76, 106L: 77, 107L:
 78, 108L: 79, 109L: 80, 110L: 81, 111L: 82, 112L: 83, 113L: 84, 114L: 85, 115L: 86, 116L: 87, 117L: 88, 118L: 89, 119L: 90, 120L: 91, 121L: 92, 122L: 93, 123L: 94, 124L: 95, 125L: 96, 126L: 97, 160L: 98, 161L: 99, 162L: 100, 163L: 101, 164L: 102, 165L: 103, 166L: 104, 167L: 105, 168L: 106, 169L: 107, 170L: 108, 171L: 10...(truncated), kw=kw@entry=0x0)
    at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2529
#12 0x0000003dbe658085 in instancemethod_call (
    func=<function at remote 0x1744230>, 
    arg=(<CachedFont(charmap={32L: 3, 33L: 4, 34L: 5, 35L: 6, 36L: 7, 37L: 8, 38L: 9, 39L: 10, 40L: 11, 41L: 12, 42L: 13, 43L: 14, 44L: 15, 45L: 16, 46L: 17, 47L: 18, 48L: 19, 49L: 20, 50L: 21, 51L: 22, 52L: 23, 53L: 24, 54L: 25, 55L: 26, 56L: 27, 57L: 28, 58L: 29, 59L: 30, 60L: 31, 61L: 32, 62L: 33, 63L: 34, 64L: 35, 65L: 36, 66L: 37, 67L: 38, 68L: 39, 69L: 40, 70L: 41, 71L: 42, 72L: 43, 73L: 44, 74L: 45, 75L: 46, 76L: 47, 77L: 48, 78L: 49, 79L: 50, 80L: 51, 81L: 52, 82L: 53, 83L: 54, 84L: 55, 85L: 56, 86L: 57, 87L: 58, 88L: 59, 89L: 60, 90L: 61, 91L: 62, 92L: 63, 93L: 64, 94L: 65, 95L: 66, 96L: 67, 97L: 68, 98L: 69, 99L: 70, 100L: 71, 101L: 72, 102L: 73, 103L: 74, 104L: 75, 105L: 76, 106L: 77, 107L: 78, 108L: 79, 109L: 80, 110L: 81, 111L: 82, 112L: 83, 113L: 84, 114L: 85, 115L: 86, 116L: 87, 117L: 88, 118L: 89, 119L: 90, 120L: 91, 121L: 92, 122L: 93, 123L: 94, 124L: 95, 125L: 96, 126L: 97, 160L: 98, 161L: 99, 162L: 100, 163L: 101, 164L: 102, 165L: 103, 166L: 104, 167L: 105, 168L: 106, 169L: 107, 170L: 108, 171L: 10...(truncated), kw=0x0) at /usr/src/debug/Python-2.7.3/Objects/classobject.c:2578
#13 0x0000003dbe649a73 in PyObject_Call (
    func=func@entry=<instancemethod at remote 0xec84960>, 
    arg=arg@entry=(<FT2Font at remote 0xf88d2a0>,), kw=<optimized out>)
    at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2529
#14 0x0000003dbe6d7407 in PyEval_CallObjectWithKeywords (
    func=func@entry=<instancemethod at remote 0xec84960>, 
    arg=arg@entry=(<FT2Font at remote 0xf88d2a0>,), kw=kw@entry=0x0)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:3967
#15 0x0000003dbe658ccc in PyInstance_New (klass=<optimized out>, 
    arg=(<FT2Font at remote 0xf88d2a0>,), kw=0x0)
    at /usr/src/debug/Python-2.7.3/Objects/classobject.c:571
#16 0x0000003dbe649a73 in PyObject_Call (
    func=func@entry=<classobj at remote 0x1707328>, 
    arg=arg@entry=(<FT2Font at remote 0xf88d2a0>,), kw=kw@entry=0x0)
    at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2529
#17 0x0000003dbe6d9fec in do_call (nk=<optimized out>, na=1, 
    pp_stack=0x7ffffffef150, func=<classobj at remote 0x1707328>)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:4316
#18 call_function (oparg=<optimized out>, pp_stack=0x7ffffffef150)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:4121
#19 PyEval_EvalFrameEx (
    f=f@entry=Frame 0x406a320, for file /home/pcpa/rpmbuild/BUILD/matplotlib-1.2.0/build/lib.linux-x86_64-2.7/matplotlib/mathtext.py, line 584, in _get_font (self=<BakomaFonts(default_font_prop=<FontProperties(_family=None, _file=None, _variant=None, _slant=None, _size=<float at remote 0x55f7978>, _weight=None, _stretch=None) at remote 0xcd03e10>, fontmap={'cmsy10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'bf': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmb10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmss10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'rm': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'tt': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'it': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmr10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'ex': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cal': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmtt10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmmi10': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'sf': u'/usr/share/fonts/dejavu/DejaVuSans.ttf', 'cmex10': u'/usr/sh...(truncated), throwflag=throwflag@entry=0)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:2740
#20 0x0000003dbe6dd58d in PyEval_EvalCodeEx (co=<optimized out>, 
    globals=<optimized out>, locals=locals@entry=0x0, args=<optimized out>, 
    argcount=argcount@entry=2, kws=0x3e4e420, kwcount=0, defs=0x0, defcount=0, 
    closure=closure@entry=0x0)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:3330
#21 0x0000003dbe6dc079 in fast_function (nk=<optimized out>, na=2, n=2, 
    pp_stack=0x7ffffffef350, func=<function at remote 0x1744398>)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:4194
#22 call_function (oparg=<optimized out>, pp_stack=0x7ffffffef350)
    at /usr/src/debug/Python-2.7.3/Python/ceval.c:4119

...

#483 0x0000003d9de21b75 in __libc_start_main () from /lib64/libc.so.6
#484 0x0000000000400721 in _start ()

Comment 9 Fedora Update System 2013-04-12 22:26:03 UTC
python-matplotlib-1.2.0-12.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Paulo Andrade 2013-04-12 23:14:44 UTC
The problem is not yet corrected.

Comment 11 Fedora Update System 2013-04-20 19:09:29 UTC
python-matplotlib-1.2.0-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-07-23 14:01:53 UTC
python-matplotlib-1.2.0-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-14.fc19

Comment 13 Fedora Update System 2013-07-23 14:02:58 UTC
python-matplotlib-1.2.0-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-14.fc18

Comment 14 Fedora Update System 2013-07-24 03:22:20 UTC
Package python-matplotlib-1.2.0-14.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-matplotlib-1.2.0-14.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13451/python-matplotlib-1.2.0-14.fc18
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2013-07-25 00:33:43 UTC
python-matplotlib-1.2.0-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-07-25 00:49:54 UTC
python-matplotlib-1.2.0-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.