Bug 908955 - CLI usability: operations that shutdown the server-side management interface result in "Communication error"
Summary: CLI usability: operations that shutdown the server-side management interface ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER3
: EAP 6.1.0
Assignee: Alexey Loubyansky
QA Contact:
URL:
Whiteboard:
: 900731 914817 (view as bug list)
Depends On:
Blocks: 910122
TreeView+ depends on / blocked
 
Reported: 2013-02-07 21:26 UTC by dchia
Modified: 2018-12-01 17:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker AS7-1833 Critical Resolved CLI usability: operations that shutdown the server-side management interface result in "Communication error" 2018-05-22 09:12:55 UTC

Description dchia 2013-02-07 21:26:32 UTC
Description of problem:
When doing multiple :reload actions in jboss-cli.sh the managment interface crashes.

The number of :reload actions to reproduce the problem may vary.

How reproducible:
Almost every time

Steps to Reproduce:
# bin/jboss-cli.sh --connect --controller=localhost:9999
[standalone@localhost:9999 /] :reload
{"outcome" => "success"}
[standalone@localhost:9999 /] :reload
Communication error: java.util.concurrent.ExecutionException: Operation failed
[disconnected /]

Comment 2 JBoss JIRA Server 2013-03-06 18:09:48 UTC
Brian Stansberry <brian.stansberry@redhat.com> updated the status of jira AS7-1833 to Reopened

Comment 3 JBoss JIRA Server 2013-03-06 18:10:11 UTC
Brian Stansberry <brian.stansberry@redhat.com> updated the status of jira AS7-1833 to Resolved

Comment 4 JBoss JIRA Server 2013-03-06 18:10:11 UTC
Brian Stansberry <brian.stansberry@redhat.com> made a comment on jira AS7-1833

Further work on this has been done in AS 8.

Comment 5 Brian Stansberry 2013-03-06 18:10:45 UTC
The fix is the addition of high-level "reload" and "shutdown" commands to the CLI that better deal with the fact that these commands result in a break in communication with the server.

https://bugzilla.redhat.com/show_bug.cgi?id=914817 duplicates this so I will close it.

Comment 7 Brian Stansberry 2013-03-06 18:12:34 UTC
*** Bug 914817 has been marked as a duplicate of this bug. ***

Comment 8 Petr Kremensky 2013-03-12 07:41:24 UTC
Calling new reload command in quick succession I get:
[standalone@localhost:9999 /] reload
[standalone@localhost:9999 /] reload
Failed to execute :reload: java.net.ConnectException: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out
[disconnected /] 

I tried to to add --timeout argument to CLI calling, but ConnectionException occurs again.

Comment 9 Petr Kremensky 2013-03-12 16:17:23 UTC
*** Bug 900731 has been marked as a duplicate of this bug. ***

Comment 11 Petr Kremensky 2013-03-21 09:13:03 UTC
Verified on EAP 6.1.0 ER3

Comment 13 JBoss JIRA Server 2013-04-16 09:58:36 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All

This issue still on my environment. I download the EAP from http://www.jboss.org/jbossas/downloads. and run it in Redhat 5.5 x86_64 system.

Thanks

Comment 14 JBoss JIRA Server 2013-04-16 10:06:18 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All

This issue still on my environment. I download the EAP from http://www.jboss.org/jbossas/downloads. and run it in Redhat 5.5 x86_64 system.please point out if I do some wrong

Thanks

Comment 15 Josef Cacek 2013-04-16 11:12:49 UTC
IMHO it was fixed after the EAP 6.1.Alpha version was released. Wait for the Beta, please.

Comment 16 JBoss JIRA Server 2013-05-27 05:27:33 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All 

Does this bug really fix in EAP 6.1?I also had the bug on JBoss EAP6.1 final version. My environment is :Linux 5.3 + JBoss EAP 6.1.0

Here are the log :
[standalone@localhost:9999 /] :reload
Communication error: java.util.concurrent.ExecutionException: Operation failed: Operation failed: Channel closed
[disconnected /] 

Please correct me if I have any misunderstanding.

Regards

Xin

Comment 17 JBoss JIRA Server 2013-05-27 05:28:22 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All 

Does this bug really fix in EAP 6.1?I also had the bug on JBoss EAP6.1 final version. My environment is :Linux 5.3 + JBoss EAP 6.1.0 + JDK 1.6.0_26

Here are the log :
[standalone@localhost:9999 /] :reload
Communication error: java.util.concurrent.ExecutionException: Operation failed: Operation failed: Channel closed
[disconnected /] 

Please correct me if I have any misunderstanding.

Regards

Xin

Comment 18 Petr Kremensky 2013-05-27 07:53:28 UTC
Hi,
see https://bugzilla.redhat.com/show_bug.cgi?id=908955#c5
Petr

Comment 19 JBoss JIRA Server 2013-05-27 08:16:06 UTC
Josef Cacek <jcacek@redhat.com> made a comment on jira AS7-1833

[~Xin.Zhang.Song] - simply remove colon (':') before the "reload" - so you'll use the newly introduced synchronized version.

Comment 20 JBoss JIRA Server 2013-05-27 11:16:51 UTC
Josef Cacek <jcacek@redhat.com> made a comment on jira AS7-1833

[~Xin.Zhang.Song] - simply remove the colon (':') in front of the "reload" - so you'll use the newly introduced synchronized version.

Comment 21 JBoss JIRA Server 2013-05-28 02:10:04 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi Josef

I had remove the colon(':'), and there is still error message on the console.I think there are different between Linux and Windows.

Here are the message:
[standalone@localhost:9999 /] reload
Failed to establish connection in 10511ms: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out
[disconnected /] 

Regards

Xin


Note You need to log in before you can comment on or make changes to this bug.