Bug 914817 - CLI usability: operations that shutdown the server-side management interface result in "Communication error"
Summary: CLI usability: operations that shutdown the server-side management interface ...
Keywords:
Status: CLOSED DUPLICATE of bug 908955
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Alexey Loubyansky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 910122
TreeView+ depends on / blocked
 
Reported: 2013-02-22 21:04 UTC by Brian Stansberry
Modified: 2013-05-28 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-06 18:12:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker AS7-1833 Critical Resolved CLI usability: operations that shutdown the server-side management interface result in "Communication error" 2018-05-22 09:12:53 UTC

Description Brian Stansberry 2013-02-22 21:04:12 UTC
Addition of high-level "reload" and "shutdown" commands to the CLI that better deal with the fact that these commands result in a break in communication with the server process.

Comment 1 Brian Stansberry 2013-02-22 21:10:25 UTC
The upstream issue AS7-1833 is resolved against the AS7 Fix Version that is the basis for EAP 6.1.0.DR4. However, subsequent testing for the one-off-patch variant of this (see https://bugzilla.redhat.com/show_bug.cgi?id=910122) has shown remaining work needs to be done. Said work is in progress and seems to be progressing well. 

This issue is to ensure this work gets into EAP 6.1.0.Final.

Comment 3 JBoss JIRA Server 2013-03-06 18:09:50 UTC
Brian Stansberry <brian.stansberry@redhat.com> updated the status of jira AS7-1833 to Reopened

Comment 4 JBoss JIRA Server 2013-03-06 18:10:12 UTC
Brian Stansberry <brian.stansberry@redhat.com> updated the status of jira AS7-1833 to Resolved

Comment 5 JBoss JIRA Server 2013-03-06 18:10:12 UTC
Brian Stansberry <brian.stansberry@redhat.com> made a comment on jira AS7-1833

Further work on this has been done in AS 8.

Comment 6 Brian Stansberry 2013-03-06 18:12:33 UTC

*** This bug has been marked as a duplicate of bug 908955 ***

Comment 7 JBoss JIRA Server 2013-04-16 09:58:35 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All

This issue still on my environment. I download the EAP from http://www.jboss.org/jbossas/downloads. and run it in Redhat 5.5 x86_64 system.

Thanks

Comment 8 JBoss JIRA Server 2013-04-16 10:06:17 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All

This issue still on my environment. I download the EAP from http://www.jboss.org/jbossas/downloads. and run it in Redhat 5.5 x86_64 system.please point out if I do some wrong

Thanks

Comment 9 JBoss JIRA Server 2013-05-27 05:27:31 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All 

Does this bug really fix in EAP 6.1?I also had the bug on JBoss EAP6.1 final version. My environment is :Linux 5.3 + JBoss EAP 6.1.0

Here are the log :
[standalone@localhost:9999 /] :reload
Communication error: java.util.concurrent.ExecutionException: Operation failed: Operation failed: Channel closed
[disconnected /] 

Please correct me if I have any misunderstanding.

Regards

Xin

Comment 10 JBoss JIRA Server 2013-05-27 05:28:21 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi All 

Does this bug really fix in EAP 6.1?I also had the bug on JBoss EAP6.1 final version. My environment is :Linux 5.3 + JBoss EAP 6.1.0 + JDK 1.6.0_26

Here are the log :
[standalone@localhost:9999 /] :reload
Communication error: java.util.concurrent.ExecutionException: Operation failed: Operation failed: Channel closed
[disconnected /] 

Please correct me if I have any misunderstanding.

Regards

Xin

Comment 11 JBoss JIRA Server 2013-05-27 08:16:04 UTC
Josef Cacek <jcacek@redhat.com> made a comment on jira AS7-1833

[~Xin.Zhang.Song] - simply remove colon (':') before the "reload" - so you'll use the newly introduced synchronized version.

Comment 12 JBoss JIRA Server 2013-05-27 11:16:50 UTC
Josef Cacek <jcacek@redhat.com> made a comment on jira AS7-1833

[~Xin.Zhang.Song] - simply remove the colon (':') in front of the "reload" - so you'll use the newly introduced synchronized version.

Comment 13 JBoss JIRA Server 2013-05-28 02:10:02 UTC
Xin Zhang <xin.zhang.song@gmail.com> made a comment on jira AS7-1833

Hi Josef

I had remove the colon(':'), and there is still error message on the console.I think there are different between Linux and Windows.

Here are the message:
[standalone@localhost:9999 /] reload
Failed to establish connection in 10511ms: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out
[disconnected /] 

Regards

Xin


Note You need to log in before you can comment on or make changes to this bug.