Bug 908976 - common files for all languages are gone
common files for all languages are gone
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: 3.2
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 909755 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-07 17:58 EST by Raphaël Hertzog
Modified: 2013-07-04 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 21:16:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphaël Hertzog 2013-02-07 17:58:36 EST
Comparing the Debian package of 3.0.0 and 3.1.1 I noticed that many files were gone (like /usr/share/publican/Common_Content/common-db5/ar-SA/Conventions.xml). They were all for languages other than en-US...

I believe this is the result of an unwanted change in Build.PL. This is the patch reverting that change:
--- a/Build.PL
+++ b/Build.PL
@@ -10,9 +10,7 @@ my $class = Module::Build->subclass(
         use File::pushd;
         use Cwd;
         my $dir = cwd() . '/tmp/rpm';
-## BUGBUG when I'm impatient
-        my $common_langs = 'en-US';
-##        my $common_langs = 'all';
+        my $common_langs = 'all';
         sub ACTION_srpm {
             my $self = shift;
             my $os_ver = $self->args('os_ver');

I'm going to test it now.
Comment 1 Raphaël Hertzog 2013-02-07 18:12:37 EST
Now I'm getting another build failure due to bad XML in PO files of lv-LV translations...

mismatched tag at line 4, column 275, byte 648:
<!DOCTYPE para PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
]>
<para processed="1">सध्याच्या कार्रत डिरेक्ट्रीमध्ये <filename><filename>my_next_bestselling_novel</filename> फाइलची अंतर्भुत माहिती  पाहण्याकरीता, शेल प्रॉम्पट वर <command>cat my_next_bestselling_novel</command> आदेश द्या व आदेश चालविण्याकरीता <keycap>Enter</keycap> दाबा.</para>
==================================================================================================================================================================================================================================================================================^

*shrug*

I spent my evening on what should have been a 5 minutes update of the Debian package. :(

I think that I'll wait the 3.1.2 release instead. I hope that my investigations helped you anyway, Jeff.
Comment 2 Jeff Fearn 2013-02-10 21:32:24 EST
*** Bug 909755 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Fearn 2013-03-04 21:16:30 EST
This bug has been fixed in Publican 3.1.3

Note You need to log in before you can comment on or make changes to this bug.