This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 909755 - Common Brand only has en-US common files.
Common Brand only has en-US common files.
Status: CLOSED DUPLICATE of bug 908976
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-10 18:19 EST by Lee Newson
Modified: 2013-07-04 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-10 21:32:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-02-10 18:19:49 EST
Description of problem:
Publican used to package various common content for the "common" brand. As of version 3.1.0+ only the en-US content is included in the common brand. Therefore if the brand itself (common, publican-redhat, etc...) doesn't include translated items such as Conventions.xml or Feedback.xml then the content will show up in untranslated.

Version-Release number of selected component (if applicable):
3.1.0 and 3.1.1


How reproducible:
Always

Steps to Reproduce:
1. Build a translated book using the common brand or any brand that doesn't include it's own translations.
2. 
3.
  
Actual results:
Common Content based material appears in English and not the translated locale.

Expected results:
Since previous versions used to include the translations I would expect the content to come out translated.

Additional info:
Comment 2 Jeff Fearn 2013-02-10 19:09:57 EST
Are you using DocBook 5?
Comment 3 Lee Newson 2013-02-10 19:33:40 EST
I've only tested using DocBook 4.5 and the example above is DocBook 4.5.

The main problem I could see, is if you check an installation of publican 3.1.0 or 3.1.1 you'll see that there are no translations in:

/usr/share/publican/Common_Content/common/
Comment 4 Jeff Fearn 2013-02-10 21:32:24 EST

*** This bug has been marked as a duplicate of bug 908976 ***

Note You need to log in before you can comment on or make changes to this bug.