Bug 909 - The Linux Installer failed to activate the boot partition
Summary: The Linux Installer failed to activate the boot partition
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-21 15:55 UTC by mfranz
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-13 21:36:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mfranz 1999-01-21 15:55:42 UTC
This is strange one :
AMD K6-2 3DNOW 350Mhz
AMD reference system (I work for a chip company)
64MB Ram
IDE HD and CD Drive

Boot from floppy to kickoff the install process. Finds the
CD drive ok, and select workstation or server as your
configuration.Let Linux take over the entire HD and destroy
whatever exists on it. Make a boot disk just in case during
the install.

After the install you'll need to reboot, at which point
linux fails to boot. If you boot from the floppy you made
during install, then the HD will boot up fine.

Now boot an MS disk, and activate the Linux boot partition,
and suddenly Linux will boot from the machines hard drive,
and not require the floppy at all.

Now, this is the fun part. I reinstalled Linux on this
machine again, told linux to reinstall itself and destry
the data. I finished the install, and BAM - Same problem,
Linux fails to boot from the Hard Drive. I again boot from
an MS floppy,FDISK the system, and once again it boots from
the hard drive.

The same install process as above has worked on a number of
other machines, so I was really surprised when it failed on
the AMD. There is obviously something strange about this
machine, but I'm not sure what. If you have any tests/need
more info, let me know. email me at mfranz@141.com or
mfranz@3dfx.com (my work email)

Comment 1 David Lawrence 1999-01-22 20:32:59 UTC
We have observed this to be a bug and have verified it on machines in
our test lab. It is being assigned to a developer for further review.

Comment 2 dank 1999-02-05 17:23:59 UTC
One of six users at LULA's Jan 99 installfest ran into this.  A fix
would benefit real users.

Comment 3 David Lawrence 1999-02-06 01:27:59 UTC
*** Bug 932 has been marked as a duplicate of this bug. ***

When using the built-in "Server" installation type, the
first reboot FAILS, despite having LILO installed.  None of
the partitions on either /dev/hda or /dev/hdb were marked
active.

I'm not sure if the interaction is with LILO, or with a
"smart" BIOS in some newer PCs.  There are two solutions:
1) re-boot off the CD-ROM (or the install floppy), get to
the point where you can pick between fdisk and Disk Druid,
run fdisk on /dev/hda, mark the partition active, WRITE
changes to disk, wait for disks to sync, then press the
RESET button (ie. hard boot)
2) boot of the boot floppy that got created during install
(if you made one :-)  and re-run LILO.  I have no idea why
re-running LILO fixes this problem.  This method did *NOT*
fix the problem on one PC with a *single* root partition
that was over the 1024 cylinder mark.  There may have been
some other interaction there.

I'm not certain, but I believe that the same behaviour
happens when using Disk Druid instead of fdisk.  Last time
I tried was a while back, so I could be wrong.

------- Additional Comments From dank@alumni.caltech.edu  02/05/99 12:24 -------
Is this a duplicate of #909?
http://developer.redhat.com/bugzilla/show_bug.cgi?id=909

Comment 4 Matt Wilson 1999-03-13 21:36:59 UTC
Fixed in the next release.


Note You need to log in before you can comment on or make changes to this bug.