Bug 932 - No HDD partitions marked Active after install; cannot boot
Summary: No HDD partitions marked Active after install; cannot boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-23 21:28 UTC by Adam Thompson
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-06 01:27:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Thompson 1999-01-23 21:28:05 UTC
When using the built-in "Server" installation type, the
first reboot FAILS, despite having LILO installed.  None of
the partitions on either /dev/hda or /dev/hdb were marked
active.

I'm not sure if the interaction is with LILO, or with a
"smart" BIOS in some newer PCs.  There are two solutions:
1) re-boot off the CD-ROM (or the install floppy), get to
the point where you can pick between fdisk and Disk Druid,
run fdisk on /dev/hda, mark the partition active, WRITE
changes to disk, wait for disks to sync, then press the
RESET button (ie. hard boot)
2) boot of the boot floppy that got created during install
(if you made one :-)  and re-run LILO.  I have no idea why
re-running LILO fixes this problem.  This method did *NOT*
fix the problem on one PC with a *single* root partition
that was over the 1024 cylinder mark.  There may have been
some other interaction there.

I'm not certain, but I believe that the same behaviour
happens when using Disk Druid instead of fdisk.  Last time
I tried was a while back, so I could be wrong.

Comment 1 dank 1999-02-05 17:24:59 UTC
Is this a duplicate of #909?
http://developer.redhat.com/bugzilla/show_bug.cgi?id=909

Comment 2 David Lawrence 1999-02-06 01:27:59 UTC
*** This bug has been marked as a duplicate of 909 ***


Note You need to log in before you can comment on or make changes to this bug.