Bug 909468 - [rfe] delta rpm support
Summary: [rfe] delta rpm support
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1102245 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-08 20:52 UTC by Rahul Sundaram
Modified: 2014-05-29 06:36 UTC (History)
13 users (show)

Fixed In Version: dnf-0.4.13-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-09 03:54:16 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2013-02-08 20:52:36 UTC
Description of problem:

delta rpm support is there by default in yum since yum-presto plugin is integrated.  dnf should support this functionality as well as potentially support delta for the metadata as well if thats possible.

Comment 1 Ales Kozumplik 2013-02-11 08:51:28 UTC
Support for delta metadata is not available in yum either yet. I'll look into the delta rpm downloads.

Comment 2 Parag Nemade 2013-10-12 16:58:45 UTC
any update here?

Comment 3 Ales Kozumplik 2013-10-14 06:05:05 UTC
no, not at the moment.

Comment 4 Zdeněk Pavlas 2013-11-19 13:20:35 UTC
I'll start porting the code from yum, but it'll probably need changes in librepo, too.

Comment 6 Ales Kozumplik 2014-02-03 09:25:16 UTC
Patches are upstream, this will get closed with the next DNF build.

Comment 7 Fedora Update System 2014-02-07 06:43:47 UTC
dnf-0.4.13-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.13-2.fc20

Comment 8 Fedora Update System 2014-02-08 05:07:32 UTC
Package dnf-0.4.13-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.13-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2172/dnf-0.4.13-2.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-02-09 03:54:16 UTC
dnf-0.4.13-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Parag Nemade 2014-02-17 07:02:34 UTC
How should I get this delta rpm support. I am daily seeing "dnf update" command giving me few package updates but in the whole transaction log in the gnome-terminal, I see no where word delta or drpms. So, I am unsure whether delta rpm support is working or not. I am using Fedora 20 and dnf-0.4.14-1.fc20.noarch

Comment 11 Ales Kozumplik 2014-02-17 07:46:20 UTC
Parag, this can be enabled with 'deltarpm' per-repo config option: http://akozumpl.github.io/dnf/conf_ref.html

Comment 12 Parag Nemade 2014-02-17 08:09:00 UTC
Ales,
   Thank you. I got the deltarpm support working successfully. I only added following line in /etc/dnf/dnf.conf [main] section
deltarpm=1

Comment 13 ILMostro 2014-04-09 14:51:33 UTC
I'm assuming this may be related to the differences I see in available updates between running dnf check-update and yum check-update.  deltarpms are enabled on my system when using yum, though dnf is not using deltarpms.

Comment 14 ILMostro 2014-04-09 14:52:24 UTC
As a result, yum check-update reports available updates, while dnf reports no updates available

Comment 15 Ales Kozumplik 2014-05-29 06:36:22 UTC
*** Bug 1102245 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.