Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 909492 - [abrt] python-boto-2.6.0-2.fc18: auth.py:633:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
[abrt] python-boto-2.6.0-2.fc18: auth.py:633:get_auth_handler:NoAuthHandlerFo...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
abrt_hash:e3078354674adadf583706b9091...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 17:18 EST by brando.khoo
Modified: 2013-04-05 04:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 04:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.38 KB, text/plain)
2013-02-08 17:18 EST, brando.khoo
no flags Details
File: core_backtrace (514 bytes, text/plain)
2013-02-08 17:18 EST, brando.khoo
no flags Details
File: environ (2.77 KB, text/plain)
2013-02-08 17:18 EST, brando.khoo
no flags Details

  None (edit)
Description brando.khoo 2013-02-08 17:18:53 EST
Version-Release number of selected component:
python-boto-2.6.0-2.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/lss3
executable:     /usr/bin/lss3
kernel:         3.7.2-204.fc18.x86_64
uid:            0

Truncated backtrace:
auth.py:633:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials

Traceback (most recent call last):
  File "/usr/bin/lss3", line 71, in <module>
    s3 = boto.connect_s3()
  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 121, in connect_s3
    return S3Connection(aws_access_key_id, aws_secret_access_key, **kwargs)
  File "/usr/lib/python2.7/site-packages/boto/s3/connection.py", line 169, in __init__
    validate_certs=validate_certs)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 548, in __init__
    host, config, self.provider, self._required_auth_capability())
  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 633, in get_auth_handler
    'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials

Local variables in innermost frame:
total_handlers: 1
checked_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
provider: <boto.provider.Provider object at 0x7f7688fabc10>
host: 's3.amazonaws.com'
handler: <class 'boto.auth.HmacAuthV1Handler'>
names: ['HmacAuthV1Handler']
ready_handlers: []
requested_capability: ['s3']
auth_handlers: [<class 'boto.auth.HmacAuthV1Handler'>]
config: <boto.pyami.config.Config instance at 0x7f7688fa57a0>
Comment 1 brando.khoo 2013-02-08 17:18:55 EST
Created attachment 695267 [details]
File: backtrace
Comment 2 brando.khoo 2013-02-08 17:18:57 EST
Created attachment 695268 [details]
File: core_backtrace
Comment 3 brando.khoo 2013-02-08 17:18:59 EST
Created attachment 695269 [details]
File: environ
Comment 4 Miroslav Suchý 2013-04-05 04:02:12 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.