Bug 910556 - Packstack fails to start newly added services.
Packstack fails to start newly added services.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
2.0 (Folsom)
x86_64 Linux
unspecified Severity high
: snapshot5
: 2.1
Assigned To: Derek Higgins
Jaroslav Henner
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 15:45 EST by Jaroslav Henner
Modified: 2013-04-04 13:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-packstack-2012.2.3-0.3.dev472.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 13:59:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2013-02-12 15:45:46 EST
Description of problem:
After installation with packstack:
# for svc in /etc/init.d/openstack-swift-*; do $svc status; done
account-server (pid  3664) is running...
account-auditor is stopped
account-reaper is stopped
account-replicator (pid  3606) is running...
container-server (pid  3542) is running...
container-auditor is stopped
container-replicator (pid  3560) is running...
container-updater is stopped
object-server (pid  3753) is running...
object-auditor is stopped
object-replicator (pid  3771) is running...
object-updater is stopped


Version-Release number of selected component (if applicable):
openstack-packstack-2012.2.2-0.8.dev346.el6ost.noarch
openstack-swift-1.7.4-7.el6ost.noarch

How reproducible:
1/1

Steps to Reproduce:
1. Install
2.
3.
  
Actual results:
Some swift services stopped

Expected results:
All swift services running

Additional info:
See the referred bug.
Comment 2 Derek Higgins 2013-03-05 06:45:57 EST
Fix submitted upstream
https://review.openstack.org/#/c/23407/
Comment 4 Jaroslav Henner 2013-03-21 17:34:42 EDT
Good job.

[root@node-01 ~]# for svc in /etc/init.d/openstack-swift-*; do $svc status; done
account-server (pid  4533) is running...
account-auditor (pid  4131) is running...
account-reaper (pid  4193) is running...
account-replicator (pid  4472) is running...
container-server (pid  4846) is running...
container-auditor (pid  3993) is running...
container-replicator (pid  4784) is running...
container-updater (pid  4055) is running...
object-server (pid  4622) is running...
object-auditor (pid  4331) is running...
object-replicator (pid  4685) is running...
object-updater (pid  4269) is running...
Comment 5 errata-xmlrpc 2013-04-04 13:59:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html

Note You need to log in before you can comment on or make changes to this bug.