Bug 913195 - New services are missing from chkconfig
New services are missing from chkconfig
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
2.0 (Folsom)
x86_64 Linux
medium Severity medium
: snapshot4
: 2.1
Assigned To: Pete Zaitcev
Jaroslav Henner
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-20 11:02 EST by Jaroslav Henner
Modified: 2016-04-26 10:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: openstack-swift-1.7.4-9.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:06:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate 1 (4.72 KB, patch)
2013-02-20 17:32 EST, Pete Zaitcev
apevec: review+
Details | Diff

  None (edit)
Description Jaroslav Henner 2013-02-20 11:02:09 EST
Description of problem:
The swift services were split recently, but the new ones are not in chkconfig.

Version-Release number of selected component (if applicable):
openstack-swift-1.7.4-7.el6ost.noarch

How reproducible:
1/1

Steps to Reproduce:
1. instll swift
2.
3.

  
Actual results:
[root@node-02 ~]# ll /etc/init.d/openstack-swift-*
-rwxr-xr-x. 1 root root 1444 30. led 20.01 /etc/init.d/openstack-swift-account
-rwxr-xr-x. 1 root root 1457 30. led 20.01 /etc/init.d/openstack-swift-account-auditor
-rwxr-xr-x. 1 root root 1451 30. led 20.01 /etc/init.d/openstack-swift-account-reaper
-rwxr-xr-x. 1 root root 1464 30. led 20.01 /etc/init.d/openstack-swift-account-replicator
-rwxr-xr-x. 1 root root 1464 30. led 20.01 /etc/init.d/openstack-swift-container
-rwxr-xr-x. 1 root root 1469 30. led 20.01 /etc/init.d/openstack-swift-container-auditor
-rwxr-xr-x. 1 root root 1484 30. led 20.01 /etc/init.d/openstack-swift-container-replicator
-rwxr-xr-x. 1 root root 1469 30. led 20.01 /etc/init.d/openstack-swift-container-updater
-rwxr-xr-x. 1 root root 1444 30. led 20.01 /etc/init.d/openstack-swift-object
-rwxr-xr-x. 1 root root 1449 30. led 20.01 /etc/init.d/openstack-swift-object-auditor
-rwxr-xr-x. 1 root root 1464 30. led 20.01 /etc/init.d/openstack-swift-object-replicator
-rwxr-xr-x. 1 root root 1449 30. led 20.01 /etc/init.d/openstack-swift-object-updater
[root@node-02 ~]# chkconfig | grep swift
openstack-swift-account	0:off	1:off	2:on	3:on	4:on	5:on	6:off
openstack-swift-container	0:off	1:off	2:on	3:on	4:on	5:on	6:off
openstack-swift-object	0:off	1:off	2:on	3:on	4:on	5:on	6:off



Expected results:
Similar outputs
Comment 1 Pete Zaitcev 2013-02-20 13:52:34 EST
See also bug 885530 that added the missing services.
Comment 4 Pete Zaitcev 2013-02-20 17:32:18 EST
Created attachment 700280 [details]
Candidate 1

Quick cargo-culted fix. Tested by installing and upgrading. Looks like nothing was typoed, but needs review.
Comment 5 Alan Pevec 2013-02-21 06:31:54 EST
Comment on attachment 700280 [details]
Candidate 1

looks good, just please bump Release: 9
Comment 6 Pete Zaitcev 2013-02-21 19:04:46 EST
modified in openstack-swift-1.7.4-9
Comment 8 Jaroslav Henner 2013-03-04 08:51:30 EST
Success

[root@node-02 ~]# chkconfig | awk '/swift/ { print $1 }'
openstack-swift-account
openstack-swift-account-auditor
openstack-swift-account-reaper
openstack-swift-account-replicator
openstack-swift-container
openstack-swift-container-auditor
openstack-swift-container-replicator
openstack-swift-container-updater
openstack-swift-object
openstack-swift-object-auditor
openstack-swift-object-replicator
openstack-swift-object-updater
Comment 10 errata-xmlrpc 2013-03-21 15:06:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.