Bug 91074 - common_dir location must be set in RH9
common_dir location must be set in RH9
Status: CLOSED DUPLICATE of bug 88746
Product: Red Hat Linux
Classification: Retired
Component: htdig (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-17 07:55 EDT by jonathan baron
Modified: 2015-03-04 20:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan baron 2003-05-17 07:55:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

Description of problem:
I upgraded from RH7.3 to RH9 and htdig search did not
include the usual header and footer on the search output.
I solved the problem by adding the line
common_dir: /usr/share/htdig
to my (various) htdig.conf files (some with different
names).  This was the default location of htdig in earlier
versions.  Could the RPM perhaps keep this?  It took me
forever to find the problem.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade to RH9, when htdig was already installed
2. try the search
3.
    

Actual Results:  No header and footer on search output (hence could only
see one page).


Expected Results:  header and footer
(but I'm sure that common_dir is used for other things too)


Additional info:

It is possible that, at some point, I installed htdig from
source rather than from an RPM, but I don't remember, and
I do believe that I was using the RPM on RH 7.3 before I
upgraded to RH 9, and htdig worked fine.  (I've been using
htdig through several versions.)

I reported this problem as a bug to htdig (731661) and the
response said that the problem was probably in the RPM.

Also, I _did_ try to search for it, but got no bugs associated
with htdig.  Perhaps I did the search wrong.  If so, sorry.
Comment 1 jonathan baron 2003-06-12 19:26:15 EDT
From an email from Gilles Detillieux <grdetil@scrc.umanitoba.ca>
about where common_dir points in the RPM:

They (RH) point it to /var/www/html/htdig. [...]
First of all they set common_dir
and image_dir to the same thing, then they move /var/www/html/htdig
to /usr/share/htdig.  In previous RPMs, they then made a symlink from
/var/www/html/htdig (in the htdig-web package) over to /usr/share/htdig,
so that htsearch et al. only found the common files if you had installed
both htdig and htdig-web packages, and htsearch's images would only load
if you configure httpd to follow symlinks.  Now, to resolve the latter
problem, they use an Apache Alias instead of a symlink, so the images
load, but nothing will find the common files unless you fix common_dir
in your htdig.conf.
Comment 2 Phil Knirsch 2003-09-02 10:01:02 EDT

*** This bug has been marked as a duplicate of 88746 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:53:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.