Bug 88746 - common_dir not set properly
Summary: common_dir not set properly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: htdig (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 91074 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-12 23:29 UTC by Mark Miksis
Modified: 2015-03-05 01:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 13:32:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Miksis 2003-04-12 23:29:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
${common_dir} does not work in htdig.conf



Version-Release number of selected component (if applicable):
htdig-3.2.0-16.20021103

How reproducible:
Always

Steps to Reproduce:
1. uncomment
#template_map: Long long ${common_dir}/long.html \
#		Short short ${common_dir}/short.html
in htdig.conf
2. run htsearch
3.
    

Actual Results:  returns a blank page

Expected Results:  returns a real page (even if there are no results)

Additional info:

Works fine if htdig.conf is changed to:
template_map: Long long /usr/share/htdig/long.html \
		Short short /usr/share/htdig/short.html

Comment 1 Phil Knirsch 2003-09-02 13:32:15 UTC
OK, simple: ${common_dir} isn't set, so it needs to be replaced with
/usr/share/htdig/

I'll see that this gets fixed in the default config.

Read ya, Phil

Comment 2 Phil Knirsch 2003-09-02 13:32:23 UTC
OK, simple: ${common_dir} isn't set, so it needs to be replaced with
/usr/share/htdig/

I'll see that this gets fixed in the default config.

Read ya, Phil

Comment 3 Phil Knirsch 2003-09-02 14:01:04 UTC
*** Bug 91074 has been marked as a duplicate of this bug. ***

Comment 4 Phil Knirsch 2003-09-02 14:06:50 UTC
*** Bug 98880 has been marked as a duplicate of this bug. ***

Comment 5 Gilles Detillieux 2003-10-17 20:33:03 UTC
As an ht://Dig developer, I'd like to shed some insight into this problem, which
by the way does not seem to be fixed in rawhide, as far as I can tell from
looking at htdig-3.2.0-19.20030601.src.rpm from that distro.  The problem stems
from confusion about the "common" directory vs. the image directory, which
really ought to be two separate things.  The Red Hat RPMs merge these two
together, but then confusion ensues as to what they should be called and where
they should be placed.

They're initially put together in /var/www/html/htdig, but then moved to
/usr/share/htdig.  Trouble is, the binaries still think they're in the former
directory.  The --with-common-dir argument to configure should be changed to
specify the directory's real, final resting place.  So should --with-image-dir
and --with-search-dir if you really want to keep all files in the same directory.

However, it would be better still to keep common and image directories separate,
so that the configuration files (templates) in the common directory are not
directly accessible from the web (and thus potentially revealing configuration
information to the public).  If you keep them separate, the image directory need
only be part of the htdig-web package, and then the Apache configuration file
for the directory's Alias is no longer needed.

Either way, the changes to the .spec file would be fairly trivial, but I can
supply patches if you'd like.


Note You need to log in before you can comment on or make changes to this bug.