Bug 910920 - [abrt] ardour-2.8.16-1.fc18: gtk_text_view_set_attributes_from_style: Process /usr/lib/ardour2/ardour-2.8.16 was killed by signal 11 (SIGSEGV)
[abrt] ardour-2.8.16-1.fc18: gtk_text_view_set_attributes_from_style: Process...
Status: CLOSED DUPLICATE of bug 909019
Product: Fedora
Classification: Fedora
Component: oxygen-gtk2 (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:f9dab0f07ca92f1e039846ea499...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 16:04 EST by Jimmy Johnson Jr
Modified: 2013-02-15 17:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 00:17:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (43.15 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: cgroup (128 bytes, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: core_backtrace (8.47 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: dso_list (11.44 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: environ (2.03 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: maps (34.52 KB, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: open_fds (491 bytes, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: proc_pid_status (777 bytes, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details
File: var_log_messages (732 bytes, text/plain)
2013-02-13 16:04 EST, Jimmy Johnson Jr
no flags Details

  None (edit)
Description Jimmy Johnson Jr 2013-02-13 16:04:07 EST
Description of problem:
Normal (as in succesful) startup of Fedora 18 with KDE 4.9.5.  Attempted to start GIMP 2.8.2 and this occured.

Version-Release number of selected component:
ardour-2.8.16-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib/ardour2/ardour-2.8.16
crash_function: gtk_text_view_set_attributes_from_style
executable:     /usr/lib/ardour2/ardour-2.8.16
kernel:         3.7.6-201.fc18.i686
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gtk_text_view_set_attributes_from_style at gtktextview.c:6377
 #1 gtk_text_view_style_set at gtktextview.c:3980
 #2 Gtk::Widget_Class::style_set_callback at widget.cc:4319
 #3 g_cclosure_marshal_VOID__OBJECT at gmarshal.c:1272
 #9 gtk_widget_set_style_internal at gtkwidget.c:7001
 #10 gtk_widget_reset_rc_style at gtkwidget.c:6613
 #11 reset_rc_styles_recurse at gtkwidget.c:7211
 #12 gtk_bin_forall at gtkbin.c:141
 #13 gtk_scrolled_window_forall at gtkscrolledwindow.c:1085
 #14 Gtk::Container_Class::forall_vfunc_callback at container.cc:476
Comment 1 Jimmy Johnson Jr 2013-02-13 16:04:10 EST
Created attachment 697029 [details]
File: backtrace
Comment 2 Jimmy Johnson Jr 2013-02-13 16:04:12 EST
Created attachment 697030 [details]
File: cgroup
Comment 3 Jimmy Johnson Jr 2013-02-13 16:04:14 EST
Created attachment 697031 [details]
File: core_backtrace
Comment 4 Jimmy Johnson Jr 2013-02-13 16:04:16 EST
Created attachment 697032 [details]
File: dso_list
Comment 5 Jimmy Johnson Jr 2013-02-13 16:04:17 EST
Created attachment 697033 [details]
File: environ
Comment 6 Jimmy Johnson Jr 2013-02-13 16:04:19 EST
Created attachment 697034 [details]
File: limits
Comment 7 Jimmy Johnson Jr 2013-02-13 16:04:21 EST
Created attachment 697035 [details]
File: maps
Comment 8 Jimmy Johnson Jr 2013-02-13 16:04:23 EST
Created attachment 697036 [details]
File: open_fds
Comment 9 Jimmy Johnson Jr 2013-02-13 16:04:25 EST
Created attachment 697037 [details]
File: proc_pid_status
Comment 10 Jimmy Johnson Jr 2013-02-13 16:04:27 EST
Created attachment 697038 [details]
File: var_log_messages
Comment 11 Justin Heimburger 2013-02-14 23:23:02 EST
Open Ardour. This appears in /var/log/messages:

Feb 14 22:04:54 juheimbu kernel: [261011.840461] ardour-2.8.16[332]: segfault at 50 ip 0000003faf816ee7 sp 00007fffbb60fcb0 error 4 in libgtk-x11-2.0.so.0.2400.13[3faf600000+46a000]


Not sure what is root cause.


backtrace_rating: 4
Package: ardour-2.8.16-1.fc18
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Orcan Ogetbil 2013-02-14 23:50:05 EST
The crash occurs in oxygen-gtk2 code. Assigning to oxygen-gtk2. Maybe its maintainer can shed some light.

Did you folks update this library recently?
Comment 13 Justin Heimburger 2013-02-14 23:52:53 EST
(In reply to comment #12)
> The crash occurs in oxygen-gtk2 code. Assigning to oxygen-gtk2. Maybe its
> maintainer can shed some light.
> 
> Did you folks update this library recently?

oxygen-gtk2 updated on my system on the 6th, but this is the first time I've attempted to open Ardour, so I can't say if it functioned previously.
Comment 14 Orcan Ogetbil 2013-02-15 00:01:41 EST
Hmm, I see a more recent build in koji. Could you try that out? How reproducible is the crash? 
Thanks!

http://koji.fedoraproject.org/koji/buildinfo?buildID=384086
Comment 15 Justin Heimburger 2013-02-15 00:09:41 EST
(In reply to comment #14)
> Hmm, I see a more recent build in koji. Could you try that out? How
> reproducible is the crash? 
> Thanks!
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=384086

The problem was reproducible 100% of the time.  The new version fixed it.  I got Ardour started.

Thanks!
Comment 16 Orcan Ogetbil 2013-02-15 00:17:57 EST
Great. Good to hear that. We can close this bug. It seems like this was reported before in bug 909019.

*** This bug has been marked as a duplicate of bug 909019 ***
Comment 17 Jimmy Johnson Jr 2013-02-15 17:41:02 EST
Bug (which effected both Ardour and GIMP) has been fixed by the most recent update of Oxygen-GTK2. This fix showed-up in my update list on 2-15-13 at approximately 5:30PM EST. As soon as I performed the updates and restarted my system the problem was gone. Much thanks to whoever did the work to find and fix this!

Note You need to log in before you can comment on or make changes to this bug.