Bug 909019 - [abrt] gimp-2.8.2-6.fc18: gtk_text_view_set_attributes_from_style: Process /usr/bin/gimp-2.8 was killed by signal 11 (SIGSEGV)
[abrt] gimp-2.8.2-6.fc18: gtk_text_view_set_attributes_from_style: Process /u...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: oxygen-gtk2 (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:77571783b24e4e39d011af2bcff...
:
: 908868 910920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-07 22:53 EST by Richard Carlson
Modified: 2013-02-15 09:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 23:58:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.16 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: cgroup (130 bytes, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: core_backtrace (6.71 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: dso_list (8.49 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: environ (2.87 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: maps (41.18 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: open_fds (424 bytes, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: proc_pid_status (922 bytes, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
File: var_log_messages (2.37 KB, text/plain)
2013-02-07 22:53 EST, Richard Carlson
no flags Details
Reproducer which exhibits the problem. (619 bytes, text/x-csrc)
2013-02-08 09:02 EST, Nils Philippsen
no flags Details
Reproducer which exhibits the problem (with oxygen-gtk2-1.3.2) (748 bytes, text/x-csrc)
2013-02-08 09:31 EST, Nils Philippsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 314688 None None None Never

  None (edit)
Description Richard Carlson 2013-02-07 22:53:06 EST
Description of problem:
Uing other software and decided to run Gimp. Clicked on program icon and it just crashed immediately. 

Version-Release number of selected component:
gimp-2.8.2-6.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/gimp-2.8
crash_function: gtk_text_view_set_attributes_from_style
executable:     /usr/bin/gimp-2.8
kernel:         3.7.6-201.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gtk_text_view_set_attributes_from_style at gtktextview.c:6380
 #1 gtk_text_view_style_set at gtktextview.c:3980
 #6 gtk_widget_set_style_internal at gtkwidget.c:7001
 #7 gtk_widget_reset_rc_style at gtkwidget.c:6613
 #8 reset_rc_styles_recurse at gtkwidget.c:7211
 #9 gtk_scrolled_window_forall at gtkscrolledwindow.c:1085
 #10 gtk_frame_forall at gtkframe.c:300
 #11 gtk_box_forall at gtkbox.c:1251
 #12 gtk_rc_reset_widgets at gtkrc.c:1638
 #13 _gtk_rc_context_get_default_font_name at gtkrc.c:1736
Comment 1 Richard Carlson 2013-02-07 22:53:09 EST
Created attachment 694910 [details]
File: backtrace
Comment 2 Richard Carlson 2013-02-07 22:53:11 EST
Created attachment 694911 [details]
File: cgroup
Comment 3 Richard Carlson 2013-02-07 22:53:12 EST
Created attachment 694912 [details]
File: core_backtrace
Comment 4 Richard Carlson 2013-02-07 22:53:14 EST
Created attachment 694913 [details]
File: dso_list
Comment 5 Richard Carlson 2013-02-07 22:53:15 EST
Created attachment 694914 [details]
File: environ
Comment 6 Richard Carlson 2013-02-07 22:53:17 EST
Created attachment 694915 [details]
File: limits
Comment 7 Richard Carlson 2013-02-07 22:53:18 EST
Created attachment 694916 [details]
File: maps
Comment 8 Richard Carlson 2013-02-07 22:53:20 EST
Created attachment 694917 [details]
File: open_fds
Comment 9 Richard Carlson 2013-02-07 22:53:21 EST
Created attachment 694918 [details]
File: proc_pid_status
Comment 10 Richard Carlson 2013-02-07 22:53:22 EST
Created attachment 694919 [details]
File: var_log_messages
Comment 11 Nils Philippsen 2013-02-08 08:53:13 EST
You seem to use the Oxygen GTK theme, probably because you run KDE, right? This bug seems to show up only with this GTK theme, therefore I'll change the component to oxygen-gtk2.

When used with oxygen-gtk2, text_view->layout->default_style is NULL which may not be the case as it is dereferenced immediately in gtk_text_view_set_attributes_from_style(). I'll attach a short reproducer which exhibits the issue.
Comment 12 Nils Philippsen 2013-02-08 09:02:25 EST
Created attachment 695110 [details]
Reproducer which exhibits the problem.

This reproducer creates a window widget, adds a scrolled window to it and then a text view into the scrolled window. I've left out code which isn't necessary for the crash to happen, as it is nothing will be shown when run under a different gtk theme that doesn't produce a crash. I can provide a slightly longer reproducer which actually does something visible on request.

Build with:

gcc -o tv2 tv2.c `pkg-config --clags --libs gtk+-2.0`

Run with the oxygen-gtk theme (e.g. under KDE) to show the problem. When run with e.g. the "Adwaita" theme (GNOME 3), it doesn't crash.

For the crash to happen, the window widget "win" may not be realized when the text view "view" is added to the scrolled window "scrolled". Adding "gtk_widget_show (win);" or "gtk_widget_realize (win);" before the text view is added to the scrolled window container avoids the crash.
Comment 13 nucleo 2013-02-08 09:03:13 EST
Is this happens with oxygen-gtk2-1.3.1?
Comment 14 Rex Dieter 2013-02-08 09:13:05 EST
I compiled your test case, and run against  oxygen-gtk2-1.3.1, and nothing seems to happen... no window, no crash. ?
Comment 15 nucleo 2013-02-08 09:22:45 EST
So, this is regression in oxygen-gtk2-1.3.2?
Comment 16 Nils Philippsen 2013-02-08 09:24:09 EST
(In reply to comment #14)
> I compiled your test case, and run against  oxygen-gtk2-1.3.1, and nothing
> seems to happen... no window, no crash. ?

The package I used is oxygen-gtk2-1.3.2-1.fc18.x86_64.
Comment 17 Nils Philippsen 2013-02-08 09:29:52 EST
I can confirm that 1.3.1 doesn't exhibit the problem, and my stripped down testcase doesn't crash either after upgrading again to 1.3.2. I'll attach the functional test case then which crashes anyway (but only with 1.3.2).
Comment 18 Nils Philippsen 2013-02-08 09:31:13 EST
Created attachment 695112 [details]
Reproducer which exhibits the problem (with oxygen-gtk2-1.3.2)
Comment 19 Nils Philippsen 2013-02-08 09:43:14 EST
*** Bug 908868 has been marked as a duplicate of this bug. ***
Comment 21 nucleo 2013-02-08 17:41:37 EST
This build with fix from kde bug 314545 fixes crash?
http://koji.fedoraproject.org/koji/buildinfo?buildID=382932
Comment 22 nucleo 2013-02-11 09:32:30 EST
So can someone test package from comment 21?
Comment 23 Nils Philippsen 2013-02-12 05:38:47 EST
(In reply to comment #21)
> This build with fix from kde bug 314545 fixes crash?
> http://koji.fedoraproject.org/koji/buildinfo?buildID=382932

With the old oxygen-gtk2-1.3.2-1.fc18.x86_64 and a new user (i.e. one who hasn't run GIMP before), running gimp crashes, with the new oxygen-gtk2-1.3.2-2.fc18.x86_64 it runs flawlessly. Thanks for the fix!
Comment 24 Álvaro Castillo 2013-02-12 09:53:29 EST
Works fine heh, thank you!
Comment 25 Ghislain Vaillant 2013-02-12 13:54:18 EST
Works fine for me after upgrade to oxygen-gtk2-1.3.2-2.fc18.x86_64. Thank you for fixing this.
Comment 26 Fedora Update System 2013-02-12 17:58:00 EST
oxygen-gtk2-1.3.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/oxygen-gtk2-1.3.2.1-1.fc18
Comment 27 Fedora Update System 2013-02-13 21:26:24 EST
Package oxygen-gtk2-1.3.2.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing oxygen-gtk2-1.3.2.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2418/oxygen-gtk2-1.3.2.1-1.fc18
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2013-02-14 23:58:53 EST
oxygen-gtk2-1.3.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Orcan Ogetbil 2013-02-15 00:17:57 EST
*** Bug 910920 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.