Bug 910945 - No signal to monitor after kernel modesetting fails
No signal to monitor after kernel modesetting fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 910946 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 19:33 EST by Steven Usdansky
Modified: 2013-09-30 12:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 12:19:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Smolt profile from working (kernel-3.7) boot (3.56 KB, text/plain)
2013-02-27 13:22 EST, Steven Usdansky
no flags Details

  None (edit)
Description Steven Usdansky 2013-02-13 19:33:28 EST
Description of problem:
When attempting a normal boot with any version 3.8 kernel, when modesetting is attempted, the monitor loses the signal and never gets it back

Version-Release number of selected component (if applicable):
kernel-3.8 all versions up through kernel-3.8.0-0.rc7.git2.1.fc19

How reproducible:
100% of the time

Steps to Reproduce:
1. Install a version 3.8 kernel
2. Reboot

  
Actual results:
Initial text displays properly
Signal to monitor goes away never to return when kernel modesetting kicks in

Expected results:
Computer will boot normally as it does with all F18 kernels

Additional info:
Onboard Nvidia 9100 graphics
Monitor has known bad EDID - works fine earlier kernels and custom xorg.conf 

Current working configuration:
 kernel-3.7.7-201.fc18.x86_64
 xorg-x11-drv-nouveau-1.0.6-3.fc19.x86_64
 xorg-x11-server-Xorg-1.13.99.901-4.20130109.fc19.x86_64
Comment 1 Josh Boyer 2013-02-14 10:14:02 EST
*** Bug 910946 has been marked as a duplicate of this bug. ***
Comment 2 Steven Usdansky 2013-02-17 18:21:46 EST
Sorry about the duplicate - had no indication this was sent. Same problem occurs on my wife's system using onboard Nvidia GeForce 6150 LE graphics.
Comment 3 Steven Usdansky 2013-02-24 05:06:38 EST
Tried a new kernel on an otherwise-working F18 system:
  kernel-3.9.0-0.rc0.git5.1.fc19.i686
  xorg-x11-server-Xorg-1.13.2-2.fc18.i686
  xorg-x11-drv-nouveau-1.0.6-1.fc18.i686
Same problem, suggesting that its something the kernel is doing that it didn't previously do that is causing the problem.
Comment 4 Steven Usdansky 2013-02-26 17:49:25 EST
Looks like a kernel bug, not an Xorg bug. Took the following two blocks from /var/log/messages. Note 3rd line of block using 3.9 kernel. Google results suggest this error crops up from time to time with various kernels.

3.9 kernel (fails):

Feb 26 08:25:42 Pyrope kernel: [    7.153565] nouveau 0000:02:00.0: VGA-1: EDID block 0 invalid.
Feb 26 08:25:42 Pyrope kernel: [    7.153583] nouveau E[     DRM] DDC responded, but no EDID for VGA-1
Feb 26 08:25:42 Pyrope kernel: [    7.154651] nouveau 0000:02:00.0: No connectors reported connected with modes
Feb 26 08:25:42 Pyrope kernel: [    7.154718] [drm] Cannot find any crtc or sizes - going 1024x768
Feb 26 08:25:42 Pyrope kernel: [    7.156635] nouveau  [     DRM] allocated 1024x768 fb: 0x50000, bo ffff8801108a7430
Feb 26 08:25:42 Pyrope kernel: [    7.159120] fbcon: nouveaufb (fb0) is primary device
Feb 26 08:25:42 Pyrope kernel: [    7.159987] Console: switching to colour frame buffer device 128x48
Feb 26 08:25:42 Pyrope kernel: [    7.160471] nouveau 0000:02:00.0: fb0: nouveaufb frame buffer device
Feb 26 08:25:42 Pyrope kernel: [    7.160482] nouveau 0000:02:00.0: registered panic notifier
Feb 26 08:25:42 Pyrope kernel: [    7.160531] [drm] Initialized nouveau 1.1.0 20120801 for 0000:02:00.0 on minor 0


3.7 kernel (works properly):

Feb 26 08:30:01 Pyrope kernel: [    4.673034] nouveau 0000:02:00.0: VGA-1: EDID block 0 invalid.
Feb 26 08:30:01 Pyrope kernel: [    4.673039] nouveau E[     DRM] DDC responded, but no EDID for VGA-1
Feb 26 08:30:01 Pyrope kernel: [    4.719650] nouveau  [     DRM] allocated 1024x768 fb: 0x50000, bo ffff880114c60000
Feb 26 08:30:01 Pyrope kernel: [    4.719730] fbcon: nouveaufb (fb0) is primary device
Feb 26 08:30:01 Pyrope kernel: [    4.719801] nouveau E[     DRM] no native mode, forcing panel scaling
Feb 26 08:30:01 Pyrope kernel: [    4.737449] Console: switching to colour frame buffer device 128x48
Feb 26 08:30:01 Pyrope kernel: [    4.737839] fb0: nouveaufb frame buffer device
Feb 26 08:30:01 Pyrope kernel: [    4.737854] drm: registered panic notifier
Feb 26 08:30:01 Pyrope kernel: [    4.737871] [drm] Initialized nouveau 1.1.0 20120801 for 0000:02:00.0 on minor 0
Comment 5 Steven Usdansky 2013-02-27 13:22:43 EST
Created attachment 703567 [details]
Smolt profile from working (kernel-3.7) boot
Comment 6 Steven Usdansky 2013-03-18 15:19:43 EDT
kernel-3.8.3-201.fc18.x86_64 still exhibits this problem
Comment 7 Steven Usdansky 2013-09-30 12:19:54 EDT
Have moved beyond kernel 3.8 (and will be moving off of F18 completely, as F20 alpha works well enough), so closing this bug

Note You need to log in before you can comment on or make changes to this bug.