Bug 910946 - Kernel modesetting fails; no signal to monitor
Kernel modesetting fails; no signal to monitor
Status: CLOSED DUPLICATE of bug 910945
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 19:45 EST by Steven Usdansky
Modified: 2013-02-14 10:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 10:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2013-02-13 19:45:42 EST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Identifier: 

In a normal boot with any version 3.8 kernel, when modesetting is attempted, the monitor loses the signal and never gets it back.

Reproducible: Always

Steps to Reproduce:
1. Install any version 3.8 kernel
2. Boot into that kernel
3.
Actual Results:  
Monitor loses signal upon modesetting

Expected Results:  
Normal boot

Modesetting works properly with 3.7 and earlier kernels. Onboard Nvidia GeForce 9100 graphics, Soyo monitor. Monitor gives bad EDID; but custom xorg.conf file has aleviated that problem. 
My current working config for Rawhide:
 kernel-3.7.7-201.fc18.x86_64
 xorg-x11-drv-nouveau-1.0.6-3.fc19.x86_64
 xorg-x11-server-Xorg-1.13.99.901-4.20130109.fc19.x86_64
Comment 1 Josh Boyer 2013-02-14 10:14:02 EST

*** This bug has been marked as a duplicate of bug 910945 ***

Note You need to log in before you can comment on or make changes to this bug.