Bug 91120 - system lockup if any mouse / keyboard action during cdrecord
system lockup if any mouse / keyboard action during cdrecord
Status: CLOSED DUPLICATE of bug 91593
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-18 23:21 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-18 23:21:57 EDT
Description of problem:
using Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
USB Belkin mouse
MSI KT266A MB
Memorex ' '52MAXX 2452AJ CRDW
PS/2 keyboard



Version-Release number of selected component (if applicable):


How reproducible:
everytime


Steps to Reproduce:
1.cdrecord -v speed=10 dev=0,0,0 <ISO filename>
2.touch mouse or keyboard
3.cap lock and scroll lock lights start blinking
    
Actual results:
must reboot system

Expected results:
no problems

Additional info:
Comment 1 Harald Hoyer 2003-05-19 05:53:00 EDT
if caps lock and scroll lock lights start blinking, it indicates that this is a
kernel problem
Comment 2 Need Real Name 2003-05-19 09:19:18 EDT
kernel 2.4.20-13.8
Comment 3 Mark Johnson 2003-05-22 12:13:42 EDT
     I'm experiencing a similar lockup with cdrecord, but the presence or lack
of keyboard activity doesn't seem to make a difference.  However, when using an
SMP kernel, the caps lock and scroll lock lights on the keyboard are on solid,
whereas with a UP kernel they do blink.
     This shows up the logs the instant before the hang:

May 22 10:36:30 wintermute kernel: scsi : aborting command due to timeout : pid
203, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00

     Hardware/Software Setup:

'Custom' (Built it myself) System
Asus A7M266-D with 2 1.2ghz Athlon MP Processors
Western Digital 40gig ATA/100 drive on onboard ide controller
Maxtor 200gig ATA/133 drive on PCI Promise ATA/133 controller
Digital Research 52x/24x/52x IDE CD-RW on onboard ide controller (ide-scsi)
Redhat 8.0 (with most/all redhat updates applied)
kernel-2.4.20-13.8 (redhat 8.0 rpm)
kernel-smp-2.4.20-13.8 (redhat 8.0 rpm)
cdrecord-1.10-14 (redhat 8.0 rpm)
Comment 4 Mark Johnson 2003-05-22 12:30:54 EDT
     I just tried going back to kernel-2.4.18-27.8.0 (UP), and hey, success, no
lockup.  I'll try an SMP kernal in a bit, but I'm betting it will work fine. 
Looks like something is all funky with the kernel-2.4.20-13 /
kernel-smp-2.4.20-13 rpms.  Note:  I'm using the .athlon.rpm versions.  I might
try a 386 version of 2.4.20 and see how that goes...
Comment 5 Mark Johnson 2003-05-22 13:35:52 EDT
     I just tried kernel-smp-2.4.18-27.8.0.athlon.rpm, and it works fine.  Looks
like it's definately something with the 2.4.20 kernel or the kernel rpms.  
Comment 6 Need Real Name 2003-05-22 16:16:26 EDT
I regressed to 2.4.18 and no problem.
I just put RH9 on a new HDD.
I'll tryout RH9 tonight.
Comment 7 Need Real Name 2003-05-23 10:39:46 EDT
RedHat 9 2.4.20-13.9 up-to-date shows no problem using cdrecord.
Comment 8 Need Real Name 2003-06-05 22:28:03 EDT
Jun  5 20:22:20 localhost kernel: hdd: lost interrupt
Jun  5 20:23:48 localhost kernel: hdd: lost interrupt
Jun  5 20:24:08 localhost kernel: hdd: lost interrupt
Jun  5 20:24:50 localhost su(pam_unix)[5273]: session opened for user root by
steve(uid=500)
Jun  5 20:25:59 localhost kernel: hdd: lost interrupt
I removed the ide-scsi from grub .conf and still have missing interrupts. 
Using kernel 2.4.20-18.9. 
Main board K7T266 Pro 2. 
This is a very consistant problem. I think other users of RH9 must be seeing it.
Comment 9 Need Real Name 2003-06-06 22:55:45 EDT
I moved the memorex cd from hdc (IDE1) to hdb (IDE0) controller. I still have
missing interrupts. The problem is repeatable with both cdparanoia and cdda2wav. 
I also upgraded the kernel to (Linux localhost.localdomain 2.4.20-18.9 #1 Thu
May 29 07:08:16 EDT 2003 i686 athlon i386 GNU/Linux). 
I tried a different ATAPI CD (LG) rom on IDE1 and it has the same problem. 
Has the kernel been hacked to prevent CD digital extraction?
Let me know if the RIAA has "prevented" RH9 from extracting digital music data.

Comment 10 Alan Cox 2003-06-08 09:31:01 EDT

*** This bug has been marked as a duplicate of 91593 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:53:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.