Bug 91130 - USB port alias for eth0 crashes neat and prevents use and editing of eth0 and other network devices
Summary: USB port alias for eth0 crashes neat and prevents use and editing of eth0 and...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 97466 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-19 07:31 UTC by Dr Julian Fidge
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 14:12:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dr Julian Fidge 2003-05-19 07:31:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I got a new cable modem with a USB cable.
I plugged it in and restarted my P3 running RHL 8.0.
USB network came up immediately, nice and fast.
Something created an alias for my eth0 to USB, blocking access to the eth0 port.
Shock! Horror!
I can't edit anything easily because neat crashes now this has happened.
I'm not game to edit the config files manually because I don't understand
precisely what did what to what, and I have good network access now which I
don't want to lose. Chicken!
I've added another ethernet card, but can't edit it because neat crashes
(see the neat bug reports). Bugger!
I have noted lots of similar complaints but no good answers or explanations on
the web.
Julian
Brisbane Australia

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Plug a cable modem into USB port
2.
3.
    

Actual Results:  Something created an alias for eth0, disrupting neat

Expected Results:  Expected to configure the USB port for networking

Additional info:

Warning box reads:
eth0 has an alias to module 3c59x in modules.conf, instead of currently loaded
module CDC Ethernet Class

Comment 1 Dr Julian Fidge 2003-09-01 12:53:06 UTC
Damn - same thing has happened to my P4 running RHL9!

I'm typing this in... Windows!

I've added and removed NICs and redhat-config-network says they're not there
  "card not present, initialisation delayed" if it sees them at all!

Woe is me using Windows,

Julian


Comment 2 Harald Hoyer 2003-09-01 12:58:14 UTC
first report: 
edit /etc/modules.conf for the alias... you may remove the line starting with
alias eth0 ....


Comment 3 Harald Hoyer 2003-09-01 12:59:54 UTC
For 9, try the erratum from:
http://rhn.redhat.com/errata/RHBA-2003-183.html

and please attach the traceback (very important to fix the bug) the next time.

Comment 4 Dr Julian Fidge 2003-09-02 13:09:57 UTC
*** Bug 97466 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.