Bug 97466 - USB networking reconfigures ethernet cards by creating aliases and makes them unusable
USB networking reconfigures ethernet cards by creating aliases and makes them...
Status: CLOSED DUPLICATE of bug 91130
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-06-16 08:41 EDT by Dr Julian Fidge
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot (136.40 KB, image/png)
2003-06-16 08:44 EDT, Dr Julian Fidge
no flags Details
Screenshot (156.28 KB, image/png)
2003-06-16 08:45 EDT, Dr Julian Fidge
no flags Details
Screenshot (147.38 KB, image/png)
2003-06-16 08:46 EDT, Dr Julian Fidge
no flags Details
/etc/sysconfig/hwconf file showing no 3COM card installed... (4.83 KB, text/plain)
2003-06-16 22:50 EDT, Dr Julian Fidge
no flags Details
/etc/modules.conf file showing 3 aliases - including the 3c501 (3COM ethernet card) (275 bytes, text/plain)
2003-06-17 08:58 EDT, Dr Julian Fidge
no flags Details

  None (edit)
Description Dr Julian Fidge 2003-06-16 08:41:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I bought a new Motorola SB4200 Cable Modem, which offers both USB and RJ45 (std
ethernet) plugs.
The ethernet cable works fine.
The USB cable works better, at 12MB/sec, but when I plug it in my kernel creates
an alias for eth0, so I can't use it. The actual message is reported when I
start RHL network configurator, which I've saved to a screen shot attached.
As you can see from the screen shots, the kernel thinks the CM USB is a 3Com!
It also stops the latest kernels seeing the ethernet cards...

Thanks for considering my problem, which I have seen around the net.

Version-Release number of selected component (if applicable):
RHL 8 & 9

How reproducible:

Steps to Reproduce:
1. Plug a cable modem into a USB port.
2. That's it.

Actual Results:   The kernel creates an alias for eth0, stops me seeing the
other ethernet cards, and stops me using eth0.

Expected Results:   I was expecting to have the ethernet cards left as is, and I
was expecting to have to configure the USB.

Additional info:

 Happens on all machines - P3, P4.
Comment 1 Dr Julian Fidge 2003-06-16 08:44:11 EDT
Created attachment 92420 [details]
Comment 2 Dr Julian Fidge 2003-06-16 08:45:43 EDT
Created attachment 92422 [details]
Comment 3 Dr Julian Fidge 2003-06-16 08:46:37 EDT
Created attachment 92423 [details]
Comment 4 Harald Hoyer 2003-06-16 09:04:50 EDT
maybe you should remove the 3com from your hardware device list in
Comment 5 Dr Julian Fidge 2003-06-16 22:50:38 EDT
Created attachment 92440 [details]
/etc/sysconfig/hwconf file showing no 3COM card installed...

There is no longer a 3COM ethernet card in the machine, and kudzu detected this
and unconfigured it. The hwconf file shows it is no longer configured in this
Perhaps the RH network configurator thinking there is still a 3COM card is
another bug, separate to the USB alias problem, but related???
Anyway, last time I played with RH network configurator I lost access and had
to re-install Shrike, so I'm not willing to remove it via the network
configurator again.
There is a Broadcom, onboard NIC which is NOT detected by the RH network
configurator, as I said above and demonstrated with the screen shots.
Puzzling, isn't it?
Julian, Brisbane, Australia
Comment 6 Harald Hoyer 2003-06-17 05:18:34 EDT
r-c-n checks /etc/modules.conf, uses kudzu and the ethertool interface... So, if
there is an entry modules.conf for the 3com driver...

you may also try the updates from:
Comment 7 Dr Julian Fidge 2003-06-17 08:58:42 EDT
Created attachment 92443 [details]
/etc/modules.conf file showing 3 aliases - including the 3c501 (3COM ethernet card)

This file is a little too terse for me to understand, except that it contains
some of the aliases which are troubling me including the non-existent 3COM
Is it possible to configure the USB port? I'd be game to try that on my side
machine which has been affected in a similar way.
There also seems to be a problem with both RH network configurator in that it
thinks eth0 is a 3COM card, not the BroadCom onboard card which it is, and it
doesn't see the 3COM card as eth1 when it's in the slot - so I can't configure
But this does clear up why I could see both cards in hwconf. I thought the
configurator read from hwconf...
Thanks for your interest,
Land of Oz

Comment 8 Dr Julian Fidge 2003-09-02 09:09:55 EDT
Thanks for your help. I worked around it...

I read dmesg, which says my eth1 Realtek is my eth0 and gave me the IRQ and
hardware address.

I stopped trying to configure eth1 as eth1 and configured it as eth0. It now
works and I am using it now to do this, through my smoothwall firewall :)

The Broadcom BCM4401 on-board NIC is in hwconf, but is not recognised by the
redhat-config-network (email if you want more screenshots).

I have had this problem with RH8 and posted a bug 91130 and suggest the two be
amalgamated if that's feasible.

Thanks again for your ideas.

*** This bug has been marked as a duplicate of 91130 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:56:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.