Bug 91149 - Crash with "NameError: global name 'timeout_add' is not defined"
Crash with "NameError: global name 'timeout_add' is not defined"
Status: CLOSED DUPLICATE of bug 86228
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-19 09:55 EDT by Allen A George
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen A George 2003-05-19 09:55:50 EDT
Description of problem:
redhat-config-network crashes immediately with the following message:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:198:__init__:NameError:
global name 'timeout_add'
is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined
                                                                                
Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x867dfdc>
notebook: <gtk.Notebook object (GtkNotebook) at 0x864947c>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x85f157c>

Version-Release number of selected component (if applicable):

redhat-config-network-1.2.0-2
redhat-config-network-tui-1.2.0-2

How reproducible:
Every single time.  The machine is setup with the latest RH errata.

Steps to Reproduce:
1.  Select Network from System Tools menu
2.  Enter password when prompted.
    
Actual results:
The loading dialog is displayed and followed by a dialog with the tracebacks in
it.  I save the tracebacks to a text file and they are at the end of this report.

Expected results:
redhat-config-network gui should pop up.

Additional info:


----------------- Traceback # 1: ------------------------
Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:198:__init__:NameError:
global name 'timeout_add'
is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined
                                                                                
Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x867dfdc>
notebook: <gtk.Notebook object (GtkNotebook) at 0x864947c>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x85f157c>

----------------------- Traceback #2 ---------------------------

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/exception.py:280:handleException:TypeError:
generic_error_dialog() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in
handleException
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_type'
                                                                               
                                                                             
Local variables in innermost frame:
fs: <rhpl.exception.FileSelection instance at 0x8651064>
type: exceptions.NameError
text: Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:198:__init__:NameError:
global name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined
                                                                               
                                                                             
list: ['Traceback (most recent call last):\n', '  File
"/usr/sbin/redhat-config-network-gui", line 154, in ?\n    window =
mainDialog()\n', '  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__\n', "NameError: global name 'timeout_add' is not defined\n"]
progname: redhat-config-network
value: global name 'timeout_add' is not defined
tb: <traceback object at 0x8684df4>
extxt: ["NameError: global name 'timeout_add' is not defined\n"]
version: 1.2.0
t: __init__
file: /tmp/crash
rc: -5
.0: (<class exceptions.NameError at 0x811794c>, <exceptions.NameError instance
at 0x8650fcc>, <traceback object at 0x8684df4>)
tblast:
('/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py',
198, '__init__')
out: <closed file '/tmp/crash', mode 'w' at 0x868e7a0>

(Both tracebacks were saved in the same instance of the crash)
Comment 1 Harald Hoyer 2003-05-19 10:01:13 EDT

*** This bug has been marked as a duplicate of 86228 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:53:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.